Updates for EZLogic - 1.31.1 (Ezlo Hubs only)

Updates for EZLogic - 1.31.1 (Ezlo Hubs only)

Link: https://ezlogic.mios.com
Previous: 1.30.1

1. Left side menu updates
We organazied the menu items and applied UI fixes.

2. Caching for NuCAL services
We improved loading time for NuCAL services on MeshBot page.

3. Virtual Devices page
It is possible to generate FW based virtual device.

  1. Select “Virtual Device type”. We provided 32 device types.
    image

  2. Provide “Quantity” value

  3. If you want to generate multiple devices click “Add More” button.
    image

  4. Click “Create” to generate devices.

On Device Settings page you will see generated devices. They will have “Test” prefix.
image

NOTE: It is possible, that your FW version does not include this plugin by default yet. In this case you will see the following page:


Click “Install” button and wait a little.

NOTE: the next public firmware release will include this plugin by default.

4. Toggle for Devices in Local MeshBot Actions
We provided ability to toggle device’s capability state. You can toggle boolean capabilities.

Fixes and Improvements:

  1. Fixed advanced mapping validation for Cloud Variables in Local MeshBot.
  2. Restricted 0 value for Interval in Trigger section.
  3. Fixed exceptions validation on edit MeshBot page.

Thanks!

3 Likes

I’ve been waiting for “Toggle” device state. Very useful for Scene Controller devices where you want to use a single button to toggle on or off a light or switch etc.

And the new Virtual devices UI should make creation of local virtual devices much easier for users.

Nice work !

1 Like

I’ve just setup a Meshbot rule to toggle two Philips Hue lights (Ezlo Hue plugin) and it seems to work OK. Both my lamps toggled on or off when I run the rules action.

There was the odd occasion when one of the lamps didnt turn on, so then they became out of sync though.

Will test it out some more.

cw-kid: A little thread-drift: what’s your experience in the performance of the hue plugin? I experience roughly 4 seconds of delay between toggling a light in the dashboard and the actual action taking place. The same happens if I control the light through a meshbot, while the hue app is instantaneous.

I cant comment about the Ezlo dashboard as I don’t use it.

However the toggle lights Meshbot rules and me pressing a button on my Remotec ZRC-90 scene controller, is pretty fast the lights toggle pretty immediately most of the time, sometimes there is some lag.

Well the virtual devices seem to work OK. I just created a new virtual motion sensor device using the new UI. I was then able to rename the device and assign it into a room and it also appeared OK on the dynamic dashboard page.

image

2 Likes

Just tried the create virtual on/off switch and works as it should. Very easy, no cryptic command line instructions. All good.

No excuse to not having Virtual switches in your Ezlo system now!

4 Likes

We are building the last ever smart home automation you will ever need, one step at a time!

Thank you for continued support and patience! We do sincerely appreciate it.

One slight issue here. I created a few virtual switches just to test out the capability. For some reason I cannot delete them now. Either from the web GUI or the iPhone app.

Not sure why this is an issue. I created Virtual switches with the script before and I believe they deleted just fine.

I created a virtual on/off switch successfully.

When I try to use it in an exception the “Switch” capability appears in the dropdown but when I select it, it does not populate the capability field. The field remains blank. I can select “Switch” again from the dropdown but still it does not populate the field so I can’t complete the exception.

I have tried cleaning the browser cache. Any ideas?

How did you rename the virtual device and assign it to a room? Did you use the ezlogic page or the Vera app?

hi @chuckf2 ,

it should appear correctly like this.


Maybe it is a momentary issue on cloud side. Can you check again pls.

You can use ezlogic Settings → Devices list and just click on the name of the device and type desired name for the device.

1 Like

Thank you. I never would have thought to look there.

1 Like

(post deleted by author)

I still can’t get it to work for me. I’m using the Chrome browser, which one are you using?

When I click on Switch in the dropdown it leaves the Capability field blank.