Anyone else having issues with home.getvera.com and connecting to your Vera hub through it?

Anyone else having issues with home.getvera.com gateway page and it not redirecting you to your Vera UI7 web interface? It does not work when using Chrome browser it doesn’t connect.
However if I try in MS Edge browser instead it does work. I tried clearing the browser cache in Chrome and also enable cookies for the site but still no joy.

Thanks

Hello @cw-kid

Yes, the issue was reported yesterday and our team is working on it.

We apologize for the inconvenience and appreciate your patience and understanding.

1 Like

OK thanks Jonathan. I assume the problem was reported to you by another user ?

Hello @cw-kid

Not exactly. It was happening to us too.

We will let you know as soon as we get any news.

1 Like

I am able to login correctly via Firefox from a laptop. No problems.

I have found my iPhone app is sluggish the past several months. I use HomeWave (V2.18) and the author has stopped supporting the software so it is a few years without an update. Meanwhile IoS has gone through dozens of updates in the same time. Would love for HomeWave to get a refresh.

1 Like

Yes, we are having this problem at our two VeraPlus sites - sometimes connects after the screen flickers for a minute or two.

Still cannot connect through server login and Alexa integration also isn’t working now.

There is a “work around” to fix this:

Go to chrome://flags
Search for HTTPS Upgrades and set it to “disabled” then restart Chrome.

I was then able to get redirected to my Vera UI7 web interface OK.

What the dev said

“It’s not much we can do on legacy Vera architecture.
That http page is needed in order to check if controller is still online on LAN ip to redirect to local UI as https pages cannot load http resources on any browser due security reasons. With https only as Chrome wants that check cannot be done at all without this workaround.”

So sounds like this “work around” is the actual fix for the problem then.

2 Likes

I was also having this problem of the connection in constant loop while on Chrome. Worked fine on Edge but I don’t use Edge. Emailed support. The response was “It’s a Chrome Problem”. Did not mention anything about Vera legacy architecture which IMHO isn’t a very reassuring response. I emailed back later and told them the solution so this is what I did and no longer have any issues connecting on Chrome where it would go into a relay death loop.

In Chrome navigate to:
Settings → Privacy and Security → Site Settings → Additional content settings (at the bottom) → Insecure Content

Under the “Allow to show insecure content” I added home.getvera.com

That was it. I no longer have the problem. Hopefully this works for others.

3 Likes

I posted a try below when trying to connect to interface via Chrome. My Alexa integration also stopped working yesterday. I just retried and it’s back and working for the moment!

I can’t believe you found this, incredible. thanks

2 Likes

Well done!. It fixed my problem, too. Perhaps the finger pointers should talk to each other to get it resolved. I wonder what the risk is for using this workaround.

I’m no expert but I’d imagine Google added a level of security to the chrome browser that may have required the ezlo team to update the home.vera.com credentials. Seeing as how they would most likely prefer we all switch to ezlo controllers, that support for the vera system is probably not a priority. Again. Just a guess. Google just does what they do and software companies need to keep up with the changes.

I doubt this poses much risk as long as you trust the security behind vera. You are only giving chrome permission on this one website. For me the bigger issue is the developers “fix” as stated by cw-kid. That’s indicative of the lack of time they are willing to spend to make sure vera users aren’t interrupted and their fix would have turned off an entire feature in chrome rather than to just their site specifically.

I started with Micasaverdi years ago and then to Vera Edge because there was an upgrade path requiring very little change, especially for my scenes and luup/Lua code.

A few years ago, I asked if they plan an easy upgrade path for Ezlo to which they answered, at that time, that they didn’t have plans. Vera Edge has adequate performance for my applications with plenty of headroom which Vera Lite did not have. That’s why I upgraded.

It takes years to create a customer and only seconds to lose one. They seem to have lost their investment and care for loyal customers. A possible way forward should include a scenes transfer method and a loyal customer discount. Otherwise, I can’t find a reason that I’d ever switch to Ezlo. Notice I didn’t say upgrade.

On the other hand, we could just blame the gorilla in room for modifying their browser.

Thanks for the conversation.

I’ve also been having problems logging in for a few days. The following error message then appears:

I’ll wait a bit and at some point it will work again.

Thanks, it works.

I bought new ezlo controller to play with, it worked great located from
home.getvera.com then it got “upgraded” and now shows up but “offline”

Now one of my older Vera Edge controllers is “online” but clicking connect causes the page to refresh and refresh and I get a unfamiliar URL from home.getvera.com.

I am still able to connect to several other Edge controllers just fine from the site.

I have only one controller that will NOT let me login, its having this loop problem described here in this thread.

I noticed “working” edge units will show a redirected url like this:

(https://vera-us-oem-relay12.mios.com/www/1.7.5185-en/?PK_Device=45017XXX&lang_code=en&ReturnUrl=aHR0cHM6Ly9ob21lLmdldHZlcmEuY29tL3VzZXJzL2xvZ291dA%3D%3D)

But the broken unit is redirected here and it doesnt work.
-home.getvera.com/device/gotouihttp?key=
450461871702908379658051dbcb855"

Those are very different URLS

I see others had this issue too but why is only one controller affected?
This seems like a gateway /relay issue not an issue on my PC since other controllers open right up. Just one controller is doing this.

Hello @focusedcoder

The redirection issue is related to chromium web browsers, and you can solve it by going to chrome://flags, Search for HTTPS Upgrades and set it to “disabled” then restart Chrome, or use Mozilla Firefox web browser.

Our Ezlo controllers are not compatible with home.getvera.com but you will see them listed because is used to manage the Amazon Alexa devices. Our new platform for the Ezlo controllers is available at ezlogic.mios.com

We recommend you our Ezlo YouTube channel videos to know more about ezlogic and these other resources:

I have other edge controllers that work fine, its only one so I dont see how this is a browser setting, the same browser opens my other edge controllers just fine.

You cannot use home.getvera.com to connect to Ezlo controllers you need to use MiOS Smart Home instead.

As for connecting to Vera controllers from home.getvera.com if using Chrome browser you need to change the setting mentioned in this thread.