Plugin: Bridge Vera with Ezlo: VeraBridge for Ezlo

Hi @cw-kid,

If you change the behavior you must delete the device and then restart the plugin so it gets recreated. It will not update a device category yet. I think the latest FW does support that so it is time for an update.

Also note that the supported_behaviours is just for documentation and has not functional propose.

Cheers Rene

Rene thanks I did not do this. I’ll try it again.

I used this to connect an Ezlo Plus to two z-wave plugin outlets on a Vera Plus, and noticed a couple things. 1) it takes about 10 seconds to turn on/off 2) regular mentions in ha-luad.log of “ERROR: plugin has no permissions to use the required module lpeg”

Hi,

The ten seconds can happen as you have a couple of devices at work. If you mean the physical device switches ten seconds after you change its virtual equivalent in the Vera App it looks a bit long. If you are looking at the GUI there will be some delay as the Ezlo plugin polls the Vera every five seconds.

The error message has no effect on the plugin. It just signals that the Ezlo FW is still missing some modules to make it perform faster.

Cheers Rene

Right - i click the MiOS app (Vera app doesn’t work with my Ezlo Plus recently), there’s a log line, 10 seconds pass, there’s a bunch of more log lines, and the light turns on/off.

@reneboer i have ZXT-600 on my vera plus and tried to copy the device on Ezlo Plus it was successful

I can control heat cool auto and off but when i change the setpoint it does not change the setpoint in vera

Br

This is how my Secure SRT321 thermostat now looks in the Vera app connected to the Ezlo Plus hub.

If I set the setpoint of this virtual thermostat device in the Vera app, it does send the command OK to the real thermostat device on the production Vera Plus and the set point is changed OK accordingly.

This is that TKBHome TZE93.716 thermostat device I added recently.

Whilst the Vera app is connected to the Ezlo Plus hub.

If I hit the Heat button the crappy Vera mobile app doesn’t refresh or update the GUI it still shows as being off.

If I exit the Vera app and go back in, it then shows as Heat being on and I can set a setpoint.

The real thermostat device on the production Vera Plus does then change its set point to the value I set, so that does seem to be working.

One thing I do not like, is in the Vera app / GUI, 15 degrees appears to be the lowest set point you can set.

I usually set the thermostat to 10 degrees for off, but I use Scenes to turn the heating off or on usually.

Hi @eonnet, @cw-kid,

If you can send me a PM with the ha-luad.log and Vera log I can see what is going on. Thermostats are a pain due to all flavors out there.

Cheers Rene

Did support for Generic IO devices ever get added ? I’ve tried adding one but it doesn’t then appear in the Vera mobile app connected to the Ezlo Plus controller.

},{
			"behavior": "generic_io",
			"device_id": 681,
			"name": "Kitchen Seismometer",
			"room": "Kitchen",
			"room_id": "5f4e2f82120bab1069c13c42"

As an example, I have a Fibaro Motion sensor that has a Seismometer.

image

Thanks

@reneboer

Door contact sensors and Motion sensors on the Ezlo Plus hub via the Vera to Ezlo bridge, don’t have Armed / Disarmed controls in the new Ezlo web GUI for some reason I can’t figure out.

This is a “real” door contact sensor I have paired on my Ezlo Hub, as you can see in their new web GUI it has a disarmed / armed tile.

image

However all my emulated / virtual door contact sensors on the Ezlo Plus, none of them have any disarmed / armed controls.

image

Any thoughts why this might be ?

I have tried removing this “Front Door” contact sensor from the Ezlo plus hub, by editing the VeraBridge.json file and unregistering / registering the plugin etc in SSH.

And then adding back in again the “Front Door” contact sensor etc, however this makes no difference to how the device looks in the Ezlo web GUI, I am just going to start calling it UI8 I think :grinning:

Code for this device:

},{
			"behavior": "dw_sensor",
			"device_id": 300,
			"battery_powered": true,
			"name": "Front Door",
			"room": "Porch",
			"room_id": "5f4e2fd0120bab1069c13c48"

This device does look fine however in the Vera mobile app whilst its connected to the Ezlo Plus hub.

Hi @cw-kid,

I have not looked at this for a couple of months as the API is still lacking functions to make a real plugin. This is also why the armed function is not working as the Lua API does not have functions to control a device armed status (oddly enough the hub API does). I asked for it to be added, but has not yet been.

The generic_io device is not added. Will be once I get the time and reason to look at Ezlo plugins again.

Cheers Rene

1 Like

@Oleh @oleg.macovei

Please can you read Rene’s response above about the API and armed / disarmed functions and let us know if this will be added?

Thank you.

I really hope you do, as currently you are our only 3rd party Dev for the Ezlo platform I think.

Rene

Any ideas about this one?

This is a virtual switch device created directly on the Ezlo Plus hub, using the Ezlo supported method with their Online API Tool. As you can see its just a switch tile and nothing else.

image

However virtual switch devices I have created myself on the Vera Plus and used your bridge for.

Those virtual switch devices also have KWH tiles, which I’d rather not see in the UI1 web GUI.

Thanks

image

Hi @cw-kid,

By the looks of things it seems that the tile for current Wattage is incorrectly labeled with KWh in the web GUI. That is for sure a bug for Ezlo to fix. It also looks it creates a tile for every item a device has. You would need to look using the API tool what items a device has. If that does not match, the web GUI is the one in error.

Cheers Rene

Yes that’s a bug I noticed yesterday.

These are the “items” of the VPN virtual switch that I created on the Vera Plus:

api: "1.0"
error: null
id: "1619596837358"
method: "hub.items.list"
result:
items:
0:
_id: "5f748b6e120bab105e88c407"
deviceId: "5f748b6e120bab105e88c406"
hasGetter: true
hasSetter: true
name: "switch"
show: true
value: true
valueFormatted: "true"
valueType: "bool"
1:
_id: "5f748b6e120bab105e88c408"
deviceId: "5f748b6e120bab105e88c406"
hasGetter: true
hasSetter: false
name: "electric_meter_watt"
scale: "watt"
show: true
value: 0
valueFormatted: "0"
valueType: "power"
2:
_id: "5f748b6e120bab105e88c409"
deviceId: "5f748b6e120bab105e88c406"
hasGetter: true
hasSetter: false
name: "electric_meter_kwh"
scale: "kilo_watt_hour"
show: true
value: 0
valueFormatted: "0"
valueType: "amount_of_useful_energy"

So is it the bridge plugin that is creating these watts / kwh or the Ezlo hub ?

Hi cw,

For a switch device the VeraBridge creates a device with those three items yes. At this moment the bridge does not query the Vera for the states/variables a device really has. The items are created based on a physical device. Maybe something for a future release.

Cheers Rene

OK thanks I understand now what is happening and how its working.

So likely I won’t be able to get rid of these Watts / KWH tiles in the new UI1 web GUI, for virtual switches I have created on the Vera Plus.

Hi Rene,

thanks for a great plugin. Wonder if you can help with a query I’m trying to resolve?

I’m looking to pick up a virtual switch device from my VeraPlus and to pull the latest value into my EzloPlus. Do you support virtual switches from either VirtualSwitch or Switchboard? If so, could you advise on the necessary device details to include in the VeraBridge.json file?

Thanks

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules