Plugin: Bridge Vera with Ezlo: VeraBridge for Ezlo

RGB Dimmer devices. I added two lamps which are Philips Hue bulbs connected to the Vera Plus via the AltHue plugin.

These lights are added in to the Ezlo Plus as RGB Dimmer devices OK, I now see a colour circle picker next to the device in the Vera app.

However selecting colours from this picker and the bulbs do not change colour at all. Again likely a problem with the device in Ezlo hub rather than your bridge plugin.

I then added a Fibaro RGBW device instead and that device doesn’t change the colours either.

The “heater” device doesn’t appear to show the current temperature for me, it says 0.0 C

The virtual device example Ezlo provided for a Thermostat works in that it can be added to the hub and looks like this:

Thanks again for testing @cw-kid.

Can you run the commands again and PM me the ha-luad.log file? I can see what gets send.

Cheers Rene

Run the commands again as in pressing buttons in the Vera app for these devices ?


Yes indeed.

1 Like

A new version is on github Fixes for temperature, rgb dimmer, window cov and siren.

The window cov up and down buttons do not work correctly yet in my setup due to the command the Ezlo App (Andriod) sends.

Note; if you have this running you must update the VeraBridge.json file and change the spelling for the temp_units to celsius.

Cheers Rene

Also a tip when downloading the new files from github, don’t over write your existing VeraBridge.json file or you will lose all the virtual devices on the Ezlo Hub, you have previously configured in that file, if you run the load plugin command.

I did this once and had to start over again adding in all the devices I wanted in the .json file again.

1 Like


I can confirm that for Window Coverings now the Open / Close / Stop buttons are working OK.

The Up and Down buttons do work OK for me and change the position of the blind in 5% increments in that direction, if that’s what its meant to do?

Dimmer RGB I can now change colours OK with the colour picker.

Siren for me is still not working and I cannot turn that device on. I tried removing the device and adding it again.

This is my code in the .json file for the Everspring siren device.

			"behavior": "siren",
			"device_id": 83,
			"battery_powered": true,
			"name": "House Alarm Siren",
			"room": "Home",
			"room_id": "5f4e2fa7120bab1069c13c45"

For the temperature sensors, I added this code on line #7 in to my .json file as it wasn’t present.

"temp_units": "celsius",


Yep, it’s the new behavior. Confirmed by the dev team.

I don’t like it !

For the same blind when the Vera mobile app is connected to my Vera Plus instead, pressing the Up button the blinds moves up until you press the stop button.

Likewise pressing down button, the blind moves down until you press the stop button.

However these 5% increments on the Ezlo Plus hub is totally pointless if you ask me.

Hi @cw-kid, with you on this, and did say this to the app developers.

5% on my blind it moves only some inches LOL.

Tell them to change it back so it’s the same as how Vera works. :thinking:

Me neither, I’m not sure they’ll listen to us.

1 Like

Hi Rene,

i installed the plugin and it works great for the short time that i tested it, at the moment i have included around 24 motion and door contacts that are from paradox plugin in vera, and around 35 Zwave dimmers, switches, motion, temperature, humidity and smoke sensors, and arround 40 zwave Dimmers and switches on the way.

I have one question for the community, is somebody working on a plugin for the oposite direction, to include ezlo zwave devices in vera as virtual devices?

Best regards

Hi @eonnet,

There is a bridge to include Ezlo in the Vera world but only when you are running openLuup ( It is based on the great work from @akbooer. It is not simple to do the same one Vera as there is not control over the device numbers that will be assigned. I might look at it at some point, but not sure if or when yet.

Cheers Rene

Yes i know i have tried it and tested it a while back… the reason why i’m asking for vera is because i use vera to expose some devices to Control4 and Home Assistant. I will have to go the hard way for now with sending HTTP requests to Control4 and Home assistant so i can get a 2 way comm :slight_smile:



Are thermostats still not working correctly?

I just added a new thermostat device using the “heater” device type.

No buttons in the Vera mobile app connected to the Ezlo Plus hub.

This is the UI7 web GUI on Vera:

This is the Ezlo sample virtual device for a thermostat in the Vera mobile app.

It has buttons but no set point controls.

I also added a new “co_sensor” device and can confirm that worked and was added OK on to the Ezlo Plus hub.


HI @cw-kid,

Can you try as hvac behaviour? The heater on Ezlo I cannot get working straight.

Cheers Rene

If I’ve done it correctly, the device looks the same in the Vera mobile app.

			"behavior": "hvac",
			"device_id": 597,
			"name": "Underfloor Heating",
			"room": "Kitchen",
			"room_id": "5f4e2f68120bab1069c13c41"

I ran the command to stop the plugin and then start it again after I edited the json file.

Still looks like this:


Don’t worry too much, I just wondered if it was working yet.

"behaviours_supported": { "dw_sensor", "motion_sensor", "co_sensor", "co2_sensor", "glass_sensor", "leak_sensor", "light_sensor", "humidity_sensor", "temperature_sensor", "smoke_sensor", "uv_sensor", "dimmer", "dimmer_rgb", "switch", "power_meter", "heater", "window_cov", "siren" },

“hvac” is not listed at the top in the list of behaviours. I added it, but still the same.

I also downloaded the plugin files from Github and updated them on my Ezlo Plus.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules