Imperihome Vera login

Not sure if you guys have seen this: Imperihome is no more . It seems Imperihome is getting out of business.

Hi
yes that I know, for a long time, but that does not explain why on the side Vera it does not work any more. ok imperihome is stopped, for their part, no more updates, no server or services. But the application does not need it to continue working with Vera Plus.

1 Like

Looks like Imperihome app was using an older host for our cloud endpoints, which had a redirect in place to our current hosts. The machine running the proxy had some malfunctioning hardware which is going to be replaced next week.

4 Likes

hope this is the soulution. I discover that Imperihome is running on an Android 6 device well, but not on a 10 anymore

Hi
what do you mean ? Mine worked on Android 9 and 10

What did you do that you Android 10 device is working again?
I have an old LG Cell with Android 6. Imperi is working on it

Hi
I installed the lite version 4.3.17 and the pro version 2.0.1
there is a login problem with imperihome servers (which no longer exists) that I got around by importing my last backup and then using the widget shortened to the dashboard

Imperihome is working again after re-install. Don’t know why - but happened on 2 devices.

Hi
I had the same problem on my samsung s10, forced to reinstall it to work locally …

Hi Pitt13,
where did you store your last back up and how did you restore? I purchased the 4.x version where registration is needed and backup and restore is via imperihome cloud. I have as well old 3.x apks where an account is not needed but on backup possible. There is no way by the App to restore the json file.
The way you descibed with the widget does not work if no dashboard exists.

Hi
my backup is stored locally, you have to go to Setting, General Parameter, then Export. Yes necessarily to use the shortcut to the Dashboard there must be a Dashboard created



Imperihome create the backup but before it asks for a password, it creates a zip file in which the json is located. Everything is as before it actually pays off.

Ok lets assume to install the lite version 4.3.17 and the pro version 2.0.1 on a new device. The widget “dashboard” call a board which does’t exists and stops. How to overcome/proceed.

Hi
are you using pages or the listview?
if it’s the listview it doesn’t work
you have to create a page, either the dashboard or another page, the widget will call this one

Understood, but when it is a new install - you don’t have pages yet. You have to link the vera the first time

Hi
I haven’t tried it but I think with a version of the app that doesn’t ask for a login it should work

You can launch Imperihome via its regular icon on Android if its a version of Imperihome that has no login functionality present.

Hi @cw-kid @Valentin_Grigoras
or have it repaired please ?

I’ve not heard anything new. I did ask the dev today in charge of this, but I haven’t as yet had a reply.

Ok thanks you

I found a workaround for a blank Android device:

  • Install the Imperihome 3.x apk (version before cloud)
  • Install the Imperihome 3.x apk unlocker
  • link your vera to Imperihome (same WIFI mandatory, press continue where account is asked)
  • generate an Imperihome page under the dashboard view (not the list view)
  • Install the imperihome 4.x apk
  • Install the imperihome 4.x apk unlocker
  • create a widget for direct dashboard access and you will see your dashboard
  • you have now access to your configuration
  • you can export your configuration to your google drive with code
  • restore or copy to another device - just open the exported zip file with the imperihome app
1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules