Beta feedback Ezlo Plus

there is still some way to go.
I hope we will be surprised on the next update with new features and other things that work on Vera and should be included in EzloPlus

I forgot one point:

  • IP camera support: today only their own device (VistaCam xy) is supported
1 Like

I have just thought of three more feature requests:

  • If commands are sent and not carried out correctly (in scenes for example) these commands should be repeated x-times. And If it fails there should be a notification. I had scenes with thermostat temperature settings that weren’t carried out, but I didn’t notice (some times ago my thermostats worked with Ezlo Plus). If anything like that fails or doesn’t work I want to get informed that there is something wrong.

  • I would like to have access to the log files from the normal interface. I don’t want to hack/ssh in to search the files in the filesystem.

  • When LUA programming is possible again it would be fine if it was possible to test the code and get shown where exactly is the fault (line xy). Additionally I want to see from this test what’s the output/response of the command.


I fully agree !
Want to add that the issue of “can’t detect device” on Ezlo Plus is mentioned by several testers (I was one of those) since august 2020 but it is still not solved


Finally got some time to fire up the beta controller and add a couple of devices today. The devices I am testing with is a Fibaro Wall Plug 2 and a HeatIt Z-TRM3 thermostat. Both are brand new Z-Wave Plus devices. I chose the HeatIt because its an very popular device here in Norway (the only one fitting Norwegian framing) but it has never fully worked well with Vera and it is a S2 device. The HeatIt works on Vera Edge but its ex troublesome to get included as a non secure device. My goal is to have the HeatIt control the Wall Plug to turn on and off based on temperature.

  • Setup of the controller worked fine. It was easy to get it up running and include the controller in my already existing account.
  • Including devices was fast and familiar. Zero issues including both devices and on the HeatIt I could choose to include it as a non secure device which is great.
  • First problem I encounter is that temperature is by default Fahrenheit and there is no way to change that to Celsius in the UI. I found a way to change that through the Rest API though but not optimal.
  • The second problem I am encountering is that there is no way to set up direct association between devices in the UI. On my Edge I’ve done this on a fair amount of devices due to the fact that I ex want motion detectors to turn on / off light without having to rely on a main controller being present in the network. I want the same with a thermostat and the relay controlling my water based heating. I live in a country where it gets to -20C in the winter so I will not rely on a central unit in my network to be functioning to turn heating on / off.
  • The biggest challenge is the HeatIt. It displays correctly in the UI, but its not possible to set the temperature on the device from the UI (the value is not transferred to the device) and it does not report the room temperature. The HeatIt does actually work better on my Edge than on my Ezlo beta device.
  • Another issue I noticed is that I can not name my controller what I want. The name can ex not contain a space or a special character like -. My Vera Edge can.

All in all, setup of the controller works good, but device vise I did not get to the point that I managed to get the most common z-wave thermostat here in Norway to turn a wall plug on / off.

1 Like

Thank you for you support in improving the Ezlo Platform.

To ensure all of your feedback is properly collected and put to good use please use the Ezlo Community Feature Request and Bug Tracker

It will take under 1 minute to create an account.

Once you are logged in with your account you can check what** other bugs or improvements have been reported by the community**.

You can choose to watch and be notified when an existing ticket is updated or you can create your own tickets.

If you want to share the ticket with other members of the community or post it in a thread you use the ticket’s unique URL that looks like this→


When I click that link after logging in, it shows no results (and always has). Hence, it remains unclear whether I might be at risk of submitting duplicate issues.

Do others see different subsets of previously submitted reports, or is the site designed not to show any to anyone? (Sorry if this sounds like a “bug tracker bug” report!)

Please try again, I added your user to the correct group. You should see all issues.

1 Like

Could you add my account to the correct group as well? I see no requests at all.

Done, please try again.

Works, thanks!

Thanks. I’m almost sorry I waited several months before saying anything, as I naturally assumed everyone was having the same ridiculous issue.

1 Like

I show the same. No results. Emptiness.

1 Like

Hi @Pitt13,
Can you add more details, I mean steps you passed through before it disappeared.

Hi @trygve, thanks for the description.

It’s the default setting now. In the next releases, you will have a choice between Celsius and Fahrenheit in UI.

Direct association in our roadmap and will be available in the next releases.

Do you have Heatit Z-TRM3 ?

I still don’t see anything on the site :upside_down_face:

Hello @Oleh any update on this?

I can see the monkey is pressing the wrong key…:slight_smile:
he needs to use the mouse and click here on “Requests” and then click “Ezlo Community”



It should be ok now, you should see all issues.

If there are any other people having problems seeing all issues reported in our tracker please send me a private message I and I will correct the issues.

Thank you.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules