Updates for EZLogic - 1.44.1 (Ezlo Hubs only)

Updates for EZLogic - 1.44.1 (Ezlo Hubs only)

Link: https://ezlogic.mios.com/
Previous: Updates for EZLogic - 1.43.1 (Ezlo Hubs only)

1. Settings. Customization.
1.1 Reset to default
We added ability to reset customizations to default state. You could customize your EZLogic instance without fear that something could go wrong and could reset your experiments any time in 2 clicks.

My EZLogic instance has custom logo and I hided “Group name” column on the MeshBots page.
To restore customization changes I need to click #1 “Reset to default” button and #2 - confirm it.

Note: Try to change default logo by custom: logo.png

1.2 Unsaved changes notification
If you have unsaved changes and click on another page or try to close the page, we will notify you about unsaved changes.

2. MeshBot Actions. NuCAL. Netatmo Weather Station
It’s possible to connect Netatmo account and use its methods as MeshBot actions.
Let’s check what methods we could play with.

  1. Go to Create Local MeshBot page.

  2. Select Netatmo Weather Station service.

  3. Click “Add account”. Then, we will open Netatmo Auth page, where you have to provide access.

  1. Go back to MeshBot page and you will see your connected account.

  1. You could select one of the available methods.

  2. Fill the fields and send the request by “Test” button.

Fixes and improvements:

  1. Fixed validation for Color RGB in cloud meshbot trigger block.
  2. Fixed NetatmoWeatherStation fields description.
  3. Fixed absent “rooms” on the controller case on Device Settings page.



Looks promising! However, I just tried adding my netatmo device without succes.

The behaviour is exactly the same as before, I get stuck at the netatmo ‘Accept’ page.

I get the same result as @jouked trying to add Netatmo Weather station, nothing is added.

we have a bug remaining in netatmothermostats and netatmodevices currently. It will be fixed quickly. Right now you should be able to use Netatmo Weatherstation.
@korttoma can you check your parameters against the original API page and see if it works there ?

Not sure what you want me to do. I get to the “auth.netatmo.com” page to authorize NUCAL to access my account and I can click “YES, I ACCEPT” but nothing happens.
I do use other 3rd party applications (Vera Netatmo Plugin for example) to access my Netatmo account and they are working fine.

@osman I am stil not able to add the Netatmo NuCAL. I was able to add the Google Calendar NuCAL but I am not sure how it can serv my purpose.

This is how I am now using Google calendar in my old Vera:
I have a separate calendar where I can add a whole day event and call it “Ledig”. My Vera device finds this event and then knows witch days I am of from work and then on those days it will run the wakeup routine about 2h later then days I am working. Would something similar be possible in Ezlo using NuCAL?

Hi @osman,

I am still not able to add the Netatmo Integration to my Ezlo Hub. I created a VM with Home Assistant the other day just to check it out and I could add the Netatmo integration immediately without any hustle.
HA also has a shit load of other integrations ready to go that I need like the MySensors, Hue, IKEA, Sonos, RFXCOM. I can even add all devices from my Vera hub to HA.

I am sorry but I am not sure how much longer I can wait for Ezlo to get their sh**t together.

Hi @korttoma

We are trying to improve our platform as hard as we can. And you can see frequent updates and support team feedback on multiple issues at once.
We would like to assist , do you still get the authentication error for netatmo ? Or is it another error you encountered ?

@osman the situation is still the same as a few post up from December 22. I get a new tab in the browser to login to Netatmo and accept the integration. I can click “YES, I ACCEPT” but nothing happens after that:

Could there be some clue in some log files in my system?

It is a cloud based integration so logs are not in your controller but in our cloud. I can see your serial number from our customer tickets, let us check the logs and get back to you

Can you try it one more time now so that there happens a newer log ?

@osman just did it again. There is not a lot going on in my hub so there should not be much in the logs…