Updates for EZLogic - 1.2.1 (Ezlo Hubs only)

Updates for EZLogic - 1.2.1 (Ezlo Hubs only)

Link: https://ezlogic.mios.com
Previous: 1.1.1

Features


1. Device Associations page
See: Beta - Ezlo Linux v.2.0.25.1859.1
We provided ability to manage Device Associations.
To use device associations you should check your firmware version (and update it, if it is lower than v2.0.25.1859.1) and unpair the devices from the controller and then pair them again.



Go to Device Associations (1) page.
See the listing of existing associations (2). Each row contains 2 devices, source device (3.1) and target device (3.2). You can delete (4) existing association.
To create a new association, press “+ Create New Association” button (5), then select Source Device (6), its Channel (7) and Group (8) and then Target device (9) and press Save Association button (11) or you can delete (10) this row.

Note: if you select a Source Device and do not see any other dropdowns there could be some reasons:

  1. Outdated Firmware version.
  2. Device does not support associations.


    2. Interaction Flow MeshBot
    If you use MiOS mobile app, it is possible to dynamically open specific Dashboard by some trigger event.






    Interaction Flow MeshBot based on Cloud MeshBot.
    In Actions you will see only “Dashboard” node (1) then you should select Dashboard (2) to display in MiOS mobile app and could provide “show only” (3) property, “show only” (optional) - this is the time interval during which the Dashboard will be displayed.


    3. Pulse Function
    Allows to generate a sequence of state transitions for the trigger while its children are in the True state. The function keeps True as the output of the trigger for a specified duration and then switches to False for another period and it repeats a certain number of times. The duration of True states is fixed and is always the same even if the condition of the trigger becomes unsatisfied.

Pulse function could generate state transition only Once

or Repeat trigger state transition several Times
image

Note: available from advanced_scenes/1.29

3 Likes

Since this update I can no longer seem to select existing LUA scripts in a new rules Action, nothing happens when I select a script.

EDIT: That appears to be fixed again now.

Also we need an option to have an unlimited / infinite pulse whilst the rules trigger(s) conditions remain true. This doesn’t appear to be possible in Meshbot’s currently.

image

So say my trigger is a virtual switch being turned ON, so the trigger then becomes true and then that also starts the pulse, for example I set “True For” to 1 second and Repeat for every 15 minutes.

So whilst my virtual switch remains ON then it will pulse (the rules output goes true again) every 15 minutes and the rules actions are therefore run again every 15 minutes etc.

But as soon as I turn OFF the virtual switch, the rules trigger has then become false and then this should stop the pulse sequence.

From your description above its not clear if this is how pulse will function in Meshbot’s ?

Also regarding Device Associations as soon as I select a “Source Device” I just get a blank white web page.

And is it really required to have to un-pair and then re-pair the devices again to setup a Z-Wave Association?

Looking at a Fibaro motion sensor under the per device settings options and selecting “Z-Wave Association Groups” it has correctly detected the groups on that device and I have not re-paired the device.

Although the text on the dialogue looks to be incorrect as it says Z-Wave Parameter Settings which is not related to Association Groups.

image image

Also the bottom menu option called “Z-Wave Associations” is definitely wrong as that just takes you to a dialogue for creating a new Z-Wave Parameter Setting, again not related to Association Groups and you should use the “Z-Wave Configurations” menu option for that instead.

image

And a feature request in the Controllers Settings / Information area, please make the current “Advanced Scenes” version number visible to the user for easy reference.

Currently the user has to use the Online API Tool with this custom command to find out what the Advanced Scenes version number is?

{
    "method": "hub.features.list",
    "id": "_ID_",
    "params": {}
}

Thanks

Nice to see the associations being in now. I run into an issue creating an association for a CoolCam Power plug. If I select it as a source I end up with a completely empty screen.

So initialy it looks like this

Once I select the On/Off Plug it looks like this (Yes empty screen)
error association2

You need to have hub firmware version ending in 1868 apparently. Mine is version 2.0.25.1859.1 currently.

And you need to have Z-Wave plugin not less then 1.0.880

You can use this custom command in the Online API Tool to see your plugin version.

{
    "method": "hub.software.info.get",
    "id": "_ID_",
    "params": {}
}

This is mine currently.

image

Thanks, I have the same settings. So I need to wait till it gets updated?
@maksympc , how do I get the proper firmware to make this work?

Your guess is as good as mine.

I would assume so yes, we have to just wait.

Hi, @cw-kid , @ranneman
that feature will be available to all controllers at the end of the newt week. And also we are adding a info place where you will be told that if the feature is available on your hub or not.
so please stay tuned.

2 Likes

I am no longer getting the white blank page when selecting a Source Device under Device Associations I now see this, but cannot Save it.

However my hub has still not updated to the required versions, its still currently Z-Wave plugin version = 1.0.874 and firmware version = 2.0.25.1859.1

I still feel the way “new” features are added is wrong. They must be working on all elements in the whole Ezlo “ecosystem” before you put them out to users to look at. Do not put something in the app or ezlogic unless all the backend system are supporting it. This is a major reason I stopped looking at all this for now as I wasted too much of my time just to find the implementation is not finished. This are not independent components and I stated this before.

2 Likes

Just noticed that since trying to setup that Association on that door contact sensor, it’s stopped working and now remains tripped all the time.

Tried to Rediscover the door sensor in the Vera mobile app and kept getting “Sync failed”.

I then tried unpairing the device but kept getting “exclusion process stopped”

So I then deleted the device paired it again and now the door sensor is working again and tripping when opening / closing.

Hello
I’m glad to announce that we released to live FW v.2.0.27.1916.1 for Ezlo Plus and Ezlo Secure that supports Device Association.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules