Unable to install WiFi device generator plugin

I have downloaded the WiFi device generator plugin locally. However upon install I get “An Error occured while installing”
Any assistance gladly appreciated

Its currently broken as you have discovered. They were meant to be releasing an updated fixed version.

@osman any ETA ?

Thanks.

Thank you for the info.
Ill wait for the release…

We are on it currently. Let me check the latest progress and update this thread shortly. Thanks for your patience

Good evening,
Any update on the progress of the wifi plugin?

Hi @exzavier
The issue should be solved now. Could you try again and let us know?
Thanks.

Good Afternoon @mert
I deleted the old Plug in and copied the updated version per your note. They both appear to be the same version? 1.0.5 , Story short … The plugin would not install.

Thanks in advance for your help

That’s correct, the version number isn’t supposed to change. We have done some work on plugins behind the scenes and uploaded them again.
It does seem however that this plugin is still experiencing issues, as you pointed out.

We are currently investigating this problem and I will let you know as soon as we have an update.
Thank you for your feedback and your patience.

Uninstalled this evening. Reinstalled and viola it worked.
Thank you for getting this glitch resolved.

2 Likes

Glad to hear that, @exzavier

Thank you for bringing this to our attention.

Im getting a “Failed to get file data” error when I try to install it using Manage Installations.

Maybe try a different browser or deleting your browsers cache and data.

Tried deleting it completely, then rebooting Ezlo, reinstalled from Marketplace, went back to plugins list and tried to assign my controller. Same error.

When I hit the Download button to the left of the Manage Installations, I’m taken to a blank screen which never clears.

Hi @Dan-n-Randy we’re currently investigating the problem with the plugin from our end. We’ll update you once we’ve replicated the problem.

The WIFI Device Generator plugin (Version 1.05) has been replaced by a newer plugin called "IP Device Generator (Version 1.0.8).

Currently plugins are not upgradable, so you will need to do the following.

In the Settings → Devices area make a note of any devices you created using the “WIFI Device Generator” plugin and any of their properties like their IP address Port number, username and password if required etc. Delete them using the Function button.

Then uninstall the “WIFI Device Generator” plugin and delete it from your My Private plugins area.

Note- You can keep your existing templates and re-use them with the new version of the plugin.

Next go to the marketplace and copy down the new “IP Device Generator” plugin to your My Private plugins area. Next install it on to your controller.

Note- You may need to Ctrl+F5 refresh your browser a few times if the new plugin doesn’t install the first time. (Took me 3 attempts).

Next go to the “Integrations” and “IP Devices” area on the menu to view your existing templates (or you can create a new one) and you can create again your devices using the correct templates and enter in the IP address, port number etc again.

Moving forward from this new version 1.08 I have been told that the plugin will be upgradable. Meaning you wont need to delete and recreate your devices.

I’ve just done this and the three devices I previously had working with the old plugin version are now working OK with the new plugin version, after being re-created.

For example the “Back CAM Motion Detection” switch is sending HTTP commands with an XML payload to control a setting on my Hikvision IP camera, that turns on or off the motion detection setting.

“Lounge Cam Privacy Mode” switch sends HTTP commands to IFTTT web hooks to control a consumer grade Ezviz indoor PTZ camera, and turns on or off its privacy mode cover over the lens.

And the “Test Switch” just sends HTTP commands to my local Node-Red installation to make my Google Home speaker do TTS announcements for on or off state.

image

Note- If your new devices don’t appear in the Dynamic Dashboard you may need to delete the local database. In Chrome browser I go to Developer Tools - Application. Select IndexedDB - ezlodashboard and hit the Delete button and then Ctrl+F5 your browser.

image

It should be noted that I just quoted my post from 30days ago, and the exact situation remains the same…

Hello @Dan-n-Randy

We’re currently investigating the problem with the plugin from our end. We’ve replicated the problem. In the meanwhile, please upload the attached file (this one has a different name) and let us know your results.


image

ezlo.wifi_device_generator1.tar.gz (6.7 KB)

Regards,

Jonathan Botero.
Customer Care Tier 1 Support.

1 Like

I wish I could say it worked…

I downloaded the file and had a .tar file show up in my downloads folder on my Mac

When I went to upload my custom plug-in, the open dialog would not allow me to select any files except folders.

So, it doesn’t work, because I cannot load it.

Thanks,
Randy

Hello @Dan-n-Randy,

Please try again, tap on “My private plugins” and “+ Upload New Plugin”

image

We will be attentive to your results.

Regards,

Jonathan Botero.
Customer Care Tier 1 Support.