Unable to install WiFi device generator plugin

I’m sorry I missed the balance of this project, we’ve had to wipe and go back to square one with my controller. So, I’m really back at the beginning and now I’m seeing 2 IP Device Generator Plugins in my Private Plugins list (v1.0.8 and v1.0.10).

Should I be deleting one of these? These seem to have been there once the new firmware was loaded. What should I be doing next?

I don’t really understand where to go from here. It occurs to me that the terms upload and download get confusing in this context. The list has a download button for each, and yet there’s an Upload button at the top of the page. An then, the Marketplace has a Copy To My Ezlo button… Is that the same as download or upload?

I haven’t seen much by way of instructions or demonstarations of this entire plug-in process so I admit that I’m firing a bit from the hip here. But, that’s really my point… The interface should be guiding me through this process, not confusing me more.

So, in my Private Plugins, I press the Manage Installations button on the 1.0.10 version and get an Access Denied error… (same for 1.0.8). Pressing Devices lets me know there are no device created. And going to the IP Devices menu tells me to Install Plugin and takes me to the Private Plugins page that appears to have 2 versions of the plugin already installed.

Now, I’ve used the Download button and successfully downloaded the .gz file.

Rhetorically, “now what?”

Now I went to the +Upload New Plugin and uploaded the .gz file and it says it was successfully uploaded


  1. I had to guess at what to do next. There was no guidance from the UI
  2. It did successfully upload, but pressing the Manage Installation button still gives me the Access Denied error
  3. Now I have 3 IP Device Generator Plugins on my page (1x v1.0.8 and 2x v1.0.10) and the all get the Access Denied error when pressing Manage Installations.

Hello @Dan-n-Randy

Do you mind following these instructions and let me know if you still have the “Access Denied” error when you try to manage installations?

  • Delete all the IP Device Generator plugin instances that you have copied to your private plugins before.

  • Go to Plugins > Edge Plugins and click on the “Marketplace” tab. Look for the “IP Device Generator Plugin” and click on “Copy to my ezlo”

  • As soon as this is done, you should be able to list the IP Device Generator plugin under the “My Private Plugins” tab again and manage installations.

I deleted the plugin, went to marketplace and downloaded to my elzo the IP tool and when I tried to manage it, it continues to give me access denyed.

Same here. I previously had version 1.0.8 installed and working. Today I pressed the Plugin Update button and now I have a new second instance of version 1.0.10

Currently both plugin instances show the created devices.

However I highly suspect if I now remove the older 1.0.8 instance this will also then delete and remove my IP devices, as this is what use to happen before in the past when trying to update a plugin to a newer version.

Can the Ezlo team confirm my devices will not be removed if I remove the 1.0.8 plugin instance?


To answer my own question -

All my IP device vanished when removing the older version of the “IP Device Generator” plugin as I feared. So I have lost them now.

ok let us check both the “Access Denied” and the upgrade problem
@cw-kid Service Desk

I’m attempting to create a plugin. When I try to install it I’m also getting 'Access denied".
Update: I had the sonoff plugin installed. I uninstalled it and then tried to re-install it. Also got the ‘Access denied’ response.

I installed the latest version of the IP Device Generator plugin today OK on my Ezlo Plus controller. I didn’t see an “Access Denied” message.

There seems to be an issue. Teams are on it.