Frustrated beyond belief. EZLO plus

I hope this is the right forum for this, I got the EZLO plus about a week ago after my Vera stopped working after power failure (even though had battery backup) I knew I would need to re create my network since I didn’t have a full and valid backup of any kind and I couldn’t access the old controller.

I guess I’m a moderate user, certainly no power user but I have enough devices Light control, receptacles, door locks, garage door opener and several plug in devices. I don’t have many scenes but have created enough to know my way around.

Now to the issue, I set up the EZLO and was easy enough to get it on network and recognized (web interface would be nice) I started adding switches and devices and that’s where the frustration comes in. Here is a scenerion I sent to tech support:
OK, Here is what I have done

• Unpaired front door device (worked fine)
• Paired front door GE/Jasco 14294 Unencrypted mode (told me it paired)
• On App, I can turn OFF the switch when it’s turned on manually but I cant turn on from app
• Does not show correct status on app and will not turn on
• I also tried same procedure using generic Z-Wave device and got same result

Second Device:

• I paired device using Z-Wave Smart Start with QR Code
• Item paired without issue and I assigned name (Basement 1)
• Device does NOT appear on device list
• I went to scan again thinking it didn’t take but app told me device exists

The other devices (external / plug in) seem to be working although I have not set up scenes yet. Not sure if you updated firmware or anything else at this point but you have my permission to do what is necessary

Now After trying to add a device I also get 6 NEW devices that just say JASCO BULB DIMMABLE but I have no idea where or what they are, and no they do not work.

I have tried unpairing everything and starting from scratch several times with same results. ANy suggestions would be appreciated.

2 Likes

Based on my experience UI is not really functional for proper device controlling. Use Android app. Works fine (although screen rotation does not work well).

1 Like

hey there, i have the same devices and if you can wait a couple days we want to setup a same setup you have and give a try and let’s see how we can help you.

Great thanks, and yes I am using Android app. Here is last response i received from Tech. The other devices were "smart devices and I guess the dumb down :slight_smile:

Regarding the GE/Jasco 14294: We found out that this device in specific is not in the integration list for EzloPlus controllers, so this might be the reason why it has not been possible to control it properly from the app. When a device is not integrated on our controllers, it is not possible to make sure that it will work properly.

If you want, we can do an integration request, and in about 2-3 months, the device should be successfully integrated. However, in order to this, we need to confirm how many times approximately have you tried adding the device to the controller’s network (This information is required to do the integration request properly).

Hello @peterg88,
You can also try the steps provided here for the issue with the second device and SmartStart.
Kind regards!

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules