Fibaro radiator thermostat FGT-001

Has there been any news on this, Svaleb? Did the new firmware update make this integration possible?

No.
It seems to be a Vera problem.
About security exchange.

I would not reduce to a Vera problem as Failed to exchange security keys is more of a generic pairing issue due to environment (interferences, pairing distance, pairing sequence used on the device) or many other things that can interrupt the key exchange. Most of the time this resolved by doing the pairing again, maybe at a closer range.

As per the functionality of this device after the pairing, I can’t say much as we didn’t officially integrate it but this device is on our shortlist.

@Sorin

I have had this device for more than a year.
I have tried frequently to integrete, from far to close, asked for help from support at least 2 times.
And I am not the only one.
I have even had answers from you in this tread. You said tou had “bumped” the integration and told me it followed the “bigger timeline”.
So what is the truth…?
If it is possible to integrete, tell me !

And please make it possible to upgrade the firmware from vera. I know it is possible.
Mine has FW 4.0 and fibaro has made corrections on lots of errors and is now on FW4.5.

Reply from Sorin 7 of March 2019

Re: MIOS Acquisition
? Reply #522 on: Today at 08:56:01 am ?

Quote
FGT-001 uses a newer implementation for radiator thermostats when comparing it with the existing ones in the market and requires updates to the supported command classes.

Report to moderator Logged
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

Quote from Fibaro forum :

T.Konopka @

  • Super user
  • T.Konopka
  • 1
  • 4876 posts
  • Poland
  • Gateway/s: Home Center 2
    Home Center Lite

Posted 19 hours ago

@svaleb, sorry to inform you but we are not planning to distribute updates for our modules over other controllers. At least, there are no plans on changing that in the near future.

If it is stupid, but it works then it ain’t stupid.

So Fibaro politics is NOT to update ANY device in other systems !!!
Be careful when you bay Fibaro devices maybe they will only work in Fibaro system where they can be updated.

On the 3. of april, when the FW 7.29 came out my FGT configured.
Officially it is supported supported as a generic device from FW 1.7.4453 (24 of April in vera plus).
I do not know how it works as I have had it placed on an empty peace of pipe for more than a year. The widget saying “getting manufacturer”.
Unfortunently I am still on FGT FW 4.0 (which did not work for fibaro) and it seems not possible to update to the newest 4.5 through Vera.
I have shut down the heating for the season….maybe I will find a solution before winther.

I have the same problem. I got my heat controller updated via a paid service and assuming that it was done properly, I should be on the latest Fibaro firmware… However I still have the same error … Failed at: Please wait! Getting the manufactu… Sigh

what vera firmware? I have two FGT-001 that I bought in november 2018 that have been working on my vera secure since firmware 7.30 or so.

That sounds promising! I’m running a VeraPlus system with version 1.7.4150 and says this is the latest…

Perhaps the controller was not updated properly… I’m not sure how to read the version from Fibaro but I see 3,4,61,4,5 in the VersionInfo field… Do you know how to check what version of the controller I am running?

Thanks!

I am about to purchase a Vera edge. Will it work with my existing Fibaro TRVS

My versioninfo is 3,4,61,4,4 i have no idea how to translate it into proper version number but i guess i have 4.4 (released in august 2018), and yours is 4.5

But 1.7.4150 is too old. UI7 ▾ Vera Software Update ▾ 7.0.30 - Nov 20, 2019 says that the support is added there, and the veraplus version is 1.7.4833

You need to upgrade your vera.

If you look here: How to make Vera recognize Fibaro Flood Sensor v3.3 as a flood sensor and not as Generic Z-wave device? there is some info on old versions. 1.7.4150 is 7.0.28 and it apparently won’t upgrade on its own.

Thanks Sunqan! I upgraded manually and now the device is recognised!

1 Like

Hi. I have the veraplus and it will not update to the new firmware. Is the firmware you guys are on the new beta ?

i have managed to add the devices, but the controller does not seem to adjust the temperature at all

it seems if you have the temp sensors attached, when changing the temperature, it does nothing, so I have disassociated the sensors and all is well

I really, really hate this stuff :frowning:

I have 4 FGT-001 connected to my Vera Secure running (7.31) . they mostly work. I just bough yet another one, and am unable to pair it with my vera… I do have a HC Lite, that I bought used just to be able to update the firmware on my Fibaro stuff, and it worked fine when I paired it to that controller.

I have tried to pair/unpair a number of times, the first time I did the mistake (?) of not bringing the FGT close to my vera, but it was still detected but not configured properly.
It gets stuck at the same place every time

“Failed at: Please wait! Getting the manufacturer”

It also is identifed differently - my old FGTs are identified as urn:schemas-upnp-org:device:Heater:1, with manufacturer Fibaro and Model FGT-001, the new one is urn:schemas-upnp-org:device:HVAC_ZoneThermostat:1 and manufacturer Fibar… The FGTs are different - the old ones have a hole where you stick a pin to press the button, the new one has a button you press…

I even tried to delete the device from the vera, and that failed on the first five or six attempts :frowning:

on the last two attempts, it does get a bit further, in that it shows the battery level, the target temperature and the current temperature (36,4 degrees celsius)… and oh - it is not connected to anything yet (I have to buy two adapters in order to attach it to the radiator…)

Any idea other than “keep trying”? is this a 7.31 thing (I don’t think I have had to re-pair any FGT since the upgrade to 7.31…) will “7.32” work better?

I had exactly the same issue FGT-001 v4.4 pairs OK, but v4.6 does not. I contacted support who took a few days, but then came back with this…

" Thank you for your patience, checking our integration details we can confirm that the version we used was 4.3 we do not have more versions tested, nonetheless, a firmware version generally is not a problem but in this case maybe Fibaro changed something that could potentially be the reason why the device is not adding properly.

I would recommend the following:

** Exclude the device from Vera*
** Factory reset the device*
** Reboot the Vera controller*
** Try to add the device once more either using the FGT-001 wizard or the Generic Z-Wave option*

Or try to contact Fibaro to see if downgrading the firmware is possible in this device."

Needless to say, this doesn’t work.

I did manage to get it working… Cw-kid put me on the right track when he asked about manufacturer info…
See

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules