Beta feedback Ezlo Plus

Yes, its the build we released yesterday and has integrated Temperature Scale Settings. The default scale is Fahrenheit now.

@ranneman, thanks for description.
We are checking this issue with app teams.

Also checking this issue with app teams.
For now the best way is to use API requests.

1 Like

I just tried adding a GE3010 in-wall smart dimmer to my Ezlo plus, with the following results:

  • First attempt was just scanning the barcode from the device. This appeared to work perfectly - except the device never actually showed up in the devices list. Fail.
  • Second attempt, I found the GE3010 in the add devices list, and ran through the wizard. It detected the device, started to add it, then asked me to scan the barcode. Which would have been fine, except it didn’t activate the camera so I could scan the barcode. Then my finger slipped, the app somehow wound up at the Alexa VOI screen, and I couldn’t get back to the add device screen (though the top of the app still showed a blue bar). Fail.
  • Third attempt, the device apparently had actually added after the second attempt, but didn’t appear to be functioning as expected (see issues below). On the thought that I had messed up the adding, I removed the device (which worked as expected), then went through the wizard again. This time it added as expected, and showed up in the devices list. Success!

Well, mostly…

A couple of issues still remain:

  • when turning the light off from the app (using the on/off switch), the light does turn off as expected. However, the app shows 66% dimming and “on”.
  • Telling alexa to “turn on the lavatory light” or “turn off the lavatory light” gives a “Lavatory light does not support that” response - clearly incorrect. Asking for a specific dim level does work, however, EXCEPT:
  • Requesting 0% from alexa (turn off) results in a “Lavatory light is not responding” response from Alexa. Even when a request for 1% five seconds earlier - and a request for any other level immediately after - works as expected.

So, all in all, not a great experience. Would it make sense to exclude the device and try again from the top? I’m not hopeful, but I could certainly give it a shot if it might help.

Forgive me if this has been asked. I tried searching but the search here drives me nuts sometimes. :sweat_smile:

But can you trigger a scene on this Ezlo Plus from the lua of another controller?

Looking to test some odd scenarios here. I’m sure you can’t bridge this controller as a slave to the VeraPlus. So how can (if you can) trigger a scene within the Ezlo Plus using the VeraPlus (as two separate hubs)? So that one scene in the VeraPlus can cause the Ezlo Plus to be able to trigger Alexa to do something to go along with a scene already prepared and complex with lua in the VeraPlus.


VeraPlus: Scene1 = Turn off lights, turn of screens, shut down computer, close the shades, turn off electronics, send lua code to trigger Scene2 within Ezlo Plus…

Ezlo Plus: Scene2 = Tell Alexa to set accent lighting (LED tape) to a different color and fade to 50%

The accent lighting in this scenario would be only accessible from Alexa since it isn’t Vera compatible directly.

So far, that’s one of the best test scenarios I have half set up to test this method with, just waiting on creating the second half within Ezlo Plus and the ability to link the two scenes. I have a few other scenarios I have created to test as well standing by :slight_smile:

check out @cw-kid guide.

1 Like

Current status of my setup:

  • no Firmware version shown in the app
  • Eurotronic Spirit thermostat shows only a TRV symbol without temperature and without the possibility to do anything
  • Aeotec Multisensor 6 is missing the motion sensor, all other sensors don’t show any value
  • Fibaro Smoke Sensor 2 don’t show the temperature
  • yesterday I got a few messages about devices don’t detect smoke anymore or changed mode to heat:

When will this things be fixed so I can start serious testing?

ElCid, you nailed it! So many leaps through hoops to get a simple task done, but it works. VeraPlus scenes are successfully triggering Ezlo Plus scenes, in order for Vera to be able to reach out to Alexa for sending it commands. So far, I have created some really messed up scenes within Vera, setting timers (so Alexa commands don’t overlap too closely) within lua to trigger Alexa through Ezlo using multiple wget commands, and everything seems to be passing properly and triggering Alexa properly.

If only there was a proper plugin or something else that can create an official handshake between devices without having to get a ras pi and APIs involved or having to dumb down security to pull it all off. The idea of bridging controllers is nice, but between Vera and Ezlo, this definitely lacks user-friendliness for the average person.

Well…that ends that test scenario. I’ll try to think of some other crazy things to stress the Ezlo out with lol


There is a vera bridge for ezlo plus by @reneboer

1 Like

I’ll have to poke around with that. I’ll have to see if scenes can trigger both Vera and Ezlo at the same time in order to trigger Alexa while also maintaining the original scene on Vera.

Update. I gave up on that idea for now. Sticking to the Vera scene to Ezlo scene trigger option for now. The more I want to mix-match between the two to get creative, the more I run into “crud, I need lua for this idea, but on Ezlo” or “crud, I wish Ezlo had a plugin screen to easily get my common plugins like Switchboard and such”.

In the end, I keep running into a single scene “If try any of this → put foot through wall”. Been playing with Hubitat lately because of it, but don’t like the interface. I don’t know if I trust the lifespan of ST right now due to their changes. Might experiment some with HomeSeer. After so many years of having so much flexibility with the Vera hubs, being suddenly forced into using an app with limited functionality is a bit rough to handle.

I like to have a scene that only runs between 6:00 AM till 9:00 AM and is activated by a motion sensor. Any ideas on how to do this?

@Oleh, can you comment on this? I’m really curious whether you have plans to extend the current scene logic options? If so can you please update us on the planned options and timeline.

Vera’s native scene supports this. Create a new scene, select your motion sensor as the trigger, and select the trigger conditions. Now select the clock face, check “restrict the trigger to certain times” checkbox and set the time range. You can also do this with Reactor.

1 Like

Thanks I’m aware of Vera and Reactor solution. But I’m asking for the Ezlo Plus. In my android app I cannot see the time restriction option.

1 Like

From time to time I receive notification “no longer detected” from sensors , while I have never received notifications “detected”. It is also unclear how to hide from Alerts the information that the scene is fired.

Same here. Perhaps this happens after a FW update was done? Seems like the current status of every device is sent via notification.


Feature request: Get a notification when a new firmware was installed (and later if a new firmware is available).

This would help in case of circle a bug like that.

I have a problem connecting to my ezlo plus, dozen times a day i receive the following when i open the app

It stays like that all the time if i leave the app open for 1 hour it will stay like that and i cant control anything. If i go to my controllers logout and login again it connects and its working ok. This happens regardles if i’m on lan or internet. @Oleh @melih any info?

Hi @Odysee, thanks for the description.
Created ticket for this case and we are checking these devices.

@ranneman, for this case you can use advanced scenes. It is already available.
Let me send you an example.

@Mobilniy, can you clarify please the p/n of the sensors.

@eonnet, can you add more details please.
Its IOS, right ? What is the version of the app ?

Yes IOS latest beta vera and mios it happens same with both of them, this has happened on the previous betas also but i thought that was a problem with the controller because i manually rebooted the controller previously and i didnt use the controller that much. But last couple of days i’m using it more frequent and i noticed this.