Alexa can no longer run VeraPlus scenes?

I recently dropped everything from Vera and moved it to something else. Then I started added certain devices back for testing purposes. I added the skill back to Alexa, but I see the original devices were still there causing duplicates. I had to manually one by one remove them all. Then I added everything again added the few devices back. Then Alexa could control the devices.

However, now Alexa won’t control any scenes. Claiming they are all “not responding”. I double checked the alexa list within getvera.com and even went to https://alexa.amazon.com/spa/index.html#scenes (which apparently is the only place you can view/delete scenes now within Alexa’s side since the app doesn’t give you this. It listed some old ones in there, so I deleted everything and hit discover. The new ones pop right in. Yet, still, “not responding”.

I even created a simple scene (manual run) that simply turns a light off, and then turns it back on 6 seconds later). Still “not responding”.

Does Alexa no longer have the ability to control scenes within VeraPlus controllers?

Hello, @TheSaint

Alexa should be able to run the scenes you have in your Vera Plus controller unless the scenes operate security devices such as door locks, blinds, or a garage door opener.

If you haven’t already tried this, I suggest you do so, which is logging to alexa.amazon.com → Go to Smart Home on the left menu → DevicesRemove All

Then, back to Smart Home on the left menu → ScenesRemove All

Finally, Go to Skills on the left menu → Your Skills on the top right-hand side of the screen → Vera Control → Disable the skill and Enable it again and rediscover devices by accepting on the button to discover devices or telling Alexa to discover devices.

If the above does not result in fixing this issue, please, open a support ticket by sending a message to support@getvera.com. There could be an issue with your Vera Plus that could be causing this.

Best regards.

1 Like

As per the first post, I technically did all of this. I won’t go back into it since it is already stated in detail in the op. However, I did it your way. I skipped doing devices as I have a LOT of other devices in there from other hubs and devices. So I only did remove all in the scene page. HOWEVER, the fracking thing deleted ALL of my devices anyway (along with the scenes). So that wasn’t the ideal solution as Alexa features quite the complex setup around here. I continued on to drop the skill and then re-enable it. It took me to the Vera login, then Vera’s Alexa setting screen, then I rediscovered and it found the Vera devices and scenes.

However, it still claims all Vera scenes are not responding. Most of these scenes are the same scenes that have worked since Alexa skill was first added. Some changes to a few and the additional of the simple test scene I described in the op. None of which have (in the past) or should be blocked by Alexa’s limitations on security (which I am fully aware of).

Now, on top of that, I am missing over a dozen devices from other hubs/devices thanks it removing everything and ALL of my created device groups within Alexa have been deleted because of the devices being deleted (all of these groups were associated with non-Vera devices). This move just set me back quite a lot of time in having to rebuild everything. I came very close to chucking the VeraPlus at the wall this round sadly. Not in a good place right now.

1 Like

Hello, @TheSaint

I’m sorry to know that after deleting all and enabling the skill again, Alexa still couldn’t control your scenes, now, it got even worse as you now have to re-add all the lost devices and configurations lost on the Alexa app. Please, open a support ticket and we’ll have a look at what’s wrong with your Vera Plus.

Best regards.

1 Like

I just looked at my scenes in the Alexa app they all state “Device is unresponsive”.

I tried a few voice commands to run a scene but Alexa says sorry I don’t know that one. I’m not sure if I was using a correct voice command to run a scene.

I then created a routine in the Alexa app to run a scene when I said “Run test”.

The Vera scene I selected in my routine turns on my TV.

When saying to Alexa “Run test” my Vera scene was actually run and the TV did turn on, so that part seems to be working at least.

But not sure why all Vera scenes say “Device is unresponsive” in the Alexa app.

I could see one scene that was from my Ezlo Plus hub and that was the only scene listed that didn’t say “Device is unresponsive”.

“curl test” is an Ezlo hub scene, all the others are Vera hub scenes.

Email sent image

@TheSaint Thank you for opening the ticket, we will get back to you on that promptly.

@cw-kid If you like, we could also check what’s happening there. Feel free to open a ticket as well.

Best regards.

It never occurred to me to check Google during all of this. I was able to confirm that Google can control both devices and scenes just fine. So this does seem to be isolated to just Alexa. I wonder if it might be something to do with the Vera skill in Alexa. I tried the URL to the log to see if there was any mention of Alexa or the scenes attempted to run. All sorts of mentions of both but none of it looks as though it matter (mostly looks like it updating its own information, checking for changing, polling, etc–at least, that’s my guess). Nothing that states communication attempts between the two.

How do you run Vera scenes via Alexa?

A voice command? If so which phrase are you using?

Or are you using Alexa Routines to run the Vera scene?

I have a scene called “Heating On”

I asked Alexa via voice to “Run heating on”

She said sorry it wasn’t responding, however the Vera scene to turn on the heating was actually run.

Seems to be some cloud to cloud latency here.

@Mayker

I dont use Alexa. I have Google Home speakers primarily.

But your welcome to open a ticket on my behalf and have a poke around my Vera account if required.

I do have a different current issue with Google Home and Vera integration here however, which Oleg is looking in to for me I believe.

Hello @cw-kid

Yes, generally that’s the way you run scenes through Alexa, for instance, “Run Kitchen Lights”.

I would kindly suggest, just to troubleshoot to uninstall the skill and install it again, also have you notice high latency in your Vera when executing scenes or turning lights through your SmartPhone?

No I have not notice high letancy, everything controlled via the Vera app seems fine.

Hello @cw-kid

Please try to remove the skill and add it again, if the issue continues we’ll create a support ticket to continue the troubleshooting and replicate the issue.

OK I will if I have time.

This isn’t the first time this same problem has been reported on the forum about Alexa devices and scenes being marked as unresponsive.

If you search the forum for those keywords you will find the other threads.

@Leonardo_Soto

OK I disabled / unlinked the Vera skill in the Alexa app. Then logged into my Amazon Alexa account in the web browser and removed all devices and scenes.

I then relinked the Vera skill in the Alexa app and discovered devices again etc.

Looking at Vera scenes listed in the Alexa app they still all say “Device is unresponsive”.

I then asked Alexa to “run {scene name}” and she says in response “Sorry {scene name} is not responding”.

However the Vera scene is actually run OK anyway regardless.

When deleting the devices in Alexa are you bulk deleting them or deleting them individually.

I deleted everything by removing all.

@TheSaint

So are you not able to get the Vera scenes to run at all via Alexa?

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules