Aeotec ZW095-A - Z-Wave Plus - Home Energy Meter Gen 5 - No Data Reported

I recently purchased the Aeotec ZW095-A - Z-Wave Plus - Home Energy Meter Gen 5. I understand that this device may be limited to Watt/KWatt readings on Vera Edge or Vera Plus. However, I am having trouble getting this device to work and appreciate any insight anyone can provide.

Inclusion accomplishes perfectly. I see two clamps plus the Energy Meter as a device. But the device shows continues 0 reading and doesn’t appear to be updating. All the settings are default for 101,102, 103, and 111. Any thoughts?

Try using one clamp ( 1 Phase) and see what happens.


I have a 4-wire EU Gen 2 but it looks the settings are identical. So this is what is working for me.

Cheers Rene

It may be your current transformer(s) are oriented the wrong way. This gen5 meter, depending on mode, will read 0.000W for power flowing out of the CT compared to power flowing in. Flipping the CT(s) around can fix that or change the power monitoring mode to see + and - power readings:
See my post in this section:

I see that AEOTEC has launched a new version of this device. I will try to buy one and test it this week. I will update here our experience.

here is the one I am planning to purchase today

For anyone getting a lot of CRC errors when included securely, I’ve been finally able to stabilize the Zwave network by issuing this command:

luup.call_action(“urn:micasaverde-com:serviceId:ZWaveNetwork1”, “SendData”,
{ Node=‘61’, Data= “x70 4 13 1 0”}, 1 )

Where Node = ‘61’ is the altid (not device number) of your HEM Gen 5.

This will set param 13 to 0. Straight from the manual

Enable /disable reporting CRC-16 Encapsulation Command. (0 ==
disable, 1 == enable)