"Waiting Initial Data" after initial installation

Hi all,

Being fed up with Vera issues as anybody else here, I decided to explore openLuup, installing it in my 24/7 mac mini running macos.

I installed the whole thing, Lua5.1, luarocks, libraries, etc, installed openLuup itself and tried to fire up the AltUI server by going to http://x.x.x.x:3480. Guess what I got: “Waiting Initial Data”. It did not load any bit of the interface, nada, zilch. Just those cold words, highlighted in red.

These are my first steps in both AltUI and openLuup so any help is very much appreciated… I did ran search on this here but I couldn’t see any case like mine, i.e., initial installation case.

This looks like more of an openLuup issue than an AltUI one.

Can you check that you can access openLuup directly, rather than through AltUI by trying


Yep, that works. It shows a page with license info, doc, version, etc.

Ah, that was just the about page. There’s a menu and I have 4 devices: openLuup v19.12.27, Alternate App Store v18.6.28, Alternate UI v2.47 and ZWave (just a placeholder, I think, haven’t explored the manual yet)

You need to look at the manual and install VeraBridge to connect to your Vera, and then transfer the device files. It’s all explained there.

But, AltUI should work already…

TBH I never even got that far.


Wimp. :wink:

What stopped you?

1 Like

Couldn’t even get the modules installed. Although it was on a very old OS using Darwin Ports


Yep, I know about the Verabridge to connect to my V+, but the AltUI thing is baffling me…

Can you send me the startup log and the current log from the openLuup menu pages?

Also try clicking on the icon at the top left of the openLuup page.

Just PM’ed a zip with the 2 logs. Thx!

Clicked the icon, same result “Waiting…”

suggestion : check what is in the chrome javascript console in terms of messages, …
open the page , clear the console mesages, force a refresh , copy paste the console messages to share them here …

I see an error in the openLuup log at AltUI startup:

2020-02-11 22:09:54.816   openLuup.servlet:: file not found:J_ALTUI_loc_pt.js

Yep, there’s that error. Will have to check where is that file but no time now. From the name, it appears to be a localization file for Portugal, is it? @amg0 could it be that the ALTUI installation does not have that file?

Try to add &Lang=en on the url
Browser must be in Portugal mode and searching for the localization file which does not exist ( open to contributions here … )
Normally it should be an optional file but I need to check

An alternative is to copy the _en file and make a _pt file…

Is your machine’s locale set incorrectly?
Try this from the shell…

echo $LANG

My (UK) result is…


I’m in Portugal and the region of this mac is PT. BTW LANG is not an env variable in macos.

Anyway, I’m away and am unable to check anything.

Well, that would explain it then! :grinning:

Interesting, because that result was from my Mac.