Video: Recover Bricked Vera plus

ask support they have it but they dont want it to be publicly posted

If anybody can PM me the Edge .bin file that would be appreciated (and the Secure one too if possible).

I reached out to support twice now specifically asking for them … the first time they replied asking me to enable remote access and the second time they just pointed me to the downloads of the normal .squashfs firmware files.

just reach out to support they have been very helpful in the past. just dont post it on the forum


I have same problem with my vera plus it’s totally brick. When I plug wire lan w to router i don’t see IP adres and MAC adress and i can’t connet ssh or telnet.
If you can help me. Please share me firmware for vera plus in bin format and explane me process flashing new firmware.
Sorry for my english

Thank you very much in advance.

The best is to Opener a ticket at support. They can then fix it .
/ Mattias


I agree with @Matteburk ,
I would not take that risk if you are not very comfortable and versed with the video, I would not take the risk to proceed. Please let CS do it for you.

1 Like

first open a ticked with support, hate to say it but, it is he best option

I did as the @Matteburk recommended.
I created new topic on site At first, I saw some interest but for four days I have not had any reply from support site. I don’t know what to think about this.
The warranty on my controller ended 3 months ago.
I don’t know how they can help me, because when i plug my controller to my router do not see IP adres.


Yesterday I recovery firmware using instruction from vera technical support. Unfortunately after operation recovery firmware I can not connect to the getvera site ( my controller is not detected). When I try open vera control panel on the controler via web site ( controler connected directly to pc) loading is only logo Vera and proggress bar and nothing else. After few minets the display return error connection messadge.
Can you have any suggestion what I wrong or how fix it ?.

After plug in power adapter and wait about 3 minets all LED’s on controller is on stady.

Thank you.
Best regards

I’d go back to support. They’ve not fixed it in any way that I understand the concept


1 Like

Ok, I wrote to technical support.

Maybe the problem is in firmware which i have recived from technichical support ?.
Mayby someone has working and tested of firmware for controller VeraPlus in *.bin extension ?

yes the extension is .bin that is the full firmware file, what exactly is your system doing

Currently my controller starting properly (that i think so). After plug the power adapter and wait about one minute all LED on the controller is on. My controller is not automaticlly found when i try add my unit to account on vera site. It also doesn’t help when I try manually addeded my unit. When I directly connected PC to controller i see IP adres and i will connect via SSH. When I try open site of the controller in the web browser opens is only page with logo Vera and progress circle bar and nothig else.

I also noticed when power adapter is plug to controller and internet is on more than about 20 minets LED Power and Bluetooth is start blinking.

On the controller is currently installed firmware from file: G450-125-1.7.4125.bin

ok so all the lights are on, are you connecting an Ethernet cable directly to the controller or is it connected to the network?

Use an incognito browser to open the vera page. that looks like its cached data if you see the green spinning wheel

Yes, after connected directly Ethernet cable or directly connected to PC all lights are on.
In incognito browser mode nothing changes. Page still freezes on green spinning wheel.

connect the vera back to your network and look for the IP. it may have changed

The IP has changed, but web page is still not loading correctly.

ok try to ssh with the new ip

Okay, I’m connecting via SSH to the controller, but I don’t know what to change to fixed my problem.

seems like ip, to factorty reset VIa ssh type all