Video: Recover Bricked Vera plus

Yes it was bricked no ssh no telnet nada
P.s Forgive my feet
you can try with Vera edge as well
I am not in the mood to type instructions b/c I have been working on this for 2 weeks almost

and excuse my feet
you can try with vera edge or vera plus

if u do extroot … do it after the firmware upgrade

you need to reach out to Vera support to get the firmware .bin file

Part 2 at minute 5 start the factory test procedure you and need to press each button one time (all 3) and then the led state power to bluetooth and back representing the success of the factory test and need a manual unplug and plug for ready to use @edward

thanks to @edward… he was instrumental, could not have done it without him. literally, he was great


very impressive! Congrats on bringing it back to life! thanks for this, seems to have been a bit of a well-kept secret that the old Lite / 2 / 3 firmware flashing utilities would work for the newer models!

Managed to unbrick a couple of Pluses I had here … did you get yours up and running fully?

yup neat little trick, trying to figure out how to do the Tftp transfer without using the tool

I have an old XP PC that I keep just to run these ancient utilities for my old Vera 3s. They saved me a few times after unsuccessful firmware updates (ran out of memory during the update). Support for Windows XP finished April 8, 2014

The old utils have that hacked together look, that you used to see out of HK, Taiwan, etc factories for various stuff. So may be the factory was the only one to have the source code?

I would really like to see contemporary versions of the utils provided, so I can chuck the old XP box.

The same Vera3 util works on the V+ and Edge you just need to get the raw firmware .bin files im assuming it will work on the protect as welll

ps. Xp-mode virtual box vm works i tried it today just need to passtrough the NiC

Successfully recovered a vera edge running XP on a VM from my NAS. Now going to try the pluses…

Edit: And 2x VeraPlus Recovered! I can work on extroot next. Took 2 tries on the second vera plus. The first time it seem to be failing the factory calibration step ending up with power and bluetooth flashing.


Hi @edward,

Can we get the bin files loaded to the Wiki just as are availble for the 3 and Lite please?

Cheers Rene


Just one odd thing with the edge after I used the 4150 image is that I could not update to 7.0.29 (4352) as the device report its self to be a “vera4lite” and teh firmware was for an mt7620. May need to look at this. It is likely some files not set properly in /etc or /www. I was able to upgrade to 7.0.30 from the detected new firmware action though.

VeraEdge-133-1.7.4151.bin is what i used


Same one I got. It is fixed now that I am on 7.0.30 I think.

1 Like

ie. If u use vera lite firmware to flash a vera plus

ok cool 4150 is what i have for V+

richie.d, have you tried this with the Sigma Z-wave Programmer?

Just hope the the standard user is not going to attempt to flash firmware on their units based on the above posts. These instructions should come with a Vera health warning, not to be used by the uninitiated. I’ve seen so many electrical doorstops created as a result of firmware flashing.

Though I agree that this should not be taken lightly and can make forever bricks, remember that the units which go through this process are already bricked. Without this process, they are already doorstops… Not much to lose.

@zedrally, I use the pc programmer frequently but it is for a USB dongle, not for the vera.

1 Like

There’s nothing worse than using a bin file to do a firmware flash to find later that the person who pointed you to a bin file download link realized that it as the wrong bin file.

Yes, that’s what I use it for as well, but it has an OTA output and thought it might be useful.

As far as bin files go, unless it comes from the Vendor, I’d be hesitant to use it unless it’s a last resort., which in these cases it is.

Really wise advice. It’s unbelievable the amount of Broadlink devices I’ve seen toasted as a result of the incorrect firmware being flashed on them. It’s usually as a result of people providing incorrect download links for a particular model. Probably doesn’t help that the manufacturer doesn’t properly support their product either in the case of the Broadlink. What a shock too when you’ve finished flashing the unit to be presented with a screen full of Chinese writing :joy:

im going to test it and see if i can get the plus back

Is this downloadable anywhere?

I have an Edge to try and recover :slight_smile: