VeraEdge Bridging Together

tried originally with Terminal on Macbook Air, then PUTTy on a windows VM this am (UK). No success then used WinSCP to get to the /etc/config/network file, altered the LAN IP address to 192.168.82.2 saved then rebooted my Vera Edge and the Veralite. Success altered the LAN address on Vera Edge the added UPNP device and found VeraLite. The two are now bridged!! Thanks for the info to start with, I am more confident dealing direct with files than with the command prompt these days.

Awesome stuff… Sometimes it’s about the information you gather from someone else, rather that how they did it…
Glad you got it working also!!

Tiaanv!

Can this IP change method working vith Vera Edge UI7 and Vera Edge UI7 ?

[quote=“slajgaj”]Tiaanv!

Can this IP change method working vith Vera Edge UI7 and Vera Edge UI7 ?[/quote]
Yes. Exactly what it’s for.

Sent from my SM-G900F using Tapatalk

[quote=“tiaanv, post:18, topic:184813”]Ok. After putting some unrelated info together I have managed to bridge two Vera edge units together… and yes… it works!

Based on info in this thread we could establish that the main issue is that the Vera uses the “LAN” interface to discover other Vera devices via uPnP. The only issue is that the LAN interface IP addresses for all Vera edge devices are statically set at the factory to 192.168.81.1. In the older devices you could change this… On the new Vera Edge you can’t… Well, maybe you can! :wink:

SO I started digging around an came upon another unrelated post in a random thread about how to do some weird stuff with the wireless on a Vera 3… I put on and one together, and presto…

The Steps:

1. You need to SSH into your vera (
either of them will suffice. Only do this on ONE of them), using putty or something similar. You’ll also need your vera’s root password, or temporarily enable remote support, and use those details. there is enough info available on this… Google is your friend…
2. You need to run a couple of commands:

[ul][li]uci set network.lan.ifaddr=“192.168.81.2” (this sets the LAN interface’s IP address)[/li]
[li]uci commit (this saves the changed settings)[/li]
[li]cat /etc/config/network (just to review that you changed the setting correctly…)[/li]
[li]ifconfig eth0.1 down (this will “down” the LAN interface. We do this to re-load the settings in a moment)[/li]
[li]rm /var/state/network (this clears the network cached settings)[/li]
[li]/etc/init.d/network restart (restart the network)[/li][/ul]

3. After doing the above, You need to restart BOTH your Veras so that the uPnP service restarts it’s discovery.

That’s it… Fully functioning Bridging…!!!

Warning!!! I have NO IDEA if this will leave anything broken… So far, for me, it’s working perfectly, but don’t blame me if this has any negative after effects… at OWN Risk![/quote]
Hello. i tried with Putty from Windows but i received this error:
uci: Parse error (unterminated ') at line 17, byte 31

so, i tried with rbrowser by mac editing the file /etc/config/network file, altered the LAN IP address to 192.168.82.2 saved then rebooted my two Vera Edge but now in the net setting inside the web panel of the edited vera edge i have the field always in dhcp (??? not setted it anytime) and the other important field like 192.168.81.1…empty…!

See the image:https://www.dropbox.com/s/x3xek7llpzkxqif/Vera%E2%84%A2_%E2%96%BE_Smarter_Home_Control.png?dl=0

Rebooted it and try to control with rbrowser. the file is the corrected, i think, modified before:

config interface 'loopback' option ifname 'lo' option proto 'static' option ipaddr '127.0.0.1' option netmask '255.0.0.0'

config globals ‘globals’
option ula_prefix ‘auto’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr '192.168.81.1?
option macaddr ‘94:4a:0c:08:4b:ba’

config switch_vlan
option device ‘eth0’
option vlan ‘1’
option ports ‘4 5t’

config interface ‘wan’
option ifname ‘br-lan’
option macaddr ‘94:4a:0c:08:4b:ba’
option proto ‘static’
option ipaddr ‘192.168.101.101’
option netmask ‘255.255.255.0’
option gateway ‘192.168.101.1’
option dns ‘192.168.101.1’


Naturally…or better to use unfortunatly the two vera aren’t bridged. The problems could be that the second vera is in other subnet? I must forwarding any other ports for this? upnp ports (i dont know what are the upnp ports)
thanks
Can anyone help me?
Naturally...or better to use unfortunatly the two vera aren't bridged. The problems could be that the second vera is in other subnet? I must forwarding any other ports for this? upnp ports (i dont know what are the upnp ports) thanks Can anyone help me?

Open up the subnet to allow it…

Change 255.255.255.0 to 255.255.0.0

Sent from my A0001 using Tapatalk

No need to change the subnet. The screenshot attached. Shows the normal net settings. Further down you will find the “LAN” settings. This ip is on a different subnet. As long as both veras are on the same subnet it will be fine.

Sent from my SM-G900F using Tapatalk

[quote=“tiaanv”]No need to change the subnet. The screenshot attached. Shows the normal net settings. Further down you will find the “LAN” settings. This ip is on a different subnet. As long as both veras are on the same subnet it will be fine.

Sent from my SM-G900F using Tapatalk[/quote]
Ya but he may have a reason he’s on a different subnet

Sent from my A0001 using Tapatalk

i have the second vera on different subnet because i have located in a different building near my home connected to my primary lan with point to point by nanostation ubnt. for better use all other equipment that i have installed there, i need to use subnet. so for see for example the webserver page of the second vera, i have port forwarded her port because my first lan is like a “internet world” for the subnet connected by wan.

But about the error and the page of second vera that now are with the empty field? always if i rewrite inside them, after save…same situation.
any chance to fix:
uci: Parse error (unterminated ') at line 17, byte 31
?

thanks for all

I must procede to reset the vera?

[quote=“filippodei”]i have the second vera on different subnet because i have located in a different building near my home connected to my primary lan with point to point by nanostation ubnt. for better use all other equipment that i have installed there, i need to use subnet. so for see for example the webserver page of the second vera, i have port forwarded her port because my first lan is like a “internet world” for the subnet connected by wan.

But about the error and the page of second vera that now are with the empty field? always if i rewrite inside them, after save…same situation.
any chance to fix:
uci: Parse error (unterminated ') at line 17, byte 31
?

thanks for all

I must procede to reset the vera?[/quote]
In your script you have a? After the ip? That should be a ’

Sent from my SM-G900F using Tapatalk

[quote=“tiaanv, post:30, topic:184813”][quote=“filippodei”]i have the second vera on different subnet because i have located in a different building near my home connected to my primary lan with point to point by nanostation ubnt. for better use all other equipment that i have installed there, i need to use subnet. so for see for example the webserver page of the second vera, i have port forwarded her port because my first lan is like a “internet world” for the subnet connected by wan.

But about the error and the page of second vera that now are with the empty field? always if i rewrite inside them, after save…same situation.
any chance to fix:
uci: Parse error (unterminated ') at line 17, byte 31
?

thanks for all

I must procede to reset the vera?[/quote]
In your script you have a? After the ip? That should be a ’

Sent from my SM-G900F using Tapatalk[/quote]
Thanks but i think that it was copy and paste error of my script, because i check now and my network script is this:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘auto’

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr '192.168.81.1?
option macaddr ‘94:4a:0c:08:4b:ba’

config switch_vlan
option device ‘eth0’
option vlan ‘1’
option ports ‘4 5t’

config interface ‘wan’
option ifname ‘br-lan’
option macaddr ‘94:4a:0c:08:4b:ba’
option proto ‘static’
option ipaddr ‘192.168.101.101’
option netmask ‘255.255.255.0’
option gateway ‘192.168.101.1’
option dns ‘192.168.101.1’

It’s still there:

config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr '192.168.81.1?
option macaddr ‘94:4a:0c:08:4b:ba’

!
ugly bastard of Rbrowser!
thanks to your info and leads…i see now that when i editing the file by rbrowser by mac, when i delete the .1 in 192.168.81.1 and put at is place .2 the program give me to screen this:
'192.168.81.1?

now thanks to you is come back the correct field in the web panel. i have correct set the second vera to 192.168.81.2 but unfortunatly…no way to bridge probably for the different subnet. i tried also to to use 255.255.0.0 on the first vera but any positive results.

Your situation is a little different, as you have the veras running on two seperate lans. How are you bridging the two lans? Router?

You could try putting the lan ips as two seperate ips in the same subnet as your wan ip… In other words… If your veras ip is normally 192.168.0.x. Then put the lan ip with a static ip in the same subnet… That way if your router is doing the nat for the normal data (wan)it should in theory work for the lan…

Sent from my iPad using Tapatalk HD

sorry i didnt understand very well. :frowning:
my lan primary is 192.168.100.x and where is my first vera with 192.168.100.219
from this location i have near other building where i have a cpe wifi that connect to a wifi access point from the primary lan. this cpe have 192.168.100.230 for lan ip in the primary and use it as WAN. then create and dhcp from her a new subnet, 192.168.101.x where 192.168.101.1 is the cpe and where my second vera edge is 192.168.101.100.
I have port forwarded the ports of the 192.168.101.100 for make it visible from the primary lan, for example the 80 for web panel, the 3480 for use it from control4 (and this is the only way for now that make useful have 2 vera, because control4 control some vera edge in a moment)
Probably if we know the port used for upnp…we can hope and try.

[quote=“filippodei, post:36, topic:184813”]sorry i didnt understand very well. :frowning:
my lan primary is 192.168.100.x and where is my first vera with 192.168.100.219
from this location i have near other building where i have a cpe wifi that connect to a wifi access point from the primary lan. this cpe have 192.168.100.230 for lan ip in the primary and use it as WAN. then create and dhcp from her a new subnet, 192.168.101.x where 192.168.101.1 is the cpe and where my second vera edge is 192.168.101.100.
I have port forwarded the ports of the 192.168.101.100 for make it visible from the primary lan, for example the 80 for web panel, the 3480 for use it from control4 (and this is the only way for now that make useful have 2 vera, because control4 control some vera edge in a moment)
Probably if we know the port used for upnp…we can hope and try.[/quote]

Sorry. I am not too knowledgeable on CPE bridges, so I can’t help… I also am unsure about what ports are used for bridging.
Try this: ?
https://en.wikipedia.org/wiki/Simple_Service_Discovery_Protocol

port 1900… that in addtion to 3480 might actually work, not sure how the traffic flows both ways, and even if you can discover across subnets… that doesn’t make much sense to me, but it’s worth a try…

Good luck.

[quote=“tiaanv, post:18, topic:184813”]2. You need to run a couple of commands:

[ul][li]uci set network.lan.ifaddr=“192.168.81.2” (this sets the LAN interface’s IP address)[/li]
[li]uci commit (this saves the changed settings)[/li]
[li]cat /etc/config/network (just to review that you changed the setting correctly…)[/li]
[li]ifconfig eth0.1 down (this will “down” the LAN interface. We do this to re-load the settings in a moment)[/li]
[li]rm /var/state/network (this clears the network cached settings)[/li]
[li]/etc/init.d/network restart (restart the network)[/li][/ul][/quote]

I tried this method on Vera Edge and Lite but came across a few hurdles.

  1. After ifconfig eth0.1 down the ssh is disconnected. This is ok since I can restart the Vera manually but I cannot clear the network cache then.
  2. Adding the ifaddr does just adds a option ifaddr in the config file which was not there yet. My ipaddr stays the same also after reboot.
  3. If I change and verify the ipaddr it seems all good. But after the reboot the ipaddr is set back to the old factory set ipaddr.

My Vera lite has 192.168.81.1 and the Edge has 192.168.00.78

Any suggestions?

@reneh you can just edit one of the /etc/config/network files so both lan ipadress will be in the same range.
My example:
edge1:
config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option macaddr ‘94:4a:0c:08:4d:22’
option ipaddr ‘192.168.84.22

edge2:
config interface ‘lan’
option ifname ‘eth0.1’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option macaddr ‘d4:21:22:fc:ce:eb’
option ipaddr ‘192.168.84.23

If you run a ifconfig you will see that the br-lan(bridge) ipadress will match the lan ipadress. This is not the ipadress were you connect to the vera’s over http but I assume this is used for bridging.

br-lan Link encap:Ethernet HWaddr D4:21:22:FC:CE:EB
inet addr:192.168.84.23 Bcast:192.168.84.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8572 errors:0 dropped:96 overruns:0 frame:0
TX packets:9435 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2973090 (2.8 MiB) TX bytes:5564099 (5.3 MiB)

I managed to brigde them but I do not see any advantages yet ??? It would be nice if this ipadress was configurable from the webui.

I have a veralite and a veraedge that I would like to bridge but they don’t see each other. I have tried changing the /etc/config/network file on 1st one then the other and it seems to go ok but within a few minutes the file, whether changed on the lite or the edge reverts back to it’s original ipaddr value. I am running the latest firmware and I have tried this with both the lite and the edge set as the master controller. Any ideas why new ipaddr settings wont stay permanent?

Edit
I guess this is the same issue ReneH is seeing only I am using the direct edit method of the /etc/config/network file instead of the set of commands he used.