VERA UI7 - Plug-In/App compatibility list (updated regularly)

For those who have installed the UI7 RC please post which plug-ins you have installed and if they are, or are not, compatible with UI7. I’ll compile a list in this 1st post. As a lot of us only have the 1 Vera and can’t afford upsetting their ‘production’ environment, it would help the community greatly in deciding whether or not to upgrade to Ui7 at this time. Knowing which plug-in will and will not work will let people make an informed upgrade decision.

Also, a list of smart phone apps. Please let everyone know if they work and if so, which version.

Arduino Sensor Mostly Working
Blue Iris Mostly Working
combination switch Working See developer post #76
Countdown Timer Working See developer post #76
CurrentCost EnviR Working See developer post #76
day or night Working
DataYours Working
DLNA Working Developer posting at,27131.0/topicseen.html
DSC Alarm Working Use new version,26620.0/topicseen.html
Ecobee Not Working
Elk M1 Partly working Developer waiting on migration info from MIOS to know what to fix.
ergy Not working keeps saying that gateway serial number is already assigned
Event Watcher Mostly Working Conflicting reports on functionality.
Freebox Revolution Working
Garage Door opener Working perform a fresh install of the plugin
gcal sensor Mostly Working
GE Caddx working See developer post #76
Google Calendar 3 V 1.1 working
Harmony Hub Control Working
Heliotrope Working
Honeywell Ademco Vista Alarm Panels via AD2USB Working See post #21
Hue Mostly Working See reply#3 below
iPhone locator Working As of version 1.93.
KiraRT Working
MultiString Working
MultiSwitch V1.5 Working
MiLightRGBW V1.1 Working
MiLightRGB V1.1 Working
MiLightWhite V1.1 Working
MyQ Garage Door Opener Working
Nest Mostly working apply fix at,26439.msg187429.html#msg187429
NetAtmo Working
Onkyo Working Updated by developer. see post #54
pilot wire controller Working See,9277.msg197514.html#msg197514
Ping Mostly Working See post #15
PLEG Working See post,26438.msg205186.html#msg205186
PowerMax Alarm Mostly Working See post #51 for download of latest revision
Power Arithmetic working See developer post #76
Rfxtrx Working Developer has released possible fix,26610.0.html Please report result.
SimpleAlarm Working
SmartSwitch Not Working
Sonos Working See,26685.0.html
Twilio API Working see developer post at,26438.msg190233.html#msg190233
upnp proxy Working
vacation ghost Mostly Working
Variable Container Working See,26438.90/topicseen.html
virtual clock Partly working Installs but settings can’t be saved
Virtual Panel Working
Virtual Rain Sensor 2.8 Working
virtual switch Partly working Installs but settings can’t be saved
Visonic Powermax Mostly Working Use latest files from svn 1.2 branch.
WDSC hvac Not working app installs but device never creates
WeMo Working - needs a maintainer
Wunderground Working
xbmc state Mostly Working
Yamaha Receiver Working

Android / iOS /Windows apps
AuthomationHD Working latest beta, confirmed working locally and remote by developer.
AutoVera Working
HomeBoddy Working
ImperiHome Working,26640.msg189213.html#msg189213
VeraAlerts Working See post,26438.msg205186.html#msg205186

HomeWave Mostly working
SimpleWave 1.1.3 Working
VeraMate Working

Grasshopper Working latest version

If I missed any apps, please let me know. I based the list of the app forums…

Thank you to all who are reporting in on this thread with their experiences. In order to keep the list of plug-ins readable, I will only add a plugin when someone reports it’s functionality. Basically Working, Mostly working, Partly Working or Not Working. There are too many plugins to list otherwise.

Powermax alarm plugin doesn’t seem to work :cry:

Keeps trying to read the panel configurations but it doesn’t seem to get it…

Veramate is working

The Hue plugin mostly works; the clickable color map doesn’t react to clicks.
The HomeWave app works (at least the basic funtions and remote access), including the HomeWave Push plugin.

My 2 cents…

VeraMate works.
SimpleWave works.
HomeWave, sort of, the thermostat temperature control goes to 33 degrees if touched and does not change, tested both iPhone and iPad. (Both Vera and HomeWave are set to Fahrenheit).

VeraAlerts works but settings can not be changed, “Notification Configuration” errors out when trying to access it.

Veraalerts does not work anymore appears they changed the alerting and you can’t get to the veraalerts interface anymore.

Looks like there was an update to vera alerts last night and it now appears to be working, great job to the developers.

Smart switches plug-in is not working. The setting tab is getting an error, unable to configure light trigger

Sonos-plugin partly works. The Controls all seem to work (Play/Stop/Prev/Next/Vol) and it shows what you are playing.

On the Player-page it says “Error executing function J_Sonos1.js.Sonos_showPlayer(): Cannot set property ‘backgroundColor’ of undefined”

TTS-page looks ok, but nothing happens when you press “Say”.

Same at the Group- and Settings-page. Looks Ok but nothing happens.

Rfxtrx-plugin also partly works. Settings-page look ok, and seems to work as it should. Plugin Settings looks ok, but nothing happens when you press the set-buttons.

“New Device”-page give this error “Error executing function J_RFXtrx.js.RFX_showNewDevice(): Cannot read property ‘2’ of undefined”

“Managed Device” lists all my devices, but you cant do anything.

It updates with the current values for thermometers and hygrometers, and I can turn lamps on and off (it is slow to update the GUI though).

[quote=“Dsitver, post:6, topic:182371”]Veraalerts does not work anymore appears they changed the alerting and you can’t get to the veraalerts interface anymore.

Looks like there was an update to vera alerts last night and it now appears to be working, great job to the developers.[/quote]

How did you get updated?
My VeraAlerts is still at 5.7.
Tried http://YourVeraIPAddress:3480/data_request?id=update_plugin&Plugin=3008 and it did not upgrade it.

I did not update it just appeard and some of my TTS messages starting coming though. However it does not appear to be working 100% can’t modify any messages.

Event watcher plug-in is not producing any reports in UI7

HomeBuddy is working

SimpleAlarm plugin is working

I’ve not made the move yet but will do soon.

Looking at my dashboard - any news on these (if not then can just be added to the list)

Current Cost Plugin
Ping Sensor
Virtual Switch
Countdown Timer
Day Night
Wunderland Weather
MiLight/Easy Bulb

in addition can anyone comment on the below plugins for ui7

onkyo receiver
vacation ghost
xbmc state
gcal sensor

I have just tried U17 and found issues with the following plugins:
Multi Switch - Cannot select which of the buttons to take an action in a scene
PLEG/ PLTS - Cannot save an Input or Condition, although previous rules seem to import okay from backup
Ping Sensor - working - but has lost the nice little red/green icon indicting responses.

The following seem to be working:
Wunderground Plugin working ok
Heliotrope Plugin working ok

Last version of grasshopper for windows phone works

Myvera works also


This is related to a bug in the temperature range (it has to be entered in C even with the app set to F).

So far no UI7-specific bugs have been reported.

Hi Guys,
Can someone please test the ELK M1 plugin? That’s the only critical plugin that I am using!

Entered as “C” where?