Vera service (or lack of)

I’m very frustrated with my Ezlo Secure and I can’t seem to get any resolution from Vera. I’ve had an open ticket for over 3 months. The technical issue is my controller does not always, or even regularly, run my scenes/meshbots. Sometimes it does, sometimes not. Sometimes all actions are invoked, sometimes not. Sometimes it stops running altogether and I have to “reboot” to get it to do anything. Sometimes I have to reboot several times.

Anyway, Vera tech service (now at “tier 2”, whatever that means) has repeatedly told me they find nothing wrong and have run me through the paces trying find what I’m doing wrong. Doesn’t seem I’m doing anything wrong because they have nothing to offer. Most frustrating with this interaction has been the VERY slow responses. Usually more than a week, sometimes several weeks, pass between responses. Then they give me the “we’ve been studying your data and find nothing wrong”.

Maybe someone in the community can offer some suggestions. Either with how to diagnose what’s wrong or just how to get Vera to do something. I’m not versed in the language you all write in so I’m only able to relate what’s happening or not with my devices. Vera did tell me, early on, that is needed to rewrite all my scenes using the ezlogic web site (and that they were now called meshbots), suggesting that somehow my Vera app was the problem. I had not even heard of this website at the time (how would one know this?) but anyway figured that out and and rewrote my meshbots. Of course, no change to how they worked.

Any suggestions out there? I’ve had nothing but grief from my Ezlo since I was scared into replacing my Vera Lite. Thanks.

Sorry to hear this. I’ve asked a senior support engineer to look at this thread and respond.


Hello @Tom1951,

Sorry for the inconvenience.

We identified some crashes during the period of time the controller was trying to execute a pair of meshbots with multiple actions. We’ve created and escalated a ticket for further review/development and its currently under investigation. I noticed we sent you an RMA request to replace your controller as well.

Since you mentioned you are not aware, Ezlogic is the new interface for Ezlo controllers where you can create automations with your meshbots, add cloud integrations, configure plugins, add virtual devices, and more. Find more: EZlogic – brief interface overview -

We suggest using the website to create and edit your automations. If you have any questions about Meshbots or Ezlogic, feel free to reach out and let us know.


Ok, under investigation. I’ve heard this many times before with the ultimate response, “nothing wrong with your controller”. Are you confident this time something can be “fixed”? Or, should I proceed to replace my controller?

Thank you

We can try some changes to your network if you are willing to, Change how the meshbots are executed and run the actions sequentially instead of all of them in parallel, add a couple of delays, etc. However, the reason why the service is crashing needs further investigation.

Alvaro, yes, please try. Brayan said yesterday that he had added some delays between actions. Last night the meshbots worked. Need more repetitions to confirm as I’ve had periods when the meshbots worked followed by bad times. Thx

Adding some time delays between each action certainly can help, if you have lots of actions in your Meshbot rule.

@Alvaro_Ochoa might the new Execution Policies help also in this situation?

By setting each Action to “Execute next action sequentially if this action suceeds” ?

Possibly not, if it only looks to see if each device command was sent out?

And does not look to see if that device was actually operated? E.g. turned on or off or whatever the actions are doing.

Update on recent performance of my meshbots…
A week ago, after asking about making changes to my controller, everything stopped and I had to reboot 4 times before anything would work again. But, then it did. Since then all meshbots have been working correctly. So, great! This seems like progress.

Can anyone tell me what happened? What’s different? The only thing I know, and can see, is that a 5 second delay was introduced in one of my mescbots between actions. Is that it? Should I do this always? What about the new Execution Policies? Do they do the same thing? Is that a better way?

At this point, should I still go ahead and send my controller back for a new one or continue with this one?

@Alvaro_Ochoa should answer.

Id also like to know more about the new Execution Policies in this regard.

Thank you for the update, @Tom1951 .

We identified that two meshbots running at the same time with multiple actions were crashing the z-wave service. This has been reported to developers for further review, we are looking forward to improve the behavior specially for users with large networks that run multiple actions simultaneously.

To adress the situation, my partner added a couple of delays between actions, we could also modify your meshbots execution policies.

Execution policies help you define the sequence in which your actions are executed. Available execution policies are:

  • Execute actions in parallel: All actions are started at the same time.
  • Execute actions sequentially: Each action is executed once the previous action is finalized. Whether the action ends in success or failure is not taken into account.
  • Execute actions sequentially as long as previous action succeeds: Each action is executed once the previous action is finalized successfully. If an action fails, the actions after that are not executed.

Find more here: Mios - Help - Execution Policies

If everything is working ok, I’d stick with the controller, however you are covered by our industry leading 3-year limited warranty. If you experience an issue with your controller and we determine it’s defective, we will proceed with a replacement. Check our warranty policy.

1 Like

Alvaro, thanks for the further info. I am inclined to stay with my existing controller as it seems to be ok for now. Also, I imagine that moving my devices to a new controller would be a hassle based on all the fussy tricks needed to get them all working on the existing controller.

Anyway, can you say if the Execution Policy is a better way to introduce delays into the meshbot versus the adding delays between actions? Do these two methods do the same thing? Thanks

Well, once again just as I hope progress has been made, my controller crashes. Some meshbots ran, some not, some incompletely. How does any user have confidence in this system?

The notion that delays might be needed suggest some sort of race condition within the logic. I have seen similar issues with meshbots running on many devices (ZWave). My guess is the ZWave protocol isn’t being handled robustly so when one device is going through all the handshaking to issue a command to a node, others are at a different state in the execution queue and this interferes with the meshbot completion (not enough round trip confirmation of each ZWave command running through to success). Now take this up a level by having concurrent running meshbots potentially commanding some of the same nodes. It gets complicated quickly. Delays or staggered execution might be a way to eliminate some of these factors.

Vera seemed to handle this better than Ezlo. I speculate that Vera had to get into the ZWave protocol weeds because it was embryonic back in the early days. Now I think Ezlo thinks of it as a blackbox with an API from Silicon Labs. Perhaps a little too hands off and overly trusting in my book.

I think there were some ZWave improvements in the most recent beta release but I haven’t been able to confirm this yet.

@Tom1951 Maybe ask Ezlo staff to add your controller into the beta programme if it isnt already?

What firmware version is currently on your controller?

In the Ezlogic web UI, go to settings then my controllers and click the i for information and a pop up should appear showing the controller information and firmware version.

I’ll check the current status and read the logs from last night.
Could you please PM me with the Meshbots that didn’t run?


I don’t know what PM is.

He means a direct message you can click his name and the message button…

I think firmware version is the latest “beta” version, that’s what my controller is on.

So assume your version is not a beta version.

Looks like I got my firmware updated to the beta version, probably due to your observation, thanks. Anyway, 3 days, no issues.
I am still interested to know the differences, pros and cons, of using the Execution Protocols versus the “delay” feature in the meshbots to achieve the spacing needed between actions that seems to reduce confusion. Thx.

Me too, I’d like to know more about that also.

I have had my Ezlo Plus for almost 2 years now, and it still will not execute simple motion and LUX meshbots, it may execute one of my several 3 or 4 times doing the day or evening and never execute any of my Motion LUX mesbots again for a week or maybe never. My LUX parameters are set correctly and according to LUX sensor they are reading below my set point.
Also, now that have new update 1.64.2 I get devices" not Reachable" either refresh Ezlo Dashboard, and it will say the one that was not “reachable” is now reachable, but another device will say "not reachable. etc. Do not know what is going on because it is not always the same device and the ones that fail most often are within 8 feet of the controller. Also ,my Pearl thermostat only allows me to change cooling temperature by 3 degrees “70 71 72” and that is it
Also, there is no hold function on the icon for my thermostat
also, I have a mess of unassigned devices under settings “device” and can’t get rid of them
also, ezlologic has renamed many of my device
Also, ezlogic dashboard show devices that are ON as not ON
Devices that worked a week ago no longer work and have uninstalled and re-installed 5 times
also the tmer function is not accurate at all 5 second delay sometimes is 3 or 10 or 6 10 minutes is not 10 minutes etc.
Sorry, these issues should have been corrected long ago.
I know your programmers are in a bad place right now, but so far this Ezlo controller is totally unreliable.