Vera extroot

This is the file with script to upgrade to 7.31b on your extrooted vera plus.

https://www.filehosting.org/file/details/844318/VPextroot4903upgrade.zip

It is too big to post on the forum so I had to use a third party upload.
unzip the too files and upload to your extrooted vera.
Run ./upgradeVP7.31beta.sh
You may need to run a permission change to make the file executable chmod +x upgradeVP7.31beta.sh

1 Like

Rafale, how do you tell if exroot is still working? I was recently on my Vera (getting ready for the new firmware I am hoping) and did a backup_to_vera command, and it pretty much failed accross the board, so wondering if my exroot died off at some point and I am actually running of the Vera.

SSH into the unit and run df -h and see how much you have left in your root partition.
What error are you seeing running back up to vera? It is possible that you have accumulated too much data and that your vera no longer is capable of hosting all your plugins and configurations without a reconfiguration of your storage.

Hmm, from below either xroot is not longer rooted or it is full which doesn’t make a whole lot of sense.

root@MiOS_50001041:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 8.6M 6.9M 1.8M 80% /
/dev/root 10.0M 10.0M 0 100% /rom
tmpfs 124.8M 896.0K 123.9M 1% /tmp
/dev/mtdblock7 8.6M 6.9M 1.8M 80% /overlay
overlayfs:/overlay 8.6M 6.9M 1.8M 80% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda1 493.6M 2.3M 455.0M 1% /tmp/log/cmh
/dev/sda2 109.4G 107.6M 103.7G 0% /mnt/sda2
/dev/mtdblock10 50.0M 1.4M 48.6M 3% /storage
/dev/mtdblock10 50.0M 1.4M 48.6M 3% /etc/cmh-firmware
/dev/mtdblock10 50.0M 1.4M 48.6M 3% /etc/cmh-backup
/dev/mtdblock9 9.8M 9.8M 0 100% /mios

No you are indeed no longer extrooted. Did you accidentally upgrade firmware by any chance?

No, no firmware updates but I had a bunch of power failures at the house and I am guessing at some point the harddrive stopped mounting or something. This actually works out. I will just leave as is and install the new firmware when it is out of Beta (I was planning to remove exroot at that time anyway).

Your other thread with all the drive info was removed from the forums. (The thread with savespace scripts), that thread was handy because it also listed all the files/directories that are safe to remove. Can you re-repost the the list of folders that are OK to clean out if you are having space issues? Hopefully I can keep the Vera up and running until the new firmware is finalized.

Hmm didn’t know that more of my posts were removed. I did not even see any notifications for edits. Oh well. I am not going to repost things the management here doesn’t want to see. You can PM me and ask specific questions maybe…

1 Like

@rafale77, for those of us that didn’t heed the warning and did an upgrade to 7.30… can we restore to 7.29, exroot again, and then try to upgrade or are we SoL?

I don’t know how to downgrade the kernel unfortunately. I suspect, I could trick the vera into doing it but the way I did mine was to run this:


and then upgrade back to 7.29 before manually running the scripts to upgrade to 7.30 or 7.31 by maintaining the kernel. It’s unfortunate that I am treating 7.30 and 7.31 upgraded units as if they were bricked… :sweat_smile:
I wish I knew how to re-enable the root pivoting on the new kernel… Sorry. My interest is also waning fast as I am migrating away from vera so I won’t spend too much time on it. I get the feeling over the last few firmware versions that eZLO is gradually closing down the platform. Whether it is intentional or not, It is increasingly difficult to maintain the system extrooted which is a far better solution than all the kernel and storage tweaks the devs are making albeit requiring additional hardware…

I hear you and that is unfortunately the way i am leaning as well. As far as a new platform, are you moving everything over to HA or what are you going to be using? just trying to follow the best path possible moving forward.

Replied to you in another more appropriate thread.

1 Like

I found the problem preventing the new firmwares from extrooting and fixed it. I managed to validate it on both the vera edge and the vera plus. There is no need to remain on the old firmwares anymore. I will send out scripts tomorrow after I am done testing them.

This is what I am getting as I found a workaround to reproduce the behavior of extroot on the updated kernels:

root@MiOS_5001XXXX:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                  234.1G    168.7M    222.0G   0% /
/dev/root                 8.0M      8.0M         0 100% /rom/rom
tmpfs                   124.3M      1.2M    123.2M   1% /tmp
/dev/mtdblock7           10.6M      1.1M      9.5M  11% /overlay
overlayfs:/overlay       10.6M      1.1M      9.5M  11% /rom
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda1               493.6M      1.2M    456.1M   0% /rom/mnt/sda1
/dev/mtdblock10          50.0M     22.5M     27.5M  45% /rom/storage
/dev/mtdblock10          50.0M     22.5M     27.5M  45% /rom/etc/cmh-firmware
/dev/mtdblock10          50.0M     22.5M     27.5M  45% /rom/etc/cmh-backup
/dev/mtdblock9            9.8M      9.8M         0 100% /rom/mios
/dev/mtdblock10          50.0M     22.5M     27.5M  45% /rom/etc/cmh-ludl
/dev/mtdblock11          19.3M      1.0M     18.2M   5% /rom/ezmi
/dev/mtdblock11          19.3M      1.0M     18.2M   5% /rom/etc/cmh
/dev/mtdblock6            8.0M      8.0M         0 100% /rom/mnt/mtdblock6

So as you can see I managed to pivot the root but from the startup logs, I had to make this happen much later in the boot process. It means from what I observed that the luup engine reloads twice during the boot process. I verified that adding plugins actually load and work on the external drive. I used the same trick I used on the previous vera edge script which should still work. The original partitions (so many of them now with this new kernel as data has been distributed all over) are now mounted as read only in the “rom” folder and you shouldn’t need to touch them.

3 Likes

Utterly awesome

C

And there you go. Confirmed on my second vera:

root@MiOS_5000XXXX:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                   58.1G    175.8M     54.9G   0% /
/dev/root                 8.0M      8.0M         0 100% /rom/rom
tmpfs                   124.3M    304.0K    124.0M   0% /tmp
/dev/mtdblock7           10.6M      1.2M      9.4M  11% /rom/overlay
overlayfs:/overlay       10.6M      1.2M      9.4M  11% /rom
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda1               487.8M      6.4M    451.8M   1% /tmp/log/cmh
/dev/mtdblock10          50.0M     13.8M     36.2M  28% /rom/storage
/dev/mtdblock10          50.0M     13.8M     36.2M  28% /rom/etc/cmh-firmware
/dev/mtdblock10          50.0M     13.8M     36.2M  28% /rom/etc/cmh-backup
/dev/mtdblock9            9.8M      9.8M         0 100% /rom/mios
/dev/mtdblock10          50.0M     13.8M     36.2M  28% /rom/etc/cmh-ludl
/dev/mtdblock11          19.3M      1.0M     18.2M   5% /rom/ezmi
/dev/mtdblock11          19.3M      1.0M     18.2M   5% /rom/etc/cmh
/dev/mtdblock6            8.0M      8.0M         0 100% /rom/mnt/mtdblock6
/dev/sda2                58.1G    175.8M     54.9G   0% /

Please find the scripts attached.

extrootplus.sh.zip (1.1 KB)extrootedge.sh.zip (1.3 KB)

Thanks @rafale77. What’s the process here if you’re already exrooted on 7.29?

Cheers

C

Awesome! :+1:
Is it possible to extroot a Vera Secure, running the latest firmware with the VP-script?

The process would

  1. Backup (Did I need to mention that?)
  2. Unplug the SSD and reboot
  3. Upgrade to 7.31 with factory reset
  4. Load the script for your unit and… extroot
  5. After the unit reboots out of the extroot, verify that it was successful with the df -h command output above
  6. Restore from backup.

@Fanan, Unfortunately I cannot guarantee it will work on the secure because I don’t have one to test on… I would presume it would mostly work but I would not be surprised if it needed something else. One way to find out would be for you to upgrade and send me the output of the df -h command.

2 Likes

I tried with my Vera Secure with the latest firmware - and kaboom - it worked!
Thank you @rafale77!

image

2 Likes

Not sure I dare :slight_smile:
C

1 Like