Vera extroot

I unplugged the SSD, I restored a previous and stable backup of my vera and then, all my scenes are back again. Good point.
I then untick the usb loggin, plugged the SSD, tick usb login again and run your script again.
All is fine again…
Now, and as you mentionned that I could have accidentaly tick usb login, do you mean that after running your script, the usb login must be untick ?

Yes. Actually ticked or unticked no longer matters after the extroot is run but… ticking the usb logging triggers a script in the vera which formats the USB drive and prepares it for a partition to store the logs. When you do that, you lose everything. You should never touch that checkbox after you extroot.

Ok, thanks for your answer.
So now vera is extrooted again, I have untick the usb login.
What I don’t understand is that I didn’t change anything on the vera settings and particularly on this part of the settings.
Vera has rebooted a couple of times since I first extrooted it and I never encounted this phenomen.
No matter the reason, the point is that now, it perfectly works again.
Thanks again.

Ugg… I thought that the Vera Backup/restore worked as normal when you were exrooted, but it seems to be sporadic, Some of my the nightly backups on Vera is only backing up the main drive not the exrooted drive. So I guess you need to run the back script periodically from the exroot tools to ensure you get a current backup?

Hmm I have never seen this. It should be backing up the data from your root partition. I suppose you are talking about the backups which are on the mios server? Even so the backup is from the drive you are booting from. The fact that it isn’t inconsistent is more concerning… Are you sure this is the problem and you are not sometimes booting from internal drive?

Not really sure what happened, definitely had one recent backup that was not from the exrooted drive, but subsequent ones were correct. All I can think of is what you hit on, it got into a bad started wasn’t booted from the exroot drive close to when one the backup occurred. But generally the thing is rock solid so not sure what happened. But the bad backup was definitely from the day I did an exroot backup. Wierd.

This would explain the whole thing. The vera occasionally does not boot from the external drive due to a missed timing of when the hardware gets loaded at boot. For me it’s been pretty rare but it does happen. A big part of it I believe is the old USB interface used on the vera and depends also on what hub is being used.

@rafale77 any thoughts on the new firmware coming up. Are you still recommending exroot, or did they go far enough with the changes to remove exroot?

I am thinking I will definitely remove the savespace hack on my Edge.

Can you remind us of the correct steps you are recommending for updating the firmware on an exrooted plus?

I would test the firmware without extroot first. The new firmware implements a solution very similar to what I proposed with savespace but in many ways better because it is native rather than a patch and is combined with some more space saving ideas. It should be enough to keep your system going for some time. Once it is fully released I will look at extroot again but this time will work with the ezlo team with it. I have had discussions with @edward to integrate it to the firmware at some point.

1 Like

@rafale77 once the new firmware is released, would you mind posting some step by step instructions for updateing extrooted systems?

In other words how to safely remove extroot an update the firmware without ending up with a brick :wink:

This should be fairly easy to do:

  1. From the extrooted vera, run a manual backup. (optional, run a backuptovera script to move your user data to the vera)
  2. Unplug the external drive and reboot
  3. Now that you booted from the onboard drive, run the upgrade (start from fresh, do not retain user data)
  4. Restore your backup on the new firmware. (make sure to tick the restore zwave network checkbox)
  5. Enjoy your config on the new vera! Apply the configuration changes I suggested on my “Zwave network explained” thread if you feel your network is crippled.
2 Likes

has anybody updgraded 7.30 on an extrooted vera

I did 5 hours ago. Followed the steps above (no 271), written by @rafale77. So far, so good!

1 Like

So you have to exroot again after upgrading?

I don’t think it is needed any more.

My fear is that with my vera edge the onboard drive was lucky to last 12 months before it died and now i have OS on enterprise SSD

Huh you are right… the edge is a completely different story. It would indeed be very beneficial. I will look into it when I can.

Just to confirm, so with the next firmware for Vera Plus, there is no need for extrooting anymore? But aren’t there still the same underlying reasons using external SSD as compared to onboard NAND (lack of wear leveling, garbage collection and poorer quality in general)?

The new firmware reorganizes the on-board NAND FLASH to make better use of available space, as well as reducing the wear on the NAND by making changes to how the FLASH is updated. These changes should eliminate the self-bricking during upgrades and NAND-wear failures.

That said, I plan to stay with my extrooted SSD. I was an early adopter of @rafele77’s extroot scripts (September 18, 2018) and have had no issues in over a year. As you point out, the SSDs are a much higher quality storage medium.

1 Like

@HSD99 is completely correct. As I said the new firmware has significant improvements making changes similar to my savespace script permanent and going a little further. I am testing the beta of 7.30 at the moment and will look at extrooting it. It failed for some obscure reasons the first time I tried and I did not spend too much time on it. It never worked on the edge as is because of DRAM limitations on the edge but there could be a workaround once I get it to work on the plus.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules