Vera extroot

Hi @rafale77

From your original post, is it still implicitly required to have a sata USB connection? Many of the new external SSD are using usb-c to USB 3.

Can I get a drive like this from Amazon and still extroot?

I can’t see any reason a USB3-C connection wouldn’t work but surely rather more expensive than a USB 3 enclosure?

C

I don’t have the drive itself so just browsing through Amazon and looking at the c300 @rafale77 mentioned I wanted something smaller than what I initially saw but before I committed to anything I wanted to make sure as long as it is USB it would be ok.

I have one of these:

Which leaves me about 54G of free space.

Not even in an enclosure just

SSD in an enclosure seems a bit daft somehow but I guess I should move it :wink:

C

1 Like

Some of those external SSD to USB 3 drives are garbage (particularly if you got random knock off garbage of the month from an Amazon seller), I tried one of those for Exroot at first and not only was it an incredibly slow drive (way below specs that were advertised)…it would just would fail periodically and other non-sense and the Vera hated it. Getting a real laptop drive in a enclosure (or SATA Cable adapter) means you are getting a slightly more trusted product that will likely work.

Also note for the drive to get enough power, speed, reliability you need a powered hub, don’t just plug them directly into your Vera. And don’t use an unpowered hub.

1 Like

Thanks for that. I’ll look into that route instead.

after 2 weeks of trying able to get it to mount but seems like everything pushed over to /rom

Filesystem                Size      Used Available Use% Mounted on
rootfs                  109.4G    104.9M    103.7G   0% /
/dev/root                10.0M     10.0M         0 100% /rom/rom
tmpfs                   124.8M    216.0K    124.5M   0% /tmp
/dev/sda2               109.4G    104.9M    103.7G   0% /rom
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda1               493.6M      3.1M    454.2M   1% /rom/mnt/sda1
/dev/mtdblock10          50.0M      1.4M     48.6M   3% /rom/storage
/dev/mtdblock10          50.0M      1.4M     48.6M   3% /rom/etc/cmh-firmware
/dev/mtdblock10          50.0M      1.4M     48.6M   3% /rom/etc/cmh-backup
/dev/mtdblock9            9.8M      9.8M         0 100% /rom/mios
/dev/mtdblock7            8.6M      5.1M      3.5M  60% /rom/mnt/mtdblock7
/dev/sda2               109.4G    104.9M    103.7G   0% /

finally made some edits to the fstab and uuid mount … im so happy right now

doest look correct but it works …

seems like everything copied to /rom/ is there any way to fix that @rafale77

1 Like

Some are, some aren’t . Getting a drive in an enclosure by no means you’re getting a ‘real’ laptops drive.

And I’m afraid your comment of needing a powered hub is really not quite accurate. It might be preferable but certainly is not required.

C

so everything mounted in the /rom/ directory not sure why everything mounted there for some reaso

Just trying to lead folks to the best chance for success.

The reason I say go with the SSD Laptop drive is that it is easier to find small size/cheap ones that are brand names that you can reasonable trust even when buying from Amazon, when you try to find a cheap small size External drive you quickly move away from name brands (which mostly want to sell you huge expensive drives) and into questionable sketchy stuff which are no better than a thumb drive. That doesn’t mean they don’t exist, but we all know the joys of trying to to determine if we buying garbage or something legit particularly in the tech space on Amazon.

For the powered hub, I found my deployment was more reliable with one, I have no idea how much power the Vera is consistently putting out on the USB port (didn’t sit there with my multi-meter), but I do know my SSD (with my Star SATA cable) and Security Connection (USB to Comport) where too much for an unpowered hub, so why risk it if your main goal is to make your Vera more reliable?

1 Like

Thanks, I literally updated my Amazon list and found something that was a drive, cable, and powered hub for about $90. The drive is a western digital so you’re right on a name brand. Really appreciate it.

@rafale77 since i got mine back i was working on a script so that people without “experience” can also use your script to extroot

upload extroot.sh Apps > Develop Apps > Luup Files
then run this in test luup
not sure it would work but its worth a try

os.execute("cd /etc/cmh-ludl && pluto-lzo d extroot.sh.lzo extroot.sh && mv extroot.sh /extroot.sh && rm extroot.sh.lzo && cd / && chmod +x extroot.sh && /extroot.sh")
but I need a way to print # df -h to a file

Edit :

df -h > /etc/cmh-ludl/MySDc_Df_h
after reboot run this in test luup

os.execute("df -h > /etc/cmh-ludl/MySDc_Df_h && cd /etc/cmh-ludl && pluto-lzo c MySDc_Df_h MyS_Df_h.lzo && rm MySDc_Df_h")

local x = io.popen "df -h"
local y = x:read "*a"
x: close ()
print (y)

This prints out the result (for me)…

Filesystem Size Used Avail Use% Mounted on
/dev/root 7.1G 2.4G 4.4G 36% /
devtmpfs 458M 0 458M 0% /dev
tmpfs 462M 2.3M 460M 1% /dev/shm
tmpfs 462M 6.5M 456M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 462M 0 462M 0% /sys/fs/cgroup
/dev/mmcblk0p1 63M 22M 42M 35% /boot
tmpfs 93M 0 93M 0% /run/user/1000

…but you could equally easily write it to a file.

how could i write that to a file?

You seem to be needing a lot of Lua coding… time to learn it better?

Try Programming in Lua.

Then Lua 5.1 Reference Manual for the full details.

1 Like

df -h > /etc/cmh-ludl/MySDc_Df_h

os.execute("df -h > /etc/cmh-ludl/MySDc_Df_h && cd /etc/cmh-ludl && pluto-lzo c MySDc_Df_h MyS_Df_h.lzo && rm MySDc_Df_h")

Hello Rafale,

This problem happened to me yesterday night. Till there, all worked fine and I did nothing particular.
At the moment, Veraplus doesn’t work if the ssd is plugged.
If I unplug it, Veraplus work.
A “failedRotate.log” file is present on the ssd.
May I copy the content here ?

Not sure what you mean by not working with the SSD plugged.
Does it mean the vera does not complete booting?
If so it is likely got corrupted on the SSD and the vera is correctly attempting to boot from it. What happened last night? What is the full content of your SSD?
If you only have some log file and only one partition, you may have accidentally enable SSD logging which wipes out the SSD. This means that you need to extroot again.

Yes, I mean that vera does not complet boot.
Nothing special happened last night…
The SSD content a partition named “MIOS” with 8 files : 6 log files named “failedrotate”, “internetok”, “luaUPnP”, “NetworkMonitor”, “serproxy” and “upgrade”, one file named “mount-test” and a folder named “sysinfo.log.gz”
On the SSD is another partition with all folders like “bin”, “dev”, “etc”, storage, lib, mios and so on.
When the SSD is plugged, vera try to boot but after a moment (4-5 minutes), I can read that “luup engine is taking longer to reload”.

When I unplug the ssd, vera boot normaly except that 3 scenes have desappear and, strangest, she seems to have downloaded the totality of all plugins luup’s files.

Is my vera owned ?

If you are able to get to that page with the luup engine taking longer to reload, it probably means that the vera actually completed booting the operating system on the SSD and that it could not boot the luup engine program. You likely have some corruption of your user-data.json. Did you try SSH-ing back into the vera while the vera is booted from the SSD? Can you run a

ps -aux

if you are able to get in? likely the webserver “lighttpd” is running but your LuaUPnP is not booting. You then probably need to copy your /etc/cmh/user-data.json.lzo files over from your internal drive.