Vera Edge - Synology Surveillance Station Plugin - Help

I have installed the Synolopgy Surveillance Station Plugin but i am unable to connect to it through Vera.

I have inputted all the details in listed in the help webpage by the Dev.

Anyone else got this working?

Thanks
N

Hello,

you will find a new version here :

You have to set the parameters “Protocol”, “Host”, “Port”, “UserName” and “Password” in “advanced” tab.

This version uses cookies instead of sid (no more communication problem)
It’s still in development and I will make a dedicated post when the plugin is stabilized.

[quote=“vosmont, post:2, topic:188745”]Hello,

you will find a new version here :

You have to set the parameters “Protocol”, “Host”, “Port”, “UserName” and “Password” in “advanced” tab.

This version uses cookies instead of sid (no more communication problem)
It’s still in development and I will make a dedicated post when the plugin is stabilized.[/quote]

Brilliant,
Thanks for the post!

Hi vosmont,
Any info on how to upload the file correctly to Vera?
I was hoping to be able to upload the .zip and for it to work, i think theres a bit more to it. Are you able to help?

Thanks
N

[quote=“alpha1, post:4, topic:188745”]Hi vosmont,
Any info on how to upload the file correctly to Vera?
I was hoping to be able to upload the .zip and for it to work, i think theres a bit more to it. Are you able to help?

Thanks
N[/quote]

You have to decompress the zip and upload the files in “luup files”.

[quote=“vosmont, post:2, topic:188745”]Hello,

you will find a new version here :

You have to set the parameters “Protocol”, “Host”, “Port”, “UserName” and “Password” in “advanced” tab.

This version uses cookies instead of sid (no more communication problem)
It’s still in development and I will make a dedicated post when the plugin is stabilized.[/quote]

it works really well but running scenes and triggering single cameras is not possible.
advanced scenes editor camera ID provided but once triggered, all cameras are recording.

Works really well!
Is it possible to set a timelimit of the recording, if it’s triggerd by a doorsensor? Lua?

Does this plugin show the cameras at all. Mine doesnt. It says i need to configure them through the advanced options which i have done and it can report on my 2 camera. When i click the camera tab it fails…

Thanks
N

[quote=“alpha1, post:8, topic:188745”]Does this plugin show the cameras at all. Mine doesnt. It says i need to configure them through the advanced options which i have done and it can report on my 2 camera. When i click the camera tab it fails…

Thanks
N[/quote]

Hello,
this plugin is still in development (I will check your problem with the camera tab).
You should see it has a remote control for the Synology Surveillance Station.
It has not been designed to replace Surveillance Station, and then does not display a camera panel.

[quote=“vosmont, post:9, topic:188745”][quote=“alpha1, post:8, topic:188745”]Does this plugin show the cameras at all. Mine doesnt. It says i need to configure them through the advanced options which i have done and it can report on my 2 camera. When i click the camera tab it fails…

Thanks
N[/quote]

Hello,
this plugin is still in development (I will check your problem with the camera tab).
You should see it has a remote control for the Synology Surveillance Station.
It has not been designed to replace Surveillance Station, and then does not display a camera panel.[/quote]

Hi thanks for the quick reply.

So i have uploaded some photos. i didnt know if i was missing something like a live view from the camera or not?

I have attached them just incase

Thanks
N

No, it’s OK (all the display is as expected)

The problem should be with actions on a specific camera.
(I just use the main switch to enabled/disable all the cameras)

Super, thanks for the quick replying Vosmont!

This is a great plugin.

Looking forward working with this as the Synology is a better way to manage the video, but it would be nice to have scenarios which trigger from Vera. Thanks for your work.

bk

Hello,
I`m a newbie here… what exactly am I supposed to input in the “Protocol” field??

Hello pauladrp,

it should be “http”

how do you install the newer version? i am confuse on how to set this up.

Hi vosmont,

I am going to give this a try too. Also looked at your coding quickly, but I see I should study it more. I can sure learn a lot from that and improve mine. :smiley:

Cheers Rene

Hello,
I will check that I’ve pushed all my new changes on Github.

A feature that I use is the external events : I can execute a scenario on Surveillance Station from an event in the Vera (rotating camera after a movement in a room)

[quote=“vosmont, post:5, topic:188745”][quote=“alpha1, post:4, topic:188745”]Hi vosmont,
Any info on how to upload the file correctly to Vera?
I was hoping to be able to upload the .zip and for it to work, i think theres a bit more to it. Are you able to help?

Thanks
N[/quote]

You have to decompress the zip and upload the files in “luup files”.[/quote]

I have done this but I can neither see the plugin in my apps or as new device >:( What is wrong? I have UI5 and have also restarted LUA and made a reboot. Shall I upload also the UI7 file?

The simplier is to install the plugin from apps.mios.com and then to update the files.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules