Vera and Ezlo Google Home portal setup merging much strangeness?

BUG

Hello

@adina.porea @Ioana

Who at Ezlo is in charge of the Voice Assistants integrations ?

On the portal gateway https://nexus.getvera.com/ there is this drop down menu:

image

Now when I go in to the “Manage Google Home” option to configure my Vera hubs I am also seeing the Ezlo Atom listed in this area, before it was not:

I have four hubs.

Vera Edge (with Vera FW for testing)
Vera Plus (Production)

Ezlo Atom
Ezlo Plus

When going in to the “Manage Google Home” option, I see my Vera Edge and Vera Plus devices and scenes as expected.

However at the bottom of the page I can now also see the Ezlo Atom as shown in this screen shot.

Stranger still I have ZERO devices on my Ezlo Atom currently other than both VOI devices, yet its showing some devices suggesting they are from the Atom, when they are not.

I have many devices on my Ezlo hub however (2 real Z-Wave devices and the rest are bridged devices from the Vera Plus using the “Plugin: Bridge Vera with Ezlo: VeraBridge for Ezlo” and some TEST virtual devices from the Ezlo API.

The devices you can see listed under the Atom look to be some random devices from the Ezlo Plus, but not all the devices from the Ezlo Plus.

The Atom and these rogue devices should not be listed at all in the “Manage Google Home” option as this is for Vera hubs not Ezlo hubs.

If I instead look in the “Manage Google Home Ezlo” option I see this page, which looks totally different to the “Manage Google Home” page, the devices and scenes are not divided in to heading / sections and are all just in one long list merging together devices and scenes.

Also there is no indication as to which Ezlo hub these devices and scenes are from?
They do however appear to be all from my Ezlo Plus.

If I go to the “Manage Alexa” option on the menu for “Vera hubs”, I expect to only see my Vera Edge and Vera Plus devices and scenes listed which I do, however I am also now seeing the Ezlo Plus at the bottom of the page, this should not be here !

And it is showing just some random devices from the Ezlo Plus not all of them. And no scenes from the Ezlo Plus are showing at all.

If I then go to “Manage Alexa Ezlo” option from the menu, I then see the devices on the Ezlo Plus but no scenes from the Ezlo Plus listed at all.

This all now seems seriously messed up and screwed up.

@cw-kid
Thank you for reporting it.
I forwarded the issue to web portal team

1 Like

Hello @adina.porea

Any update on the above, from the portal team on this yet ?

Also I have some additional feedback about the Ezlo / Google Home service integration.

Roller Shutter devices aka Window Coverings, do not work with the Ezlo service for Google Home app GUI, they look like this:

image

image

However the Vera service for Google Home they do kinda work (Switches) and look like this:

image

image

Thanks

RGBW lights with the Ezlo service for Google Home:

This is your own “TestBulbRGB” virtual device on the Ezlo Plus and how it looks in the Google Home app.

image

image

image

There are no colour controls available.

I have over 80 virtual devices on the Ezlo Plus hub and a few real Z-Wave devices.

The virtual devices have been added to the Ezlo hub using the 3rd party Vera to Ezlo bridge plugin.

So I can effectively control my real devices on the production Vera Plus by the corresponding virtual devices on the Ezlo Plus hub etc.

However in the “Manage Google Home Ezlo” portal page I only see a small number of devices in the webpage, for selection to expose them to Google Home, where are all the other missing devices ? Some of these devices I can see in the portal page are some of these virtual devices from the bridge and some of them are the real devices I have paired to the Ezlo Plus hub.

However there are lots of devices that appear to be missing and not listed in this portal even though they are present on the Ezlo Plus hub.

The voice assistant management portal webpages are still serious messed up for both Vera and Ezlo hubs.

Hi @cw-kid,

I just looked and what I see is:

  • Manage Alexa Ezlo shows all devices and scenes lumped together, even devices that do not have any action like a power meter or Lux sensor.
  • Manage Google Ezlo shows only actionable devices and scenes. This makes more sense to me.
  • I see no difference between a local and bridged device.
  • I miss the way the device types and scenes are organized when managing Vera devices for Google/Alexa.

Cheers Rene

The whole thing is a mess at the moment.

The Alexa page layout looks different to Google Home.

For Alexa it does not automatically tick new scenes and devices that have been added to Vera, for exposure to that voice assistant.

However for Google Home new Vera scenes and devices are automatically ticked and they appear in my Google Home app when I might not want them to.

The Vera hub pages now show some random devices for an Ezlo hub as I described above, but not all the devices that are actually on the Ezlo hub.

That has since changed, at least for an Ezlo hub.

Today when adding new devices in to the Elzo Plus hub, those new devices were auto selected for exposure to Alexa. Worse still there is a bug where the devices don’t remain unselected when you try to unselect them.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules