Vera 7.31 Core Firmware BETA Release

BETA - Warning

The links below are for Beta software and are not recommended for testing on a production machine. They’re intended for beta testers only. Please try at your own risk.

Vera Edge:
Vera Plus:
Vera Secure:

We have a new update available with fixes to the reported issues:

  • Added device information for Wake-up Interval Capabilities Report, CC Wake Up V2 (WakeupCapabilities)
  • Fixed the ‘Xmas lighting’ issues reported in Vera Plus and Vera Secure.
  • Fixed the issues with the upgrade process reported on Vera Plus caused by bad blocks.
  • Fixes the upgrade issues reproducing on slow networks where some files need to be downloaded during the upgrade process, which on slow networks it takes more than 15 minutes

Based on the current implementation if the connection is lost during the upgrade process will be resumed once the internet connection is reestablished.
Please note that if the controller it’s in a state where the power led is blinking it means that the download process is still in progress and it should not be disconnected from the network or power cycled.


Up and running since published. No issues to report so far. Upgrade was smooth (7.30 to 7.31, so perhaps not a stringent test). Am testing Internet LoS right now…

Edit: Start + 01h:15m - Service and Internet blinking, but box is healthy. Reload luup continues blinking with healthy operation so far…

Edit: days later, no problems, no soft-bricking. Good work team getting that nasty surprise out of there!


Replying to bump this up in the list.

This new beta version contains fixes for a couple of issues that have been fixed with the help of several community members and it was made available a little over a week ago.

However, through some miscommunication, the thread was made available for a small group of developers in the community not the entire community.

We corrected this now and we apologise for not providing this beta sooner to the entire community.


You beat me to it, @Gabi !

My tests so far have been solid good, no issues. Internet up and down, long and short, no soft-bricking or hangs.


Thanks to @rigpapa for alerting us that, this post was not publicly viewable :slight_smile:


No apologies! Happy to see it was tested by the very knowledgeable developers on the forum before being made available to us :blush: Upgrading as we speak.

I guess I missed this during Holiday travel - installing and testing on my V+ now.

I wonder when Geofencing will finally be fixed?

1 Like

Upgrade went flawlessly, initial tests look good and nothing unusual in the logs. This is my main home production unit so I’ll know better in the next 24 hours or so.

Upgrade went well here. I didn’t perform any testing but it was fairly quick to. I came from 7.29.

I’m still doing post upgrade fixes though like deleting extra firmware not US related. Would be nice to not have to deal with that.

Also, still removing ergy from crontab.

Still no issues observed. I did fresh post upgrade zwave network backups uploaded to the server.

nice im waiting on the extroot version @rafale77

Well it succeeded on the Edge where the 1.7.30 didn’t, except that the RFXcom isn’t working.
error msg: Choose the serial port.
I’ll open a support ticket and let CS work it out.

I have two RFXtrx connected to my Vera Plus. The upgrade to this Beta version failed. I tried again with the RFXtrx disconnected and it also failed. But on both occasions I had to reload Luup and then go to Apps -> develop apps and select serail port configuration. There you can select the baud rate and then select your RFXtrx device from the drop down and save it.

Thanks, had to set the baud rate in both to get it going.
Weird why the Port Config was changed?

edit: Finally found out what a lot of unknown devices were thanks to the com port failure, appears they are RF433 sensors Now I need to track down what they are.

So did the upgrade to 7.31 beta work in the end?

1 Like

Quick and easy upgrade. No issues observed sofar.

Is it faster and more relyible compared to 7:29?

Anyone that fels big improvment ?

Happy New Year everybody!
/ Mattias

I missed it as well. Upgrade was smooth, apart a conflict in lighttpd (as it’s occurring to me since the latest 3 or 4 fws), so I had to change lighttpd.conf and remove auth module.
I will report back with my findings, if any.

Happy new year!

Upgrade worked well on my test Edge, no issues.