Updates for EZLogic - 1.5.1 (Ezlo Hubs only)

Updates for EZLogic - 1.5.1 (Ezlo Hubs only)

Link: https://ezlogic.mios.com
Previous 1.4.1

Updates:

1. Local MeshBot. Triggers. Latch Function.

We provided name (1) for LATCH function block and reset latch (2) button.
image

Note: we will provide more ways to reset latched triggers and will expose status is trigger currently latched on UI soon.

2. Local MeshBot. Triggers. Date and Time.

How to schedule a MeshBot to run at a specified time every day?
Use Date and Time → Custom time → At a time of day and specify the time.

3. Prevent token expiration.

If you use EZLogic more than a day you will not see expired session screen, we will regenerate token automatically.

Fixes and improvements:


Thanks for your feedback!
2 Likes

I don’t know if this started with this update or not, but as of this morning I am unable to get in to edit existing MeshBots. After clicking the edit button, I just get a blank page. After some time the console window shows an “Unhandled Promise Rejection: AbortError”, but nothing ever shows up on the page.

I’ve tried to create a MeshBot Automation that should arm a motion sensor at a a specific time (monday to friday at 9:00 am):

That trigger didn’t work. So I changed “Custom time / After” to “Custom time / At a time of day” and saved the automation. After re-editing the automation it changed back to “Custom time / After”.

Also note if you do use the Custom Time “At a time of day” if your controller is offline at that specified time and then later comes back online again, the rule will not be triggered and actions not run as the schedule has been missed.

I would recommend you use “After” instead as that one runs up until midnight. So when the controller comes back online your schedule is still run albeit at a later time.

I do not have this problem. I can change the Custom Time to various different once and when I edit the rule it remains on the last one I selected OK.

I do not have this problem either and I can edit existing rules OK.

I suggest both of you clear your browsers data and cache and try again.

I’ve cleared the browsers cache without success. However I noticed the following:

When I select “After” and klick the save button I get to the Meshbot overview with the message “MeshBot successfully saved”.

When I select “At a time of the day” and klick on the save button I remain in the scene editor.

I just tested again and its definitely working OK for me. I created a new rule with “After” and saved.

I then edited the rule and changed “After” to “At a time of day” and saved OK.

What firmware version is your hub? And Advanced Scenes version?

image

image

I’ve created a new scene with just one event “At a time of the day” and switched it to “After” and vice versa. That did work. But If I add another Trigger “AND Days of the week” only “After” works in combination:

If that’s an non-working combination there should be some kind of error message.

Another thing I’ve found:

If I enter " in the Action Notification in the field subject or message body the browser page goes blank and I have to reload it.

This trigger should fire up every monday to friday at 9:00 AM, but it doesn’t. Am I wrong in my reasoning here?

Trying it now from my home computer on the same network as the controller, it works. So either it is something about the network it was on when I was trying it, or the computer/browser I was using. Interesting.

I only had one trigger added not two.

Looks like a bug then.

I tried it seems you cannot save the rule if you have two triggers “At a time of Day” and also “Days of the week”

But as you said you can do that when using “After” and also “Days of the week”.

I have reported it to them as a potential bug.

…and now my home computer is showing the same blank page when trying to edit issue. It worked yesterday, but not today. Tried it in both Safari and Chrome with the same results :frowning:

EDIT: I just realized, this is only happening with some of my Meshbots. Others seem to open without issue. So that explains why I thought it was working earlier - I had tried a different meshbot, which did work. The ones where I have e-mail notifications set up, however, do not.

I am getting the same blank screen on my browser when I try to edit a Meshbot with both days of the week and a specific time of day as triggers. Other Meshbots can be edited per normal. i do not have e-mail notification turned on for the Meshbots that can’t be edited.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules