Update enable setting on Ezlo Hubs

Does this setting do anything? When I first got my Ezlo Plus the firmware was several versions behind. I had to request support to get it updated. It’s behind a version now - not a big deal for me at the moment - but I tried to turn off 'Update enable" and the setting visibly changes but if I go back to it later it’s still enabled. I thought I’d disable it and later enable it - possibly triggering an update. But obviously that can’t work if it’s never really disabled.

That setting did work previously in the past when I tried to disable updates on one of my Ezlo Plus units, it did then stop the auto firmware updates from happening.

Perhaps something has changed and broken it since?

Probably better to have that setting enabled and reboot your Ezlo hub to try and force it to update to the latest firmware that way.

If the setting is not staying as you set it, maybe that is a Ui issue in the browser. Try clearing your browser cache data.

@Alvaro_Ochoa can you assist here pls

I logged in using a different PC - a laptop. Also it seems you can only log in from one host at a time so logged out from my desktop PC. From the laptop I could turn off update enable and it seemed to hold that setting. Logged of from the laptop and the on from the desktop and from there could see that update enable was off. I don’t know anything really about web page design with regard to caching but I would expect these settings to refreshed from the hub.

One would think so. It should pull the current settings state from the hub and display the correct state of that setting in the web UI.

Another way to double check, would be to check the controllers settings in the Online API Tool web site.

You can send this “custom” command to return the hubs settings, which can then be seen in the result output.

  "method": "hub.settings.list",
  "id": "_ID_4",
  "params": {}

Mine is “true” meaning the setting is enabled.


BTW after turning off Update enable I rebooted the hub - and then enabled Update enable and rebooted again just to see if I could trigger an update. Nothing so far - still at But again it’s not urgent for me - just a curiosity.

I am not up to date with the current firmware version numbers that are out, but I know your controller has to be enrolled in to the beta program for it to receive the latest beta firmware updates.

You’d have to speak to a member of staff about that which I am not.

I think the most recent non-beta was announced here: LIVE - Ezlo Linux FW release for Ezlo Plus, Ezlo Secure controllers

Well one would assume “Live” and “Production” means a none beta release as you say, so your hub should get it.

My controller is on that version now I just checked it.

Hi @tinman ,
The default behaviour is of course as you say it takes the setting from the hub. And it refreshes the cache.
However there may be bugs/different behaviour on some versions of chrome or other browsers. As you already tested it works on another browser. So it seems there may be an issue specific for your case on desktop.
And for the auto update feature, it should check and update to the latest non-beta build automatically if the setting is “ON” so let our customer team check it @SaraV

Actually my laptop and desktop each are running Firefox. And both are on Win 11.

Hello @tinman!

Could you please share your unit’s serial number via PM to verify its settings?

Will keep updating you on this forum thread.

@tinman thank you for sharing your controller’s serial number. I just checked on your controller’s settings and disabled the updates for your controller in order to check if the changes were made. This is the broadcast I got from the API tool as soon as the hub.setting.value.set call was sent.

    "method": "hub.setting.value.set",
    "id": "_ID_",
    "params": {
        "name": "update.enable",
        "value": false

Broadcast received:

                "name": "update.enable",
                "value": false,
                "valueType": "bool"

Could you please confirm if you can see updates disabled from your end? Could you please let me know how did you set the value initially in order to try to replicate the same behavior?

Viewing it from MiOS Smart Home I can see that Update Enable is off. I’ve only ever changed this setting from this web page.

I’ve checked on your controller and enabled the setting again but from the website.

It seems to be updating the value and giving the proper broadcast after the set was made. Could it have been the website’s cache?

                "name": "update.enable",
                "value": true,
                "valueType": "bool"

Could you please give it a try again and let me know if it still doesn’t work even after clearing it?

OK, the setting was enabled. I disabled it, refreshed the page and it remained disabled. Enabled it again and it seems to be working now.

Thank you for the confirmation. Feel free to reply back or tag me if further help is needed on this!

It’s been a month now. From above we can see that enabling and disabling auto update works as expected. But my Ezlo Plus hub is still at