Unable to Upload or Install a plugin

We have created a plugin that works well if we manually install it via scp. However, when we try and upload it via the ezlogic UI, we get an error “An error occurred while add plugin”. I downloaded the Wake on LAN plugin, and tried to upload that. That uploads correctly. But I cannot install the Wake on LAN plugin on my controller. I get “An error occurred while installing”. The default Node test plugin also fails to install.

Has anyone gotten either uploading or installing to work? Or is this just a “not yet ready” feature. If you have gotten it to work, any ideas on why it isn’t working for us?

1 Like

Hi @richK

Previously, if you could perform this action of uploading the plugin from ezlogic, now since the last 3 updates it has not allowed you to upload it again.

Could you tell me how you did to upload it by scp? We also have a plugin that works fine but has not allowed us to upload it.

Thank you!

We can upload the plugin manually if you have a local connection to the controller. Just like ssh, you can scp to root@IPAddress of the controller, and upload the plugin code directly to the controller, not using the UI. This is fine for development, but not for deployment.

I don’t understand, we have never had a successful upload of our plugin to the UI. What do you mean by not allowed to upload again? Are you trying to update the plugin?

1 Like

Oh!!! Ok, earlier if it allowed us to upload the plugin and install it on the gateway. Now it shows us that error.

When they uploaded this update we began to see that error, if you read there is my post with a gif where you see the error Updates for EZLogic - 1.11.1 (Ezlo Hubs only) - #9 by maksympc

hi @JoseC , @richK we introduced the prefixes for the plugins.

Did you try creating your prefix here first and then udating your config.json file with it. Then try uploading your plugin again pls.

1 Like

Hi @osman How are you? Yes, we have already carried out the process, I attach some gifs of how it was done
plugin
plugin2

1 Like

I get the same thing. Even after defining a prefix, and putting it in the config.json file, I still get the error on upload. Is anyone able to upload a plugin at this time?

1 Like

Only administrators can install and activate plugins on a site. If you are the owner of the website, then you need to ask your developer to make sure that you have administrator permissions.

I am trying to upload my plugin to my account via the mios UI, as described in the instructions. I have no idea what you are talking about when you write about administrator privileges for the website.

Hi @jessica.bullet , @richK
There is no usage like administrator privilige or activate a plugin.
You can check our help documentation on develeoper.mios.com. or we have it posted on the forum MiOS new plugin framework and documentation

It is still not working for me. I was previously able to get the Wake on LAN plugin to upload, but it no longer does. I even added the prefix too the WoL plugin’s config.json file as shown above, and it will still not upload.
I tried the ezlo_protocols plugin also. It failed to upload.

What am I missing? Any suggestions? Does the prefix need to be in the tar file name or something?

@richK it should not be called prefix, give it any name to add it in the litsa of the prefix section, and then put it in all the files,
1-config.json for example : “id”: “security.mqutt” and in the part that says “setitemvaluecommand”: “HUB: security.mqutt…” , “setsettingvaluecommand”: “HUB: security.mqutt…”
2-interface.json for example: “script”: “HUB: security.mqutt…”,
3-scripts example: loadfile(“HUB:security.mqutt…”)
try that way

@andersoncamero Tried this with both the Wake on LAN and ezlo_protocols plugins. Added the prefix as you suggested, and both still fail to upload.

1 Like

Hello @richK

I will double-check once more with the team and the changes that are required in order to upload the plugin, thank you for your comprehension.

@richK This is what needs to be changed in order to upload the plugins

  • config.json
  • interface.json (In case it includes the extension name)
  • Any LUA Scripts that include the extension name
  1. Config.json:

  1. LUA files referenced:

Check the name, label and scripts that include the extension name.

image

Finally add the prefix to the Plugins settings page and then try to upload the tar.gz file.

Let me know if you continue to have problems and if so, please share the plugin if you can.

Still doesn’t work.

This is what I did:

  1. Grabbed the latest version of ezlo_wol from this thread:
    Ezlo - Wake On LAN Plugin is on the marketplace! - #4 by cw-kid
  2. Verified that my prefix was still in the mios Plugin Settings.
  3. Added the prefix to the ezlo_wol/config.json file as shown above. Added the prefix to all “HUB:ezlo_wol” as: “HUB:prefix.ezlo_wol” calls.
  4. Created an updated ezlo_wol.tar.gz file.
    tar -zcvf ezlo_wol.tar.gz ezlo_wol/
  5. Tried to upload the ezlo_wol.tar.gz file (Verify that “MY PRIVATE PLUGINS” is selected. Click the “UPLOAD NEW PLUGIN” button, select new ezlo_wol.tar.gz file, click “UPLOAD TO MY ACCOUNT”).
    Result: “An error occurred while add plugin”.
1 Like

Hi @richK I can help you. can you upload a gif showing the step by step?

Hi @richK

Can you share that same tar.gz file you were trying to upload?

We can check what is happening.

Here is the tar.gz file.

I renamed it so people won’t confuse it with the original. It was named ezlo_wol.tar.gz when I tried to upload it.

Let me know when you have it, so I can remove the link.

I accidentally deleted the file. Here is a working link: