Unable to login to my vera account on home.getvera.com

I had some issues using a third party app I use to connect to my vera plus controller this morning. Upon trying to login to my home.getvera.com account I was met with login issue. Using my usual login info which is stored in chrome, I received an unknown user or password error. I then tried to reset my password and was met with an unknown user message. I don’t believe I deleted my account and since I cannot see that information in my vera unit without first logging into my account I am kind of stuck. Any suggestions?

I am the same. Can’t log into https://home.getvera.com/users/login

I am getting Incorrect username or password message but they are correct.

Same here when i try to log in to the portal i get Incorrect Username Or Password

I have the same problem on 2 different controllers in 2 different cities.

Same here @Sorin There appears to be some issue chap


Same here. My Amazon Echo integration wasnt working. I went to reset the skill and it told me incorrect password. I tried the “forgot password” option then it tells me my uid/email doesnt exist.

I’m having the same problem this morning. No access, reset password, nothing working.

Same with me. Looks like server is down.

I’m going with significant outage at their end. Alexa can’t do anything and I have alerts that are waiting to upload.

Oddly the status page maintains that everything’s fine :wink:


Same here. Also cant seem to access the controller directly itself by IP. Sticks with a spinning green loading icon

It’ll probably get there eventually but I suspect it’s spinning its wheels trying to talk to Mios.

Mine was awfully slow to get in (trying to get details on FW update) but is OK ish now.

Status page still saying all is fine…


Hi everyone, thank for your reports. Apologize for the inconvenience, guys are investigating this and will come up with an update.


Same here.i get Incorrect Username Or Password

don’t try to reset your passwords, it won’t work. so you can try to login with your existing password when everything is back.

1 Like

Use local login when this happends

Local log in? What witchcraft is this?


1 Like

@Catman I guess he meant when you are on the same network you can login with VERA IP address.

Same problem here. After Alexa refused several times in a row to perform a standard action (“Turn on Computer” - which is a virtual switch on my Vera Plus), I realized there must be a GetVera server issue afoot.

Nevertheless, I followed Alexa’s suggestion (of Disabling / Reenabling the Vera Alexa skill), only to encounter the same issue others are reporting here. Namely, that my known-good GetVera login credentials kept getting rejected.

Fortunately, the problem did not last long, as I was able on my fourth or fifth try to login, and at least get the skill enabled. Still, one last hurdle remained:

Note the “Server is Unresponsive” warning at top of this screenshot. This meant having to turn on my laptop using its physical button.

Living like a savage!!

  • Libra
1 Like

Well you can access, but there’s no login (i.e. user / pass that allows you to do stuff that needs you to be logged in) that I’m aware of


Hi guys, things should be back shortly but there’s a queue going on and might take a while for the service to be fully restored.

Official communication here: Important information about your Vera system

I’m sorry, everyone.

1 Like