UI7 - Vera Firmware Update - Version 7.0.31 + new Cloud storage service (1.7.5185/1.7.5186/1.7.5187) - September 2nd, 2020

We are pleased to announce that we’re releasing today Firmware v.7.0.31 + new Cloud storage service for the following controllers:

  • VeraEdge: 1.7.5185
  • VeraPlus: 1.7.5186
  • VeraSecure: 1.7.5187

New Features:

  • Added support for upcoming VistaCam 1200 doorbell camera

Changes & Improvements:

  • Replaced the cloud storage for camera recording resources (recordings & snapshots)

*Please note that after uploading the video to the new cloud storage the processing of the videos can take some time.
Also due to the changes done on the upload mechanism in case of multiple recordings using cameras that don’t support http push you will receive an error in case the memory on the controller is exceeded.

Starting October, 1st we’ll use exclusively the new cloud storage we released in this firmware version. If you have cameras added to your VeraEdge/Plus/Secure controller please upgrade until the end of the month. If you won’t upgrade, the recordings and the snapshots won’t be available anymore for you starting October.


  • Fixes the issue with the live Streaming stopping in about 50-60 seconds after starting video recording
  • Fixed the issue with video quality for saved videos that was very low for mjpeg cameras

Known issues:

  • Video records from VistaCam PT have only 8-15 seconds (on the old implementation/storage the length of video was 19-20 seconds)
  • Some of the mjpg files are not encoded in mp4 format
  • Storage option is mission from the Web UI under the camera settings on VistaCam 1200

Previous known issues (targeted to be included for the next release):

  • Storage page on Vistacam 702 doesn’t load in some scenarios in the Web UI.
  • Wrong error message being displayed on the Web UI when the VistaCam 702 camera is disconnected.
  • Buttons overlap current date when viewing live image on VistaCam 702.
  • Issues on VistaCam 1200 where the ‘Configuring’ message/bar is still displayed even if camera is already configured.
  • Controller reboots and engine reloads while recording videos on multiple old cameras.
  • Not able to manually change day/night extra setting on Vistacam 700 from the Web UI
  • Error message being displayed when trying to update Weather Settings without changing Temperature Format.
  • Issue reported on units that are bridged, with devices on the slave units that generate alerts on the master unit , every time the engine reloads. The issues was reported for door locks.
  • Not being able to control Hue devices with the Philips Hue 2 plugin.
  • Icons/templates for UV Sensors and Generic Sensors have no space between “Level” and the value for “Level” is not being correctly aligned.
  • Associations handled from web UI are still handled securely even when the device has been included insecurely.
  • Issue with previous notifications added being still present in user_data after Reset Z-Wave Network was done.
  • Plugin startup messages is not being displayed correctly on dashboard cards
  • Job watch callback is not receiving job number
  • Error message about snapshots, recording, live view are displayed multiple times on cameras.
  • Disable “Broadcast SSID” not working from Settings"->“Net & Wi-fi” ->select “Manually configure (advanced)”;
  • Lights are turning off while live streaming page is open on Firefox, when the option to turn on the light when user view the camera is be enabled.
  • Preset modes Frost /Confort / Confort-1 / Confort-2 aren’t properly set on Qubino DIN Pilot Wire device.
  • Issue on Vision Glass Break & Shock Detector VSN-ZS5101US where In step two no content is displayed in Device Wizard.
  • Burglary alerts are received without template.
  • Not being able to change setpoints in scenes for GoControl GC-TBZ48 thermostat
  • Issue on Aeon LED Bulb (ZW098) when changing color back to white the color is changing to ‘blueish’ white.
  • Yale Door Locks has some incorrect message being displayed when trying to add restrictions to pin codes that are not displayed in clear (“****”)
  • Smart switches with category 3 and subcategory 3 ( in Wall Switches) are displayed with wrong icon in cpanel/setting section.
  • Issue on the Web UI with not handling times which don’t contain seconds when editing an existing scene.
  • Not being able to add Foscam C2 third party camera using the add device wizard
  • Aeon Smart Switch generating ghost child devices after pairing.
  • Not being able to remove multi-channel association on Gerber GPS-2000 devices.
  • Not being able to set weekly restrictions on Schlage BE469ZP and BE468ZP locks
  • Child devices are missing for Philio PST03-1A 4 in 1 Multi-Sensor after pairing.
  • Issue on Qubino ZMNHJD1 (Pilot Wire) with no mode is selected when a scene is run with action set as Confort-1/ Confort-2 if mode number set to be suported by Qubino ZMNHJD1 (Pilot Wire) device is 4
  • Qubino Flush On/Off Thermostat 2 is not being configured during the secure inclusion process
  • Controller is removing log files even though the process to upload them to servers has failed.
  • Device category name inconsistency for RGB Bulbs between Web UI and mobile platforms.

Do you have any sales blurb / specs or images of this new camera yet ?

I will wait for some feedback before updating


Proceed with caution my Vera Edge is not happy now.

I pressed the upgrade button and I did not see the usual page that asks you if you want to backup first.

I just saw this screen and continue to see this screen.

The WIFI and Z-Wave lights are not lit up currently.

Power and Service lights are solid and Internet light is flashing

1 Like


I’ve just submitted a support ticket (230553) please have it raised to 2nd / 3rd line support ASAP in case there is a wider issue for other users here?

After some time Vera has just come back to life on its own and its has not updated.

So I took a manual Z-Wave network backup and a system backup.

Then tried the upgrade again, this time I am seeing the normal upgrade screens, I did not see these the first time when it went wonky after clicking the Upgrade button.

And this time its completed OK. No idea what all that was about…


Just successfully updated V3+ without any issues.

1 Like

I’ll wait too. There seem to be only a few changes with cams and I don’t want to run into the controller online/offline error I got with the last few firmwares.

Just updated my Vera Plus, no issues.
Had to do it to get rid of the update nag.

1 Like

This seems to be a minor update for functionality and a few minor fixes? Aka, not worth it unless you have cameras.

Hi there, I gave a heads up to our customer care team.

A serious problem, sent also to the Vera support team

After updating to the newest firmware, it is not possible to make an z-wave back-up (tried several times, also after restart same problem

This is the message:

A serious problem, sent also to the Vera support team

After updating to the newest firmware, it is not possible to make an z-wave back-up (tried several times, also after restart same problem


After 6 months, this firmware update, with this content, sound like a joke…

1 Like

Did a reboot by power of and on waited 20 minutes that worked, I was able to make a backup again, hope there are no further issues

I crossed my fingers and went ahead with the upgrade on our Vera Plus this morning. No problems and I was able to complete another backup after the upgrade.

I tried to upgrade mine. Failed and now will not reboot. Currently internet and power light are flashing alternately. I can connect via putty and winscp.

I have same issue, looks my vera is brick now…Tried to factory reset but no result.

I didn’t try to reset or restore a backup or even reboot the Vera unit.

I just left if alone for maybe an hour or more and then it just came back as I said and I was able to do the upgrade normally.

Vera support emailed me today. This is all they said so far. I will try and get more information out of them.

"Thank you for communicating with Tech Support.

This is going to be handled by a level 2 support technician.

I accessed your controller and saw that there’s one problem with the Openwrt version of it, this will need to change, is it ok if we proceed to do so?

Note: all your settings and devices will be fine and won’t be lost.

Best regards,"

I told them to proceed as this Vera Edge is just a test unit not my production Vera Plus, which I haven’t upgraded yet.