UI5: Scene Controller Running Wrong Scene

apologies for the multiple posts – I was having problems with my forum reader.

Vera 2 / 1.5.254

I have a brand new GE 45600 scene controller. I have defined 9 different scenes to be triggered by “A Scene is active” for this device. Each scene has a single trigger and is assigned to a different button.

After defining all scenes I re-included the scene controller (hold SETUP, press 9-6-7) to resync/transfer scenes with vera.

Pressing the buttons triggers the assigned scenes as expected; however, most of the buttons also the scene not assigned to that button, but to another button.

If I press on for scene #1, it runs the scene associated with #1 (correct).
If I press on for scene #2, it runs the scene associated with #2 and scene #1.
For #3 it runs #3 and #2.
For #4 it runs #4 and #1.
For #5 it runs #5.
For #6 it runs #6 and #2.
For #7 it runs #7 and #1.
For #8 it runs #8 and #1.
For #9 it runs #9 and #2.

This is verified by watching the dashboard as I press each button and seeing both the correct and wrong scenes run.

Anyone else seeing this behavior?

Bug entered. http://bugs.micasaverde.com/view.php?id=2083

[tt]http://forum.micasaverde.com/index.php/topic,5614.0.html[/tt] might be related.

I don’t have access to that forum – can you summarize?

Sorry for the link to the private forum.

Scene button 8 of my Remotec Z-URC 550EU (node id 185 and id 16853) activates the corresponding scene and a device that is part of a scene that is assigned to scene button 1.

Related topics:

Bug report:

[quote=“Ap15e, post:4, topic:170261”]Bug report:

Thanks, Ap15e. That bug was entered just under a year ago and assigned 6 months ago… What’s the over/under on this being fixed before the aeon labs outdoor multi-sensor is released?

Luckily I know a better way to run scenes from a hand held device :slight_smile:

I just upgraded to the lastest UI5 beta and thought I’d give this a go to see if it got fixed. Nope.

Press button #1 and the correct scene runs and verified in Vera display.
Press button #2 and the correct scene runs
Press button #3 (nothing programmed to that button) and scene #1 runs but pressing off on button #3 doesn’t turn off the device
Press button #4 and the correct scene runs
Press button #5 and scene #1 runs again and can’t be turned off using button #5
Press button #6 (nothing programmed to that button) nothing happens
Press button #7 (nothing programmed to that button) nothing happens
Press button #8 (nothing programmed to that button) scene #4 runs again and can’t be reversed using button #8
Press button #9 (nothing programmed to that button) nothing happens

If something is assigned to button #3 and/or #5, the assigned scene will run AND scene #1 will also run. Vera status for both scenes confirm that both were run by single 45600 button press. Didn’t know that a single button press could run more than one scene, but it does.

Assignments to buttons 10-18 cause the remote to flash the green LEDs as if commands are being sent, but nothing happens to devices associated with those buttons and the Vera display does not indicate the scenes have been invoked.

At this point, all I’m able to do with this remote is to run a couple of scenes, and I need to hunt for the buttons that don’t cause more than one scene to run at a time.

Looking in the Advanced tab for the remote device, the list of scenes and the desired button assignments are correct and unique. Something must be getting screwed up in the communication between Vera and the 45600. I have a couple of 45600s and they all have similar problems.

While it is nice to have a remote that can manage 4 or so scenes (especially one that is this cheap), that’s a far cry from the theoretical 18 possible for the device. Based upon others who have previously posted to this thread, it’s likely that our troubles are not unique. Just wanted to share my experience with these gizmos to help others make informed choices. They may not live up to expectations.

It is possible to transfer all network info, including scenes to the secondary controller such that it can operate without VERA.
This means that when pushing a scene button on the remote, the remote sends commands to the devices in the scene.

At the same time, VERA tries to run the same scenes when a scene button is pushed, so it might be that 2 controllers try to run the scenes in parallel.
Is this relevant ?

Got a chance to play with that a bit last night. It’s flaky for me also. At first glance, what the remote emits seems consistent / ok.

If you transfer the scenes back to the remote, and then power Vera off, for diagnostic purposes, you may get better behavior.

I’ll write a bug report.

I have noticed that things got worse lately. Before I only had 3-5 scenes, and they were fine. Maybe the newer firmware changed something?

Now, I have a few more, and they are slightly different. So sometimes (maybe 40% of the time) when I hit scene 2 (which is nearly identical to scene 3 except for a couple lights should be off in scene 2, but on in scene 3), I get some of the lights popping on and immediately turning off.

It’s almost like Vera thinks (well knows) the lights should be off, but the remote thinks they should be on. So the remote turns them on directly, and when Vera sees the scene button pushed, she turns them right back off.

I’ll experiment more tonight. I’m wondering if this is caused by a “take it slow” problem, like the Monster scene controllers. We are confusing Vera with too many button presses in too short a time frame? ???

From what I saw it appeared that Vera is interpreting the button presses in a ‘funny’ way, and multiple times, depending on the button; yet what the remote was sending seemed consistent.

I don’t know if it ‘ever’ worked, say on UI4 with 2.78 Z-Wave (but the remote doesn’t seem free of issues, given the problems getting devices assigned to individual buttons (which has been reported in conjunction with controllers other than Vera)).

I, too, occasionally have seen devices turn on and then immediately turn off again when invoking scenes using the remote. It seems to happen most frequently when the offending device has recently changed state. I don’t usually see that happen when the devices haven’t been altered for some time.

I’m in agreement with oTi@, Vera seems to be the one doing the funny business. If I watch my control panel after pushing a button on the remote, I can clearly see Vera running the 2 discrete scenes, one appropriately and the other inappropriately. I didn’t imagine that it is possible to invoke two scenes from a single button assigned to a single Vera scene, but I see it all the time when using this combo in Scene mode.

It’s almost as if Vera is interpreting the button press as a Group of scenes wherein it makes up some of the scenes belonging to that group. Interesting and frustrating at the same time.

Did you notice any improvements after the latest firmware releases ?

I see that you are on 1.5.346. I just updated to that firmware version. The strangeness continues concerning the errant scene activations, but I haven’t repaired the remote to Vera after the update. I’ll try to do that this evening and get back to you.

Is there any particular reason to believe this problem was addressed in the latest update? I imagine it would be good news if this is straightened out as ebay seems to be flooded right now with cheap offers to sell this remote.

It is an existing bug with remotes according to this:

There was another bug reported that I can’t traqce easily.

So probably not resolved but hopefully given some attention soon.

I had a chance to give it another shot this morning. The problems continue under the most recent update. Scenes that weren’t applied to buttons tend to run anyway. In some cases, multiple scenes are invoked with a single button press. Hitting the off option for a button with an errant scene assignment gives a green flashing led as it tries to undo the mischief but ends with a red led flash to indicate it wasn’t successful in it’s attempt.

Some of these problems have been worked around by manually assigning groups. In most instances, I want whole groups of devices to go on or off at the same time. That works fine. I guess the main reasons to go with scenes would be situations that require some devices to be turned on while other devices are turned off and/or scenes involving devices using other protocols, is that pretty much it?

The OFF-button does not work, which is why you see the red flashing LED.
It seems one can only use the ON button to evoke a scene.

I found this one quite useful:

[quote=“Turk4U2, post:16, topic:170261”]The OFF-button does not work, which is why you see the red flashing LED.
It seems one can only use the ON button to evoke a scene.

I found this one quite useful:

So they are working on it:


I looked at the bug reports you linked to. I hadn’t thought to try unhooking Vera and seeing if the 45600 would run the scenes correctly. Turns out it does! The green led flashes much longer than usual with each button press which ends with a single flash from the red led. Looks like the culprit is Vera and how it is responding to the remote’s key presses.

MCV is missing an opportunity to capitalize upon the situation presented by the current supply of cheap 45600s. We’re talking about X10-like prices. The remotes are incredibly handy and make living with Vera much more pleasant. Comparably speaking, the iPhone/iPad options are slower and more cumbersome. Access to cheap remotes has made it possible to place one in multiple locations. It’s an enabling situation. I couldn’t predict ahead of time how much nicer that would make things. It’s made me more inclined to extend further into the realm of HA.

It’s also helping to win over the Mrs. She doesn’t do geek, but she will, happily, pick up a device and push a button. The 45000, flawed as it is, has been a turning point for her attitude on all this. That could be good for MCV. After our burglary, her comments resulted in quite a few of her friends installing alarm systems and/or updating their existing ones. If she warms to Vera, maybe her friends will, too. So, MCV, please fix the problems with this remote ASAP and maybe that will help us help you.


I’ve found that the off button does work for scenes, so long as all the devices in the scene are zwave - with the caveat that sometimes the Vera/45600 get their wires crossed and make up things. Disconnecting Vera made it possible to turn on scenes and turn them off as expected by using the 45600.

The problems I’ve had with the off button have involved scenes containing INSTEON and/or X10 devices. Vera/45600 will put those devices to the intended state with the ON button, but the off button only affects the z wave devices. That problem relates to the problem discussed in the link in your recent post.

Similarly, I’ve noted that the remote usually ends successful commands with two green led flashes. The red led flash seems to indicate a problem in communication, either with a device or Vera (which I guess is also a device). It’s not normal for either the ON button response or the Off button response - at least in my limited experiences with the beast.

I continue to be delighted that folks are keeping this topic on the front burner. I’d love to see this issue resolved.

I absolutely agree! $6/remote is crazy. Another issue though is that whenever you “update” your 45600, it wipes out the Light and Group associations, so you have to roam round the house to set those up again. What a PITA. So for my 45600s, I’m not using Vera-originated scenes and for my HA07, I’m only using Vera scenes and no specific device associations.