Syslog to paper problems


This app is absolutely perfect for what I need, until tonight I had never heard of syslog servers but it is exactly what I need… The only problem is I can’t get it working… I’ve obtained the domain name and port from ( a syslog company that seems to offer the services I require without charging the earth every month) and put this into the syslog variable in th event watcher setup page but it only seems to log locally…

Papertrail automatically detects new systems when they begin logging. No additional Papertrail configuration is needed. The same destination can be used by many systems.

The fqdn is this: where X is a number

The site also states

Accept unrecognized senders Accepting TCP (TLS), TCP (plain text), UDP

Hopefully I’m missing something obvious and you can point me in the right direction… Or maybe to an alternative syslog provider that definitely works



I run syslog locally on another machine, so don’t know about remote hosting.

EventWatcher uses UDP datagrams to send data to syslog, which should work to any accessible IP and port. It’s not a firewall problem is it?

You do need to use the IP number, not the URL, of the website.

Oh i thought it had been updated to allow fqdn… The syslog service only provides the above so unless they give me an ip address to send to, it won’t work?

Also what ports does it need open to send syslog data?



You’re absolutely right! As of v16.07.01 it should work. So if you’re on the latest, that’s OK.

Also what ports does it need open to send syslog data?

They should provide you with the (in fact, you said they did.). Shouldn’t need any port opened at your end, but firewall should allow UDP (should be doing that anyway.)

You ought to be able to look up their IP address and try that if the fqdn doesn’t seem to work.

I’m not sure I’m on the latest version or not… I installed the version from the app store and that server out of date so i deleted the device ane reinstalled manually via github files as per your post in another thread and now when i go into device, advanced, variables in version it says this “2014.01.23 @akbooer”…


Definitely not the right version. Should be 2016.11.16.

Files are here:

Deleted device
Installed new version (create device, implementation = I_EventWatcher.xml, device = D_EventWatcher.xml)
Several luup reloads and a vera reboot

Now getting startup failure… But at least it now says version 16.11.16 lol
If i go into logs it just says “no handler”…

Thanks for your help and patience lol


bizarrely I installed the app store version then uninstalled (thinkng it might clear old files) then reinstalled github version… created device… and it started working… until a luup restart… then it comes up lua startup failure again…


Uninstall will not delete any files. It possible, perhaps, that something outdated is lying around. Vera keeps some files in /etc/cmh-ludl/ and also /etc/cmh-lu/.

How did you install the GitHub files?

Download zip from github
Unzip on pc
Go to develop apps > luup files, upload files
Reload luup
Create device > I_EventWatcher.xml & D_EventWatcher.xml
Reload luup

Is it worth ssh ing into vera to delete the files?


How did you create the new device… manually, or prom the plugins page?

Went into
Apps > develop apps > create device

So it sounds like you’re doing all the right things… just not getting the right result!

From the Develop Apps > Files window, download the EventWatcher.lua file and check that at the top the version matches what you think you downloaded.

Take a look in /etc/cmh-ludl/ and see if any EventWatcher files are in plain text, rather than compressed. Actually, you may also scan the Files list to see whether there are apparently any duplicates - this may be symptomatic of the same.

I’m sorry this is causing you such problems… seems like we’re missing something glaringly obvious, but just can’t grasp what that might be.

I think it must be something I’m doing wrong as I’ve just tried installing latest version from scratch on another vera (ie no residual files) and getting startup failure in that as well… Ive checked the lua file you mentioned and it says version 16. 11. 16… However i checked L_EventWatcher2.lua and that said “2013.12.28 @akbooer” maybe that’s where I’m going wrong? Just off to check github now for a more up to date file


That the library file, which hasn’t changed for years AFAIK.

I don’t have any subdirectories visible… I’m just wondering but in the instructions it says to ssh into it to create a new directory and add files there for something which I didn’t do because you said that feature doesn’t work in ui7… Possible cause? I’ll see if i can ssh into it later to check for any subdirectories not listed in the ui to check the items you mentioned earlier

I think what we need here is the log during startup to see a more explicit error message (perhaps.)

I’ll do that now. Fyi the files in cmh-ludl are. Lzo compressed

02 07/09/17 13:00:17.155 Device_Service::MatchupUpnpServices no upnp service for urn:akbooer-com:serviceId:EventWatcher1 <0x775c6320>

50 07/09/17 13:00:24.275 luup_log:27: EventWatcher: starting… <0x76c14520>
50 07/09/17 13:00:24.275 luup_log:27: EventWatcher: 16.11.17 <0x76c14520>
06 07/09/17 13:00:24.276 Device_Variable::m_szValue_set device: 27 service: urn:akbooer-com:serviceId:EventWatcher1 variable: LuupRestart was: 09-Jul-2017 12:58:03 now: 09-Jul-2017 13:00:24 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x76c14520>
50 07/09/17 13:00:24.277 luup_log:27: EventWatcher: defining CLI… <0x76c14520>
01 07/09/17 13:00:24.279 LuaInterface::CallFunction_Startup-1 device 27 function init failed [string “ABOUT = {…”]:1294: attempt to concatenate local ‘ip’ (a function value) <0x76c14520>
01 07/09/17 13:00:24.279 LuImplementation::StartLua running startup code for 27 I_EventWatcher.xml failed <0x76c14520>

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules