Supported IP-cameras / manually adding camera?

I’ve got two D-Link DCS-900 cameras which weren’t automatically detected. I was wondering if this is because they’re not supported and/or if there is a way to add them manually.

This is a mistake. We’ll fix it right away. There was an option to manually add devices. It got removed by mistake. We’ll put it back before the next firmware upgrade planned in a few days.

I’ve used Axis brand camera’s before. Any idea if they are doing Z-Wave cameras?

ZWave is really too slow for a camera. The throughput is much less than the 40+ Kbps claimed.

Wow. I didn’t even realize that the camera’s that Micasaverde is selling were nothing more than network cameras.

I guess it really doesn’t really matter. I’m glad they have an interface for the camera’s anyway.

I am using a panasonic WV-NM100. It was not autodected. I can access images by going to http://mycameraip/cgi-bin/camera … this returns a 640x480 image. I tried to add the camera manually in vera by changing the IP address to my cameras IP address and changing the “#2 Path” to cgi-bin/camera. This does not work. Any thoughts?

The cameras we sell online are normal IP cameras. The only thing we do is: 1) run Panasonic’s proprietary setup program and configure the camera to get an IP address automatically. For some reason we can’t figure out Panasonic decided to make the IP cameras by default get an IP address and immediately release it, so the cameras aren’t usable until they’re configured. 2) We set a default username/password of dceadmin/dcepass. This is the default that Vera will attempt to use when a new camera is discovered. 3) If the camera is wireless, we set the wifi name and wpa2 key to match the unique one for each customer’s own Vera.

The purpose is to make it easier for novice users since the camera will work immediately out of the box. But, they are normal IP cameras and if the user knows how to configure them, he can use any IP camera that retrieves a JPEG frame. Today’s firmware upgrade adds the ability to add non-Panasonic cameras by hand.

Looks like this didn’t make Firmware version 1.0.283.

An option just appeared at the bottom of my devices page to add an IP camera. I have a BL-C131A, so I’m not sure if it just detected it.

The option doesn’t seem to setup the camera properly. I had to manually input my ip and mac addresses. After doing so, it still doesn’t display an image from the camera.

I noticed that in the advanced section after adding a camera, the “Controlled via” defaults to “Computer”. I noticed that there is a “Generic IP Camera Manager” in the dropdown list, but changing it to that won’t save.

That’s really weird. Now I see it too. I wonder if something was still cached when I looked at it the first time. Testing to see if I can get it to work.

I finally got both my cameras working, but setup was very difficult. Got it working by trial and error.

Here is what I had to do for each camera:

  1. Click button to add the camera to the desired room.
  2. Input username and password
  3. Click on the + tab
  4. Don’t bother inputting anything in the “simple” view.
  5. Click on the advance button
  6. Switch in “Controlled via” from “Computer” to “Generic IP Camera Manager”.
  7. Fill in ip and mac address (note when you go back they will clear out… not sure why)
  8. Click Save
  9. Refresh the web page (e.g. CTRL+R)
  10. Go back to the device section and click the + on the IP camera
  11. Fill out the options in the “simple” view and reenter the ip & mac address.
  12. Refresh the web page again

Forgot to tell you to click save between 11 & 12. Make sure you save before you refresh the web page.

Well, I can’t get my D-Links to work.

It seems to be making a request to the camera, but all that comes back is:
HTTP/1.1 200 OK
Server: ControlMyHouse
Content-Length: 26
Content-Type: image/jpeg

501 Method Not Implemented

Turned on full logging but the 10-Generic_IP_Camera_Manager.log doesn’t contain the actual URL/request it makes to figure out what it is trying to do and whether the path I entered actually works the way I think it should.

Looks like this didn't make Firmware version 1.0.283.

Actually it did. If you’re not seeing the pull-down at the bottom of the devices page that lets you add a camera, try hitting F5 to refresh your browser’s cache. This is always a good idea after an upgrade anyway.

The option doesn't seem to setup the camera properly. I had to manually input my ip and mac addresses.

If you manually add the camera you do need to input the IP so Vera can find it, and the mac address so the dhcp server will know to always give it the same IP.

Then you need to click + after you add the device, put in the IP/Mac, then click 'Advanced, and in the ‘path setting’, put in the path to retrieve a JPG file (without the http://[ip address]). This needs to be the path to the jpg file itself; not an html containing the jpg file. Bring up the page in the camera to view the image, right click on the image, and choose copy location. That’s what you want to paste.

For the panasonic the Path setting is: low=/SnapshotJPEG?Resolution=320x240&Quality=Standard
This means that this:
(assuming the camera is .111) returns a jpg file. If the camera requires a username/password, put them in under ‘authuser’ and ‘authpassword’ near the path setting.

This does work. The challenge is that since all the cameras do things a bit differently there’s no way to make it universal for all cameras. If the camera you have is a popular model that others will want to use, let me know the make/model and path, and we can add it to the plug and play database so it’s added automatically like the panasonic.

The issue with the IP/mac disappearing is a bug. It might be related to the cache issue which was fixed in the 283 firmware. I created a bug report to have someone look into it:

[quote=“micasaverde, post:16, topic:164027”]For the panasonic the Path setting is: low=/SnapshotJPEG?Resolution=320x240&Quality=Standard
This means that this:
(assuming the camera is .111) returns a jpg file. If the camera requires a username/password, put them in under ‘authuser’ and ‘authpassword’ near the path setting.[/quote]

As I mentioned earlier, I have a couple of D-Link DCS-900s. The path to them is simply http://ip.address/IMAGE.JPG and I’ve entered “IMAGE.JPG” into the path in the settings (along with the IP address and MAC address for good measure). They currently require a user name and password which I’ve verified several times. The authentication is a standard HTTP auth.

It looks like Vera is making some other type of request, maybe using the incorrect HTTP verb, but I couldn’t find a way to debug that via the logs (and don’t have time to start capturing traffic to see what’s going on). The response ends up from the camera being “501 Method Not Implemented” so this is the basis for my assumption that the request isn’t sent (or there is something wrong with the authentication) correctly.

Would you mind calling us and letting us in to take a peek with remote assistance? It should work, so we can get it fixed for the next firmware release if we can figure out what’s going wrong.

Is the default in “Controlled via” (advanced mode) set “Computer” also a bug? Should it have defaulted to “Generic IP Camera Manager”?