Siren turns off after a minute

I have a Everspring SE812 siren that turns off automatically after a minute. I think that it is automatically happening via the Vera Controller because the message “Success, transmit was ok” under the graphic. Is there a way to override this or increase to more time?

Might be configurable as a parameter setting

Also I suppose you could have your scene simply re-trigger the alarm after 60 seconds, again after 120, 180, … as many as you like.

I dont think that it is the siren that is doing this, it looks like Vera Ui7 is doing it becasue after a minute, the siren shuts off then the message “Success, Transmit is ok” shows below the SIren graphic in Devices.

According to the manual the alarm once triggered only runs for x seconds. default is 3 minutes (180 seconds) but it can be modified. The sister product SE813 shows parameter 1 as the config setting for duration of the siren. Perhaps its the same for SE812.

You should be able to modify that in Vera by setting the value you like under /devices/your siren/device options/ then add a configuration setting for Variable 1, 2 byte, and set for anything 1- 600 seconds…

Vera UI7 I believe by default turns on the siren when some armed sensors are tripped, so perhaps that is what turns it off also after 1 minute.

You need to turn this off in Dashboard - My Modes in the section named “What to do if an armed sensor trips?”

Then have a scene or a couple of scenes that turn on / off the siren when your desired armed sensors are tripped.

I have the same Everspring SE812 siren and mine does not turn off after 1 minute.

I also just checked its Z-Wave device parameter settings and I have none set at all by the looks of it.

What is really weird with my Modes, the Siren does not appear in the list “What to do if an armed sensor trips?”. All of the other devices (door locks, relays, lights and outlets) show up in the list, but not the siren for some reason.

Not sure then, we woud have to compare our Everspring siren devices and their settings, like category and sub category.

So my Everspring SE812 Siren looks like this on my system.


And in the Advanced - Params area of the device:

device_type = urn:schemas-micasaverde-com:device:Siren:1
device_file = D_Siren1.xml
device_json = D_Siren1.json
category_num = 24
subcategory_num = 0

If yours are the same? It should appear in the “What to do if an armed sensor trips?” area in My Modes I should think. I don’t recall doing anything special to make it appear in there.

The only parameter that was different was the catergory_num = 3, however changed it to 24 just like yours and still not in the list. what is weird is that I added a virtual switch and it appears in the list…therefore I know that this is not a limit issue. The siren just does not want to appear.

You will have to reload the LUUP engine first before it appears. Go to Settings - Z-Wave Settings - Advanced - Reload Engine and click that Go button, also refresh your browser.

Correct Device Category numbers are listed on this web page here.

Siren is 24 not 3 which is a Switch.

it shows up now, thanks for your help

OK now ensure its all turned OFF for the siren in the “What to do if an armed sensor trips?” area and then try your scene(s) again that are meant to keep the siren on for more than 1 minute.

However, what I cant understand is, if I turn on the siren manually via the on/off switch on the graphic, it still times out after a min? I have excluded it and then reset the siren, then added again and still same issue. what is weird also, is that after it turns off after a minute, the message “Sucess, Transmitt ok” appears below the graphic. This is why I think that it is the Vera system turning it off automatically instead of a siren timeout.

I turned off all in “What to do…” and just tested the scene and manual activation, still turns off after a min. Frustrating, LOL.

Ok well least the siren is configured correctly now and you have ruled out that its not the My Modes doing it, so thats something.

I cant test my siren now as its late but will maybe tomorrow to double check it stays on for longer than one minute which I think it does.

Next you need to see which scenes are using the siren device?

I assume you are just using the native Vera scenes? And not also a 3rd party rules engine like Pleg or Reactor.

When you go in to the siren device click scenes at the bottom it should list any active scenes.

And yes it seems strange if you manually turn on the siren it auto turns off after 1 minutes. Some Vera thing must be doing it.

Also on that same screen check Device Options also are any parameter settings set?

If not like mine, that page should look like this.

very sure that nothing in Device Options is doing this as I completely exclued, reset the device to factory and re-included. I am firing via PLEG, however I know that there are not any other scenes that are shutting it down as I just started programing the last few days ago (as I just recently upgraded from Ui5 to Ui7), ive also double and tripled checked my programing. I just manually programed from old settings in Ui5 to Ui7. It never did this in Ui5, which is why I find this totally bizarre.

So there are no native Vera scenes referencing the Siren device correct?

And no Z-Wave parameter settings set by the sounds of it, if you reset the device to factory.

But you are using Pleg. Long time since I’ve used Pleg but I did use it for years before.

So what have you setup in Pleg so far? In relation to the siren device.

There must be something some where turning it off.

Ill test my siren tomorrow and let you know if it stays on for more than 1 minute.

100% sure that PLEG is turning it off after a minute. I have double and triple checked the programming. I have programmed a lot with it in the past and am only learning the differences between Ui5 and Ui7 as there a differences, however conditions and actions have not changed much. What is strange is that there are lights that turn on at the same time the siren is turned on, these stay on as they should…just the siren shuts off. Totally weird.