Schlage Lock PIN Codes - Displaying Codes instead of ****

After a frustrating experience attempting to get my Schlage lock working after my upgrade to VeraPlus/UI7, I finally bought a new one and it’s working fine. However, I have a question…is there any way to show the actual PIN codes in the interface, rather than having them obscured with ****? There is a checkbox at the top of the PIN code form that’s labeled “Show PIN codes in clear.” I thought perhaps that was an unusual way of saying “Display the actual PIN codes” but checking that box doesn’t change anything - I still only see ****.

Is this a known issue? Am I overlooking something obvious?

I have this issue with my Yale Real Living lock. The pin codes were displaying properly for me, and then I added one. Now they are all showing “****” despite the setting of this checkmark. ??? ???

Any workarounds?

I just installed a BE468 CAM 619 for my VeraPlus controller using the “generic” device.

If you program some codes directly from the lock, these will not be able to edit. This is a GREAT feature so these codes are secured from most hacking.

If you want to manipulate Codes from VeraPlus then create them from the VeraPlus “code” interface. Then you will be able to see everything.

I hope this helps.

I am having the same issue and hope this can be corrected by a software engineer.
When the pin is entered and the box is checked, the PIN number will show up, but if the box is unchecked then rechecked, the pin is not shown and the display shows, ****

I have the same problem with a brand new Yale Lock, I program everything with the Vera but after a while appears **** instead of the 4 digit pin, any idea about how to solve it.

[size=2]Hi there,

This functions as intended.[font=verdana]“Show PIN codes in clear.”[/font][font=verdana] is checked by default, For example, if you door lock us already included and pin codes added, they will be shown in clear by default, but if you uncheck the box, all existing codes and new ones will be shown as masked. Checking the box again, will NOT unmask the pin codes (security measure). If you want the codes to be visible again, you will have to delete the existing masked codes and add them again from Vera’s interface.[/font]


[font=verdana]! Pin codes added directly from the keypad of the lock will always be masked, no matter if the [/font][font=verdana]“Show PIN codes in clear.” [/font][font=verdana]is checked or not. If you want the codes in clear, please add them from the interface.[/font]

[font=verdana]! In some rare occasions door locks might get reconfigured automatically, in which case the existing pin codes will get masked. This is usually caused by an issue with the lock itself and the z-wave chip inside it. Also, sometimes, codes might still be present on Vera’s interface but masked, but they won’t actually work on the lock. This happens because the lock has hardware issues and loses the codes from it’s internal memory. This is a hardware issue of the lock. Might consider replacing the z-wave chip from the lock, add a new set of batteries and/or replace the lock entirely if necessary. This can be checked with the manufacturer of the lock itself as well.[/font][/size]

Sorry John that just sounds like a bug to me, not a security feature, as no other Alarm company manages pin codes that way.

If the check box is only good for revealing the Pin codes once, than it should have a big warning that unchecking the box will make it so that the pin codes are not unmaskable ever again. Ironically new pin codes will be shown in the clear so I now have a few codes that are in the clear and a few that are peminently masked.

All alarm company/z-wave integration UI that I have seen allow you to show and hide the pin codes at will.

The correct behavior here should be, by default show the mask. If I select the check box, temporarily show the pin codes (if known obviously you aren’t going to know the ones that were entered at the device). If I uncheck the box or leave the page, revert back to masking the codes. I should be able to do this procedure as many times as I want.

What it sounds like is happening is when you uncheck the box it is telling Vera to forget the pin codes so that they can’t be shown in the clear anymore. That is a bit silly unless Vera is incapable of storing the pin codes securely for future retrieval and display.

My workaround for this issue is to just add the pin code to the code name. So:

Pin Name: John 1234
Pin Code: 1234

I do this for both my Schlage and Yale Locks.

[font=verdana][size=2]@shallowearth - feedback has been passed on to R&D, I’m just trying to explain the mechanics behind the process. I’m sure there are some hardware caveats imposed by the z-wave [/size][/font]technology, we have to work around. Anyway forwarded your valid point of view, and if something can be done, it surely will.

Just came upon this, after trying for a while to get my pin codes to display on my Schlage deadbolt

Amazing that once you uncheck “Show Pin Codes in The Clear”, you can never get them to display again. Seems like a good place for a simple warning asking if that’s your intent…

Fairly simple UI stuff. Sigh. Making it simple to accomplish an unintended and irrevocable task is the opposite of Good UX. “Functions as intended”. Indeed.

Onward Vera Soldiers!

I’ve just come across this PIN code display problem too. This is a poor way to handle PIN codes. I have computers and security systems so I don’t have to write things down. I want Vera to keep track of the PIN codes I’ve assigned. Now I’ve got to call all of my PIN code holders to ask them for their PINs. Most probably won’t even remember so I’m starting all over again.

Is there going to be a fix for this?