RGB Color Number Help

Not sure what you mean about the cancel and submit buttons.

Do the lights now change colours using the colour picker box in the Vera Web UI?

No, unfortunately not. I can select the color I want from the picker, but it seems there’s nothing transmitted to the lights.

Maybe that was one of the issues with the V2 module then, really can’t remember you’d have to read those threads.

So I take it that it’s not working via Home Remote either then.

Not working anywhere. I’m still researching on both the Vera & Home Remote communities.

Thank you so much for trying to help.
Bob

Yeah this guy on this thread says the native Vera colour picker wasn’t working.

And I link to another longer thread in that thread. Not sure if there was a solution found?

And Home Remote likely doesn’t support the RGB Controller plugin devices. Not sure I’d have to test and try one.

What happens if you do that? or have you tried already adding an RGB Controller plugin device instance into your HR dash page.

Yes…I’ve tried using the RGB Controller plugin device. That plugin uses a strange color code: #8000090000. I’ve read the threads you’ve mentioned…seems an ongoing issue. Bummer.

Maybe ask Bill the dev on the Home Remote forum. Maybe he can add support for the RGB Controller plugin devices.

As I don’t think Ezlo will fix the old Vera firmware now for this Fibaro V2 module.

Will do. Thanks again.

@cw-kid…so, after much digging, I couldn’t find a remedy to the RGB Controller issue, so I thought I’d try my hand at a down-and-dirty Plugin. I’m doing everything via HTTP requests to Vera. The one major issue I’m having is changing the RGB Controller device. Here’s what I"m sending:

http://MyVeraIP:3480/data_request?id=lu_action&output_format=json&DeviceNum=466&serviceId=urn:upnp-org:serviceId:RGBController1&action=SetColorTarget&newColorTargetValue="#1580000000"

Would you mind taking a quick look to see if you spot anything. I thought you may have a better understanding of luup. Seems the “action” and “target” items are the issue.

Thanks

I will have to try it, don’t think I have sent colour commands directly to an RGB Controller plugin device instance before, certainly not by HTTP I don’t think.

What colour should #1580000000 be ?

I will have a play about with it see if I can get a working http command going.

I just got this code line to work but in LUA.

It did change the RGB Controller plugin device from its current colour to Red OK.

luup.call_action("urn:upnp-org:serviceId:RGBController1", "SetColorTarget", {newColorTargetValue = "#FF0000"}, 434)

I then tried this HTTP command, but removing the quotes around the hex colour code and that also worked and changed the light to Red.

http://VERA-IP/port_3480/data_request?id=lu_action&output_format=json&DeviceNum=434&serviceId=urn:upnp-org:serviceId:RGBController1&action=SetColorTarget&newColorTargetValue=#FF0000

Think you need to use RGB HEX Colour Codes etc.

Red - #FF0000
Green - #008000
Blue - #0000FF

I don’t know what #1580000000 is ?

Think they have to be six digits which makes your code a Green colour

image

https://www.color-hex.com/color/158000