Fibaro FGRGBW-442 configuration?

I knew when I picked it up that others have had some troubles with this module, but I thought I could possibly work through the issues. I think I may have been wrong.

I’ve added it to my Vera Edge running 1.7.4969 (7.31). It pulls in a number of devices as expected. I’ve figured out and renamed the main controller, the dimmer device and the RGBW devices plus what I assume is the inputs/sensors that I’m not using. I’ve changed the device_file/device_json to the corresponding DimmableRGBLight2.

It does “work”. I also have an Aeotec RGB LED strip that I had to also change to DimmableRGBLight2 and then it works decently well with the built in UI7 color picker so that is what I am use to. With the Fibaro RGBW 2 I can adjust the RGBW with the individual devices no problem. The “dimmer device” also works. The dimmer on the “main controller” works as well. However the UI7 color picker on the main controller does not work. The color does not change using it. The box showing the current color will however eventually change to the current color based on how I have the individual RGBW devices set.

I know that I can(and am currently using) the old RGB Controller plugin to control it. I also understand that with the old “v1” of the fibaro RGBW controller that the default UI7 color picker also worked. So why is it not working with this “v2” controller?!

I could be fine with using the RGB Controller plugin except that the color wheel from it does not appear on the Vera mobile app… I’m not likely to change the colors that often, but I don’t want to HAVE to use a web browser to get to my Vera to do it.

I’ve tried a few things but I don’t want to rule anything out so if anyone has ANY ideas please let me know.

Not to derail the convo but if anyone has suggestions for other RGBW controllers I’m open to them as well. Qubino? Monoprice? etc…

EDIT* I’ve ordered the zooz controller to try. I have until the 10th of august to return the Fibaro part.

The Zooz controller is the same part as the Fibaro RGBW dimmer V2 (same FCC ID and even says made by fibaro on the label) and suffers the same issues. sigh

It’s really unfortunate that these new parts aren’t working properly with Vera.

The only other recent talk about the 442 device can be read on this thread. I would ask your question in there. I only have 441 devices myself.

If you use an RGBW 441, the right value is 0x48 (72) and not 0x9d (157) Becareful, you should use hexa value
I think animation programm are between 6 and 10 but this is not specified on the doc I have for the 441

I think the default value is good for the 441 but you can see it in this lua file L_RGBController1.lua

I hope it would help you


I think the OP is stating that the native Vera colour picker isn’t working. Can you confirm it’s working for you?

Also please upload your modified . lua file for the Animations with the RGB Controller plugin.

Sorry but I don’t use the native verra colour picker. Using both can create unexpected situation.
Best is to use only the Plugin.
–> luup.call_action(SID.ZWAVE_NETWORK, “SendData”, {Node = pluginParams.rgbZwaveNode, Data = “0x70 0x04 0x9d 0x01 0x” … toHex(programId)}, 1) Replace 0x9d by 0x48

Normally, the default settings are good for you. You have only to do the change I have posted if you use the 442

Thanks for confirming the Lua code you are using with the 442 for starting animations.

So your not able to tell us if the Vera colour picker works with the 442?

The animations can be started easily via scene/code but I don’t care about them. I started playing with the test luup code page and the parent device simply doesn’t respond to newColorTarget or newColorRGBTarget. The only way of adjusting the color is by controlling the individual color channels either via the interface or via luup code. That’s the reason the RGBControl plugin works, it manipulates the individual color channels.

I looked at some device handlers for smart things yesterday(HERE) to see if I could figure out what they were doing. It looks like the “child device” others in the 441 thread are calling the “dimmer channel” may actually be a color or hue channel on the 442. My attempts to change that to D_DimmableRGBLight2 and issue color target commands to it have failed.

I’ve hit a wall at what else to try. I think we may need a firmware update to make it function like the 441. I’ve ordered the monoprice controller to give a shot. I’m returning the fibaro 442, but I may keep the zooz Zen31 to play around with or possibly help the Vera devs figure out how to make it work if they want. Plus, I have another place I will probably install some LED’s but likely will only manipulate via scenes which I can just run a few lines to adjust the individual color channels if it doesn’t get fixed to work “properly” with the Vera. I consider the RGBControl plugin dead and don’t want to use it. It needs to work with the native color picker.

EDIT* I forgot to add that it appears these new controllers use COMMAND_CLASS_COLOR_SWITCH V3 and the older rgbw controllers seem to use COMMAND_CLASS_SWITCH_COLOR V2(looking at the qubino rgbw controller manual) . I’m not 100% what that equates to or what makes them different. I can’t find much info on it.

EDIT again**
Fibaro 441 controller Command Classes
Fibaro 442 controller Command Classes
Quibino(same as monoprice) flush controller Command Classes

Actually when comparing the command classes for those 3 controllers the 441 and quibino list “basic” as a control class while the 442 does not. Maybe that’s something? I’m just grasping at straws. The list of vera command classes doesn’t appear to have been updated since 2016 so who knows if that is current, but it doesn’t list any version of SWITCH_COLOR, which leads me to believe it’s the “basic” control the 442 may be lacking(EDIT* looking at the 442 manual does list the basic class… sigh…). The Aeotec LED strip I also have that works well also lists “basic”

1 Like

I’m having massive issues with the Fibaro rgbw-442. It successfully adds a device but when viewing the device list it shows the channels as individual dimmable lights along with a number of other devices. These do control the various RGBW channels however I can’t seem to set parameter 14 to 21845 to turn all channels on with a toggle switch. I have three older version 1 RGBW controllers and theses all work perfectly.

Any help would be greatly appreciated.

Edit. I have made some progress changing parameter 23 to 1d hex set as 3. It now works with a toggle and remembers the previous state. All the devices still have random names and their states don’t match what the light is actually doing.

2nd edit. the toggle only affects output 4 from input 4. I want one input to control all 4 outputs. Is that Parameter 150 setting to 1 rather than default 0?

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules