Release Notes - Ezlo Linux Firmware LIVE release for Ezlo Plus and Ezlo Secure Vera Edge controllers

We’ve released a new Ezlo Linux Firmware LIVE release for Ezlo Plus and Ezlo Secure Ezlo controllers and Vera Edge running Ezlo Linux fw

New Features:

  • Added support for sending logs to Cloud during firmware update and reset process


  • Implement LED behavior for different battery states.


  • Fixes & improvements on connectivity

Known issues:

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state
  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)
  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF
  • Issues with some Door Locks, as Danalock V3, that are not added with S2 encryption

Not sure when you guys did it but BRAVO on moving from dropbear to OpenSSH 8 for ssh! :clap: :muscle:

I would suggest that the migration scripts should have copied the authorized_keys file from /etc/dropbear to /root/.ssh as a convenience because it took me a while to figure out why I wasn’t able to ssh to my controllers.

Another suggestion is to allow users to configure the authorized_keys via the GUI or API so a user who disables password authentication in the sshd_config is able to reset/replace the keys if something happens to the keys during an upgrade that prevents the user from accessing their hub.


Zooz ZEN77 Dimmer still not integrated? I put the request many weeks ago:


Hello, @echino
Your request ECS-474 is currently assigned to one of our engineers and we’re working on it. Keep in mind that integrating a device takes time, and don’t forget that it’s one of our priorities. Eventually we’ll get it fully integrated.

Thank you for your patience.

Is there any new device intergration in the last time? I didn’t see any new integration message since 2021-Feb-22.

New integrations are underway, but given the number of them, it takes time to get them all rolled out, so we thank you for your patience. I do see plenty more being posted internally since February, but I’m not in the position to post those publicly. They will eventually do so here.

You can find the latest updates on device integration by the link:

1 Like

I have a older version on my Vera Edge. How do I update?

Thanks for all

Hello @myrus,
Follow the next steps to upgrade the firmware version of your VeraEdge:

  • Log in to your account at and connect to your controller.
  • Go to “Settings” → “Firmware”.
  • If you have a pending firmware upgrade, you will see the next page:
  • Click on the “Update” button to do the upgrade process.
  • If the current firmware version is too old, feel free to contact the Technical Support Team at so they can do the upgrade.

But if you are already on 1.7.5185, how do you update the linux version. I am not seeing an update button and no manual download link, am I missing something?

Hello @Scarab,
You can follow the instructions here to upgrade your VeraEdge to the Linux Firmware. Please note that 1.7.5185 is the latest official version released for VeraEdge and upgrading to Linux is optional and for customers that want to try the new features.
Kind regards!

When I click that link I get “Oops! That page doesn’t exist or is private.”

I did find a similar named article before here: How to upgrade to new Linux Firmware on Vera Edge - Company Talks / Official Announcements - Ezlo Community

Though it concerned me as the the link provided is for Vera4Lite, and there is now way in the GUI to view the linux version just the firmware version.

It is strange that the link is not taking you to the right place, I’ll take a look into it.
However, the article you found has the same instructions and links. Don’t worry about the words VeraLite being written on the link, you can tell it is the right link because it has the code G150 on it and because the Linux Firmware is available (among Vera controllers) for VeraEdge only.
Kind regards!

I was “able” to perform the upgrade, though now the unit is not accessible via the app, and am unable login via SSH.

I have power cycled it and so see the unit as online in the app, but it times out connecting while I am on wifi.

Just upgraded to this version after several months that the unit was powered off, upgraded seems to ok, however I can’t access the “Unit Settings” I get the following screen:

Hi @nirgal,
Please try uninstalling the app, restarting the phone, and then reinstalling the app. If this doesn’t solve the issue, please let us know here or at
Kind regards!

Issue was solved by uninstalling and installing .


1 Like