Reactor Safety Lockout


I have a Reactor Safety Lockout error. Can you advise / suggest what to do to get things up and running agian??

The safety lockout occurs when Reactor detects that your system has restarted too many times in too short a period. This is a new feature of the 3.4 version under development, so I’m guessing you’ve recently installed that to test notifications. VeraAlerts can have you doing quite a few restarts (every time you leave the editor after making any change). So if you’re going back and forth between VeraAlerts and a ReactorSensor playing around (which I myself have done many times), or just tweaking the messages one at a time, you can end up restarting a surprising number of times.

I’m still tuning to figure out what the “best” default values are for the sensitivity parameters MaxRestartCount and MaxRestartPeriod. The current defaults are a bit low. Try setting these (on your Reactor master device) to 10 and 900, respectively, and see how it goes. That’s max 10 luup restarts in 15 minutes (900 seconds). That should be unusual, but if not unusual enough for your system, put in what you think makes sense.

Version 3.3 users, this thread does not apply to you.

Thanks for the prompt response. It came back to life on its own after a bit of time had passed. Everything is working spot on.

Yes, it’s meant to self-heal. This will evolve a bit yet before final release.

I too encountered the Safety Lockout. I changed the settings as suggested. Anything else I have to do to refresh the system as at present none of my Reactors are functioning.

Usually just waiting a few minutes and then doing a luup reload is all it takes. If you’re in a hurry, set the “rs” state variable (on the Reactor master device) to 0 (zero) and restart luup.

You should also have a comfortable explanation for why your system was restarting so much, though…

The Reload fixed the Reactors which were otherwise disabled for 24 hours. No idea why so many restarts. I had just created a 14 group Reactor and was editing device names.

If you rename a device or change its assigned room in the device’s control panel, An alternate way is to go into the Advanced > Params tab for the device and modify the name there, which does not cause a restart.

All reactors look like this.

Please Review Thread Reactor Safety Lockout - Reactor - Ezlo Community

12 Hours later.

Ironic as it may sound, you need to reload Luup to recover.

Is that the same as “Reload Engine” or “Reset Zwave Chip” in settings?

I found allot of posts about Luup Reload but not how to do it. Thanks. Appreciate your vids.

Answered my own question. That worked!

1 Like

That’s “Reload Engine”. Easy ways…

  1. Go into any device’s control panel, to “Advanced” tab, to “New Service” subtab… there’s a “Reload Engine” button there;
  2. My personal favorite, go to Apps > Develop apps > Test Luup code (Lua), enter and run: luup.reload()
  3. Slightly bigger bat: go to Settings > Net & WiFi, there’s a “Reboot” button there.
1 Like

No shortage. Thanks.

Your vids on Reactor helped allot. Thanks for taking the time and work. Our house has several outdoor lights that were almost useless except for decorative effects. Using reactor I was able to add motion detectors and much brighter lights that are kept on a dim setting during the lights on period and go bright with motion. Indoors motion has dual use as well. Thank you.

1 Like

Quick note here; The safety lockout does not seem to self heal… I removed and added some devices yesterday, and subsequently got locked out, but this morning it was still locked. Luup reload fixed it, just thought you’ like to know if it’s supposed to self heal. :slight_smile:

For convenience, could there be a button in reactor master to reset this when you know why it happens? adding several new units would definately set this off, and as I didn’t know about the RS variable, i couldnt set up reactors for the new units at the time.

1 Like

That reset would have been useful this morning, but no biggy :smiley:

Hi all,
Iam a huge fan of reactor but after the last update (via tools/Update Device Information Database) I can’t use it anymore.
On my main reactor I see the message ‘Safety Lockout!’ and when I click on it I see a red ‘Reactor.Can’t Detect Device message’.

On the real reactors I get the red ‘can’t detect device’ message.

Can you tell me what I can do so I can use all my reactors again? I hope someone can help.

Kind regards

did you search the forum?

1 Like