Pre-Alpha Ezlo API Testing Tool

Hi @melith,

That works if the device is still on the controller. But is it is not you cannot exclude it without a standalone exclude function. In zwave you can always exclude a device even if it never was included in the controller. Useful in many situations especially if your controller does a spontaneous reset and wipes its config, or second hand devices, or , or…

Cheers Rene

not my experience…that button starts the process…and you can unpair the device even if its paired with another controller…(like a rescue :slight_smile: )…I use it all the time as i test many different controllers i take a device paired with controller A and unpair it with controller B…try it…its a “general exclude” functionality …I got that put in as soon as I bought the company…i couldn’t operate without it :slight_smile:

1 Like

Aha, you must have a iPhone. The Android app does not have this. It can only Add and delete an existing (unless it is an Alexa, i have a ton of those I cannot get rid off even with a complete deinstall).

Cheers Rene

1 Like

hmm…just checked an android device…you are right…we have an “escapee”! we’ll get that put in on android asap!


Indeed the Android doesn’t have an easily accessible button in the devices view, however it does allow the unpair of any devices, including ones from other hubs.

You can go to any device’s advanced settings tab and click the “Trashcan” icon. You will get a pop up asking for confirmation and which will give the options to cancel the operation, delete the device (if it was a defective one) and unpari the device. If you click unpair the controller goes in unpair mode and the app displays the “Remove devices now…” message. At this moment you can unpair only the device you started the process from or any other zwave devices.

Another option is to try adding the other devices directly, using the specific device model wizard, or the generic zwave wizard. When you get to step 3 and the pairing fails, you can hit retry and this will make the controller go in unpair mode and the app displays the “Remove devices now…” message. At this moment you can unpair any other zwave device.

I hope this helps

Thanks @Gabi,

I did not go that path as I was not sure what the controller would do. If all it is go into exclude mode that this will work on any device indeed. Nice one for the FAQ.

Cheers Rene

Just found an issue with the api test tool. It seems that I can not set the mode switch delay because the switchToDelay field is purportedly missing.


  "method": "hub.modes.switch_to_delay.set",
  "id": "ufp067q3j5p",
  "params": {
    "switchToDelay": "30"


  "error": {
    "code": -32500,
    "data": "rpc.unknown.error",
    "message": "Unknown error",
    "reason": "switchToDelay field is missing"
  "id": "ufp067q3j5p",
  "method": "hub.modes.switch_to_delay.set",
  "result": {},
  "sender": {
    "conn_id": "4981b7dc-8aa7-4fa4-bc4a-8d00667520da",
    "type": "ui"

You can see that the switchToDelay parameter is in the request json so I am not sure what is happening…

Please advise.

forwarded your request to the team and will back with the answer asap.

1 Like

@Oleh Would it be possible to have an API request to generate a Authentication Token, that the user could then use in http request and curl commands. Or the ability to add a user defined auth token in the Ezlo app, or generate one.

You saw this earlier?

They also announced we will be getting access to a local Http Api with not authentication earlier as well.

1 Like

Yes i saw it.

great step forward, but it should be accessible in the app or API. No need for another step/application,. How many users will be frustratted trying to make it work not knowing what or how or where to run the python script. It would be nice to keep security, but simplify it.

1 Like

@blacey thank you for let us know about this issue, we fix it and now the API Tool should handle the parameter as expected.

I was able to confirm the fix BUT now if I close the session and re-open it to my ezlo controller, I am not able to select any hub commands to send. Did you guys change anything else?

Aside the fix nothing else have been changed. After closing the session and login again you should select your hub and connect to it to enable the drop-down menu with the hub commands. The only reason to fail doing so is if suddenly the hub loses internet connection. I have just tried and it worked, however if you keep having the problem let me know to investigate.

I’m finding that it works with my Atom2 but not with either of my Ezlo Linux hubs (ezlo plus and vera edge) running 1.1.988.4. Are you able to connect to an ezlo linux hub and perform queries?

I have tested with a Vera Edge running the same version of Linux fw you reported, and I’m able to switch between it and a PlugHub V1 without problem, closing the section and login again. I will add more hubs tomorrow to my test account to see if I manage to replicate this case.

Works for me this morning.

I tried to post a screencast of the issues but these forums don’t allow anything other than static images in select formats. That said, the symptom is that neither of my Linux hubs allowed queries after connecting but the Atom2 hub does. I noticed similar behavior for an Atom that I did not have plugged in.

So, I tried rebooting one of my Linux hubs and I was able to perform queries again. This means that there are 2 core issues.

  1. The connection between the cloud and the hub on Linux FW was in a state that required a reboot to recover (not good). The hub that I rebooted was 90000330. My hub 45006642 is in the same state but I will not reboot it until I hear from you so you guys can diagnose and determine the root cause. @Melih and the engineers know where to find me on Skype if you would like to reach out in a more interactive fashion for diagnosis.
  2. There is no feedback on the apitools webpage that informs the user that it is unable to connect to the hub. Or, it connected to the hub but in a state where queries were not possible. Either way, the apitool should provide some sort of error feedback to the user and ideally a recommended remedy.


I had to reboot my Ezlo Plus and re-login to be able to send queries otherwise the spinning wheel on “connect” did nothing.


Not sure if this is possible with the system you are using?

But I would like the API TOOL to also display a HTTPS command for the queries you make.

For example, this query will turn on my Z-Wave plug socket.


And the Response looks like this:

I would also like to be shown a working HTTPS URL command for the same query I have just done.

For example this is the correct HTTPS command to turn that same plug socket on.

But I’ve had to work that out myself.

Can the API Tool as part of its response or broadcast, give me this HTTPS command / example.

So you can more quickly work out what the HTTPS commands should be, for use with the Ezlo HTTP Server API ?

If not we need more detailed documentation of all the possible HTTPS commands we can use, rather than me just fumbling through it trying to work it out.

For example I currently cannot change House Modes with a HTTPS command because I don’t know what the correct command is ?

Yet I can change house modes using the API Tool.