Pre-Alpha Ezlo API Testing Tool

Hi developers,

We’re pleased to release the Ezlo API Testing Tool which helps you to test the Ezlo API with a physical Ezlo hardware:

  • Ezlo Atom
  • Ezlo PlugHub
  • Vera Edge that runs Ezlo Linux FW - to get this on your unit you must be part of the Alpha testing group

How to use the tool:

  1. Login with your existing Vera account (same account you use for Vera mobile / webUI);
  2. Add the SN of the Ezlo hardware you have under your account;
  3. After logging in, simply select from the list the API you want to see results for and select “Query”.

Please note this tool offers you the ability to test the API posted here, NOT the LUA API.


great job guys!
we want to empower the developer community with everything they need!

1 Like


It does not have all api calls, but I could include and exclude a device using it. A quick way to exclude a device for now :slight_smile:

So funny first test.

Cheers Rene

1 Like

Hi @Ioana,

I want to see if I can use the API from a PI on the hub LAN Ethernet interface. But when I try to open a socket on port 17000 is comes back with a connection refused. What am I missing?

Cheers Rene

@reneboer, Do you have avahi-utils installed on your RPI? If so, you might want to try avahi-browse _ezlo._tcp --resolve unless you already have, to confirm the port #. On my Mac, the Bonjour search shows the _ezlo._tcp service but no associated items. Maybe I’m missing something but in my quick look, I don’t see anything listening on port 17000 on my Edge?

root@HUB45006642:~# netstat -tulpn | grep LISTEN
tcp        0      0  *               LISTEN      1852/spread
tcp        0      0 *               LISTEN      1905/ha-networkd
tcp        0      0  *               LISTEN      1528/dnsmasq
tcp        0      0*               LISTEN      1528/dnsmasq
tcp        0      0*               LISTEN      1528/dnsmasq
tcp        0      0*               LISTEN      1528/dnsmasq
tcp        0      0    *               LISTEN      1188/dropbear
tcp        0      0 ::1:53                  :::*                    LISTEN      1528/dnsmasq
tcp        0      0 fe80::d621:22ff:fefc:bac7:53 :::*                    LISTEN      1528/dnsmasq
tcp        0      0 fdb9:1071:df31::1:53    :::*                    LISTEN      1528/dnsmasq
tcp        0      0 :::22                   :::*                    LISTEN      1188/dropbear

Hi Blacey,

Looking at the firewall config that also shows port 17000 for the websocket communications, so it should be the right one. But you are right nothing is listening on that port. I guess they forgot to tell us what is suppose to working rather than the vaporware what keeps getting communicated. As you can hear I am far from happy with Ezlo at the moment. The openLuup + zway route sounds more tempting by the hour. Or some other, established controller for that matter.

Cheers Rene

1 Like

It must be a bug in the latest firmware that escaped regression testing because the API tool advertised in this thread doesn’t work either. If I reboot my Edge, the _ezlo mDNS service is advertised briefly but eventually disappears so there is something from preventing it from working. Interestingly, my Atom doesn’t show up either but it may not be running the firmware with the exposed local API.

You clearly aren’t alone these days. Ezlo seems to be working very hard to do their part but this invaluable community will be instrumental in either the success or failure of the platform so we either all win or all lose. I’m just another guy on the forums but I urge you and other talented key players to hang in there and help everyone win because the alternative is a huge loss. Remember, this is an “alpha” release, not a production release :wink:

I’m not quite there yet and I can change platforms at any time but my hope is that ezlo will prevail and deliver their federated-controller platform that embraces and empowers the developers here who will continue to extend and add value on top. It won’t be without pain but currently, there isn’t a pain-free solution on the market. Just my two cents.



That’s what we are working towards! Thank you for your understanding Bruce!

3 posts were merged into an existing topic: openLuup & (not) vera

Hi, @Ioana,

I cannot get into the API tool. The logon does nothing, so I thought maybe I need to try to recreate my account, but that just hangs after clicking ok.

Cheers Rene

@reneboer we’re looking into this. Thank you for reporting it.

hi @Ioana,

Any updates? ETA? I still cannot get it working.

Cheers Rene

Hi @reneboer, days ago we did some updates and was offline, but now the tool should be up and running, I just tested and is ok. Please let me know if you still are facing issues to fix them as soon as possible. Best regards!

I just gave it a shot and it effectively hangs trying to log in… I’m using my portal password.

Hi @sroa,

The problem is that same as I reported 19 days ago. The problem started when you changed the login as before it asked for the controller serial. Now it seems to do a query for that and this fails.

When i logon with my account credentials that give me access for all my controllers (Linux and Vera) nothing seems to happen, but if I look in the console out put I see the message “You do not have any Ezlo hub with the required communication protocol (WebSocket) to use this tool”. To me the message is incorrect as I do access the Linux controller with this account.

When I try to create an account also nothing happens and this is what I get in the console.

Cheers Rene

O, and when i try to login with the account I just tried to create (who knows, the backend may have worked). Also nothing on the web page, but this in the console:

Thank you for the feedback, we will investigate those issues and once fixed I will let you know.

Hi @reneboer and @blacey, we detected that the new login page was working only with Ezlo hardware, as soon as we fix the issue to getting it working with Edge controllers running Linux FW I will let you know, in the meantime, the login page has been changed to the previous version.

Thanks @sroa,

I feared it was something like that.

I like the API as it offers the best device exclude option of all. The controllers should have that in their GUI. A button to start the exclusion process. Sourly missed on the Vera. Also, the soft reset on the Linux Edge wipes the whole configuration so you must exclude the devices you had before including again. Good it is just a test setup for me.

Cheers Rene

1 Like

yes that was my issue with the app initially, I got it put there…under Device and “trash can”…
it starts the exclusion process as soon as you press it.(if thats what you mean).