PowerMax to Vera Plus Connection Issue

I am trying to get my new Vera Plus to communicate with my Visonic PowerMaxPro console. I purchased and installed a Dual RS232 Adapter Kit from EuroX-10. I’ve connected the ethernet-to-serial adapter from EuroX-10 to the serial-to-usb adapter they provided and then connected the ethernet from the Dual RS232 module to the adapters and a USB cable (also verified) to my Vera Plus. I then hard-cycled power on my PowerMaxPro (power cable and battery), which is supposed to register what’s connected to the RS232 to the PowerMaxPro. I’ve installed Vera the Vera Visonic App. within Vera. After installation I get a script that says
Config Start
Config waiting for app data for app: 1028
Config found app data
Config data was not found. Waiting for it…

It stalled at this point forever. When I go back to the My Apps and select Powermax Alarm Panel I get a screen with a menu bar that has:
Event Log Settings Zones Devices Back

Below the menu is a message in red :Lua Startup Failure Can’t Detect Device

So I went into Settings: Communicating with UART and selected #6 ftdi)sio . There is no button to save this setting and if I hit the Back button I am back out of the Visonic App. When I go to the Visonic App under My Apps and back into Visonic PowerMax Panel, the same menu bar comes up but the red message is now gone.
I have the configuration instructions and they say I should be getting a screen saying “PowerMax Alarm Panel” at the top and a menu bar with
Control Event Log Settings Zones Devices Advanced Logs Notifications listed. I’ve never seen this screen.

Can someone suggest something I can try?

Assume that you’ve setup the Serial Port configuration?

Apps → Develop Apps → Serial Port Configuration

My configuration setting show in the attached screen shot.

In the Powermax ‘Settings’ there is no save button, as with alot of Vera things, just make sure that when you enter a value in a field that you move to another field to have it remembered.

Lastly, make sure that you update the .js file to reflect the port change with recent FW for vera. Load using Apps → Develop Apps → Luup files → Upload, search for forum post in the RFX433 app area which explains why it is necessary. This hasn’t been updated in the app store because the original author I think has moved on.

Good luck.

It worked! At least so far. I was able to connect to a brand new PowerMaxPro panel I have. Contents were very uninteresting since I did not program all my sensors and X10 devices in it. But the serial number shown in Vera agreed with the panel serial number.

Thank you so much for your advice!

After sending this, I tried to connect to my installed panel and I get a “Lua Startup Failure Can’t Detect Device” message. After reading the Visonic App Installation Instructions, I realize that even with the brand new panel I never got the message “Power Max: Reading Panel Settings” nor the PowerMax" Ready for Use" message. However, as I said, Vera had the correct serial number for that panel. Seems like there is still something amiss in the communications. I attempted to follow your advice for the .js file, but I had trouble figuring out how to upload the file. It says to drag and drop the file, but I couldn’t highlight the file in the list and then drag and drop it. I am a serious newbie to Vera obviously! I tried to search the forum for the area you suggested but nothing came up. Was that in the micasaverde user forum? Sorry to be so dense. Your assistance is greatly appreciatled!

After the above, I again tried to upload Powermax.json by first downloading the file then dragging that to the upload box. It seemed to work, but no change in communications with my old panel. I plan to install my new panel and at least partially program it like my old one to see if Vera will then read the panel settings.

This is the update I was referring to.


If you download your existing .js file to your PC and edit using something like Notepad+, editing as described in the posting above and 'Upload the updated .js file that should take you a step further. I would have posted copies of my own .js file, but you can’t do that in this forum it seems (I tried).

Best of luck

Thanks again for your assistance. I went to Develop Apps/Luup files and downloaded D_Powermax.json to my computer. When I clicked on it I got a message that windows could not open the file, so I opted in that dialogue box to select a file to open it with and selected Notepad. In Notepad I got a text version of the file with no line breaks, so very hard to scan for the correct line. I tried searching for “newAjax.Request” and got a “Nothing Found” reply. I tried scanning the text visually, but could not see the line to edit. Before laboriously reading the text, I thought I’d ask if I have the right file and whether I’ve approached editing in Notepad, as you suggested, correctly.

Thanks again.

As an aside, it is a little disturbing to think that Vera firmware changes (which apparently are mandatory) can suddenly make the Visonic App stop working. Should I be worried about that?

Ignore my uninformed question about Notepad. You said Notepad+, not Notepad. I assume you actually mean Notepad++. I found a free copy of that and opened D_Powermax.json using it. I searched for new Ajax.Request and got 0 hits response. In reading through that file I found a call to J_Powermax.js. So I looked further in the Luup files and found that file, which does have the line to be edited in it, which I did dto match the change in the link you provided. I have saved it on my computer as J_PowerMax1.js and I’m not clear as to what to do next.

I think I may have a communication problem with my installed panel. I was able, again, to connect to my brand new panel and it is showing the correct serial number and sensor information agrees. Also, I inadvertently disconnected, then reconnected the phone line and I get a notification about phone line being restored, so that is real-time information being shown.

However, I think I am in what is called “Standard Mode” and there is no handle to change to “Powerlink” mode. Do you think this could be related to the file edit you have recommended? I am still using the unmodified J_PowerMax.js file because I’m not clear how to get it uploaded. Could you also clarify for me, when I do upload it, is that just being uploaded to my panel and should I retain a modified copy on my computer in case I need to re-upload it?

In looking at the MiOS Visonic PowerMax plugin for Vera file I see that the latest version of the plugin is shown as being compatible with UI6 and I think we are currently on UI7? This may relate to the comment you made about the support person who was keeping this plugin updated having moved on. While I still would very much like to make this plugin work for my PowerMax Pro panel, if it looks like, in the future, every UI update by Vera may introduce some new kink in the operation of this interface, then I have to wonder if it is worth proceeding. Your thoughts on this would be much appreciated. Perhaps the moderator for this site could weigh in on this inquiry.

Thanks for all of your assistance.

You’re right I meant Notepad++

The .js file is the right one to edit. When you upload it, it is to Vera. I keep copies of all files I have downloaded for editing so that I can revert if required (good practice).

With regards to the Vera firmware, that s just life and development of the platform. This specific change to communication port didn’t just impact this app, there were a number, all of which applying this change got them working again. I rely on the community to work through these issues and find fixes.

The apps allows you to set the Powerlink mode as opposed to Standard.

Best of luck

Sorry for my slowness on this thread – other priorities have inserted themselves. I have my Vera and PowerMaxPro talking. The panel shows up in my devices. However, it is in standard mode and I can’t seem to figure out how to get it into Powerlink mode. Do I need to have a Powerlink module installed in my PowerMaxPro for that to work? I am currently using the RS232 interface. If I do need the module, do I need to connect to the Powerlink module, rather than the serial link?


I’ve tried everything I can think of to get my PowerMaxPro to show up in Powerlink mode and to be fully interactive. In the interest of being sure the Powermax panel did not have a previous powerlink registered, I reset the panel to factory default, then registered one sensor to make the panel happy. When I did that, LAN settings did not show up in panel’s Installer mode, as the manual says it should be if a powerlink is not installed. I then went carefully through the Installation Configuring for first use instructions. When the plugin starts up I do not get the message “Reading panel settings”. However, I had set up an alert to send me a text and email when the panel status changes and I did get those messages. When I go into Devices, the panel shows up. Under Alarm Area it correctly shows it as Disarmed. However, if I click on Arm Away the green rotating wheel shows up and spins for a while, but nothing happens on the panel. Under the Alarm Panel section it shows Powermax Alarm Panel, then PowerMax Pro Part Mode Powerlink (so Vera thinks it is in Powerlink mode it would seem). Under Door and Window Sensor it correctly shows the one sensor I have set up. When I go to Settings/Control, once I enter an access code I can get the panel to arm and disarm. So it looks like standard mode may be working as it should. When I go into Settings (on the screen with the menu of “Event Log Settings Zones Devices Back”), under Powerlink options all of the Off and On choices are greyed out and do not respond to mouse clicks. It appear something is just not quite right, but I’m at my wits end.

Anybody got an idea to try?

I forgot to mention that I edited the Powerlink.js file as recommended and I uploaded it after reloading the Visonic App.

I went back and checked my panel settings and as you say some of them are greyed out (see attachment) but for me at least they don’t stop the alarm working and being controlled by Vera correctly. Not sure what else I can add, sorry for that. I will add that I don’t have a powerlink installed and the alarm panel is controlled via the RS232 interface as shown in the setting (attached).

Just in case I’ve attached a full set of the app modules from my setup, in case you want to give that a go also (make sure you make a backup copy of what you have already before trying!!)

Thanks for the app files. I will try them when I get the chance (and back up everything first, as you suggest). I’m wondering about something else I’ve read in past posts from you. You mentioned some time ago about downgrading to firmware version .3015 to fix PowerMax (and other app) problems. Are you still running that firmware version? It seems possible to me that since Vera has stopped supporting the Visonic plug-in, perhaps their newer firmware versions have changes that are incompatible with the Visonic plugin. Appreciate your advice and help!

There was an issue with the firmware which resulted in the port change impacting certain apps. At the time I downgraded the firmware as you say, but also change the app code to get round the issue. I’ve since caught up on firmware and am running 1.7.3501 with the app files I provided and it remains working.

Thanks for that info, it’s very encouraging! I have not had time yet to try your files, but I did capture them and downloaded all of my similar files for backup. Will try when time allows.

I tried uploading your app files. One time I actually got the message “Reading panel data” and after that, for the first time, under devices it showed Mode: Powerlink. Under zones it showed the one zone I had set up and it had read the panel serial number correctly. However, the display was still standard, not the Powerlink mode displays like it shows int he setup file. After getting that working with the PowerMax Pro panel in my office near my Vera Plus, I moved the PowerMax panel upstairs to where I normally have it installed, replacing my old one. Since moving it up there I have not been able to repeat that success. In fact, under devices it now says Mode: Unknown. I get Vera SMS and email notifications saying that the PowerMax panel is responding again and that it is reliably connected. But now under zones it doesn’t even show the zone I have set up and it doesn’t read the serial number either.

Is it important to use the correct version of ethernet cabling/wiring (e.g. crossover, straight, rollover) and if so, which should be used to make the connection from my Dual RS232 module to my ethernet-to-serial-to-USB converter? I have straight through now.

I was never able to get communication to the panel going with the serial to usb converter I got from EuroX10. I got a prolific unit and that is the one I’ve had any success with. However, I’m concerned that it may not have an FTDI chipset. I’ve ordered a USB2920 unit that has an FTDI chipset to try out. Won’t have it until late next week.

It seems to me I may have a hardware problem either with my Vera Plus, my Dual RS232 module my serial to USB converter or with my PowerMax Pro panel, which is brand new.

The only software problem I can fathom being the problem, since I’ve uploaded all of you app files, is that I’m running firmware version 1.7.3532, whereas you are using 1.7.3501 I believe. Could that be the problem?

I’m on firmware 1.7.3501.

It sounds like there is a connection issue which might be down to a number of different things, cabling or possibly the connection, which means I’m a little in the dark. The fact that you’re sometimes getting some form of message indicates that.

I agree it seems like that is the problem. I verified the ethernet cable from upstairs where my Visonic panel is usually mounted to where it exits in my office using an ethernet cable checker. I even included the cable from the wall to the ethernet-to-serial adapter. So if it is a connection problem, it is either the ethernet-to-serial adapter (just a hardware adapter, so unlikely I think), the serial-to-usb converter, or the Dual RS232 module. Everything else has been verified. I thought it possibly could be noise induced in the long ethernet cable from upstairs to down, but I brought the panel back down to my office and it is still unresponsive. I think something in the communication link has now failed because I don’t get even as much response now as I have in the past. I will probably wait until I get the new serial-USB converter as my next step. If that doesn’t do it, then ordering a new Dual RS232 module would be the next step. However…

I have been having another communication problem with my Vera. I have a GoControl Smart Plug-in for Appliances, which I have successfully paired with my Vera, but within a day after pairing, I start getting “Can’t detect device” messages from Vera. I contacted customer support and they recommended unpairing the device, then resetting it to factory defaults and repairing it. All of that went well, except, within a day or so I started getting the “Cant detect device” messages. I’m wondering if I might have a defective Vera. Any thoughts?

Hello isablend
I’ve finally had some luck. First, using the same RS232 module and USB-to-serial-to-ethernet signal chain I’ve been using with Vera, I connected my new PowerMax Pro panel to my computer and was able to get it to communicate with the Powermaster software, which brought up all of the Powermax settings. Based on this, I was convinced that the problem was not in the communication link. My next piece of luck was getting in touch with a Vera tech who was somewhat Visonic conversant apparently. He initially fixed my communication problem with my GoControl switch and I have not had any recurrence of the “Can’t detect device” messages that had previously plagued me. He then showed me how to “Reload Engine” under the Z-Wave settings. Doing that causes the Vera app to read the panel settings and to come up with all of my sensor and device settings but, unfortunately, in standard mode, not Powerlink mode. I have tried uploading all of your app files and then reloading the engine, but it still comes up in standard mode.

The technician thought Powerlink mode was only available with UI5. I thought you had told me you are running UI7 and that your PowerMax panel comes up in Powerlink mode with screens that look like those in the setup guide. Is that correct? Do you have any insights as to why I’m still not going into Powerlink mode? The technician offered further assistance. If I am able to tell him, with certainty, that you are running UI7 and are in Powerlink mode that would be helpful (but only if that is, indeed the case!). Thanks again for all your help.