Philips Hue Firmware 24th Feb Breaks Plugin

Following a Hue Bridge firmware upgrade on the 24th Feb all of my Hue bulbs have vanished from my Vera configuration, not just from the UI. I ran the Device List code and every Hue device has gone.

The Bridges are still there, but now when you press the On for the Bridge device in Vera it seems to send an All Lights On command to the Bridge.

I have tried to restore a backup from before the 24th but the devices are still missing.

Any ideas anyone?

1 Like

Same thing happened to me on the 24th.

I installed the AltHue plugin instead and changed the devices IDs of the “new” Hue bulbs that were added into Vera with the device ID numbers of what the bulbs were previously.

Luckily I was able to look up their original ID numbers in the Imperihome app.

This meant I didn’t need to reconfigure all my PLEG logic or the Java HA Bridge software.

However any native Vera scenes that included the Hue bulbs I had to configure again as the Hue devices were just missing from those scenes.


Sounds like the whole issue is due to the Philips/Signify name change…
If someone can can fix it with such a minor edit on the user side it makes me wonder why there’s no update for it.

Thanks for this ‘workaround’. I will take a look at this later today. My concern is that unless the PlugIn is modified at source, each time there is a Hue firmware upgrade will the Hue bulbs vanish again and another few hours spent fixing it.

Yeah, I haven’t tried it out myself. considering moving to ALTHue now that I need to put work into getting it working anyways

I downloaded the D_PhilipsHue2.xml file and edited the Manufacturer from Philips to Signify. I unplugged the Hue bridges so Vera did not see them, then restored a backup from the 23rd. I then uploaded the edited xml file. When the Luup engine restarted I git the “Please wait, configuring z-wave devices” and then the hue lights vanished again :frowning:

There must be some other file that is used that I missed. At the moment though this does not seem to work.

There might be some further explanation in this thread (same thread the quote was from): Release Notes - UI7 - Vera Firmware Update - v.7.0.31 (1.7.4954/1.7.4955/1.7.4956) - February 19th, 2020

I couldn’t figure out how to edit the Philips Hue 2 plugin file(s).

However in the AltHue GUI under Hue Devices, the manufacturer name is listed as:

Signify Netherlands B.V.

I changed the xml file to include Signify Netherlands B.V. as the manufacturer and for a moment I thought that had fixed it - then Vera did a reload and starting configuring devices and then they were gone (again). I have even tried deleting the whole ‘manufacturer’ name and no luck.

I spoke to Vera support and they are receiving a lot of calls about the Hue bulbs vanishing since the hub firmware update. They are looking for a fix.

Unless someone much more clever than I can figure this, I’ll have to wait.

cough… ALTHUE… cough… cough


Well… I gave up and switched to AltHue plugin. Although I have to adapt several scenes. Which is for me also a good reason to use Reactor for this in stead of the limited scene capabilities of Vera.
Again an example that we luckily have a bunch of very capable external plugin writers. Much more capable and quicker than Vera team (sorry to say so…). @amg0 and @rigpapa igpapa thanks again for you excellent plugins!


Yes. My Hue Bridge firmware upgrade failed on 24-Feb.

Thanks for the recommendations everyone. Sounds like ALTHUE or Reactor are options.
I am not terribly impressed with Philips Hue. The scenes are very limited.

I will not loose more time to check the old plugin and start with AltHue. If you are able to maintain the devices and want to preserve scenes (to some degree, since AltHue is using standard actions, while the official one goes for proprietary ones…) you can

  • restore a backup
  • remove the embedded flag from the child devices (this should prevent a delete) before they get deleted
  • install AltHue
  • run a discovery
  • swap device ID, as previously shown

This will preserve scenes. If you are able to start from scratch, just do it and never look back. AltHue is very well maintained and it’s working with standard actions, so 100% compatible with mobile apps.

EDIT: and I wish it was possible for the community to flag a plug-in as not working and have the AppStore reflect this, to prevent new users not accessing the forum from installing non-working things and get frustrated. There’s a long list of scenarios like this…


Agreed. I also dumped the old Plugin yesterday and installed AltHue due to that all my bulbs were deleted. I will not look back.

1 Like

Bit the bullet and moved over to AltHue - creating a second device as I need two Hue Bridges. It took a press of the button on the Hue Bridges and a couple of Engine Reloads to get things working, but all devices in and working and added back into the scenes.

1 Like

Cheers, I just used the AltHue plugin to restore my 3 Hue lights - even that was painful so Im glad I only had 3!

1 Like

I have also installed AltHue a while ago and my devices are shown again.
But I can’t find any coloreffects like colorloop etc.

Is this still possible in AltHue?

Yes use the “SetEffect” option “newEffect” = colorloop

Ok many thanks.

As soon as my Vera is working again ( I updated to the latest firmware and can’t connect to Vera at all anymore) I will try this. Do you happen to know if it is also possible to adjust the colorloop speed?

I am not aware that can be done no.