No ZWAVE Dongle detected in Mios

Funny I dont have a dongle with the Vera2 and now I cant control squat or add any devices There is a Red box in the corner of Mios that states “No ZWave Dongle”

I have tried unplugging and re-powering the Vera but still get the same message.

What version of the software are you running? There was a bug where the firmware for the dongle wouldn’t always get flashed with earlier versions

Check the version in the firmware tab under Advanced and you need to make sure you have 1.1.1047. If not then visit from a PC located on the same LAN that your vera is located on and do the update! That may get you up and running!

I check the firmware and it is running 1.1.1047

If you click the Z-wave Icon at the top of the dashboard and then go to the options tab, do you see /dev/tts/1 listed for the port?

Also have you git anything else plugged into the USB ports like serial devices or Insteon adapters etc?

yes it’s listed, and there isn’t anything plugged into the Vera2 except the correct power cord and the ethernet cable to Ethernet1

It might be a while until you get somebody coming back to you from support but you could try to make a back up (unless you already have one) and either reset to defaults and see if the no wave error goes away, if it does it would be interesting to see if restoring your backup then breaks it again! The other option is force load the 1.1.1047 firmware from the URL in the hope that it will re-flash the wave internal dongle.

I will try to do the back up and see what happends. Worst case how do I force load…Thanks for all your help!

I have the same problem with my Vera 1, this has happened twice in one week. I can’t correct the problem using remote access. I need to unplug it in order to recover from the error.

Edit: Has anyone sent in a ticket yet?

[quote=“boomer135, post:7, topic:166563”]I will try to do the back up and see what happends. Worst case how do I force load…Thanks for all your help![/quote]You can force the load through the firmware tab in Advanced by copying and pasting the following URL into the “URL for MiOS custom firmware” dialog box.

@JimMac your problem is different, so do not try this! How old is your V1 and did you ever try the firmware update on the dongle? There was a known issue where it would lock up quite frequently for some users.

Yes I sent in a ticket and I also tried to repower the unit several times. I will reset it when i get home and do it all over again if I have to.

Well I am home. I backed up my previous settings, and set back to factory defaults. I went through all the zwave components and unpaired them all and then added them.

The system is working again, but I dont want to load up the back up, I’ll just start from scratch with scenes and such…

Funny thing is even though the system is connected the Ethernet1 light wont illuminate again.


My dongle was updated and everything was running fine until UI4. My Vera 2 arrived today so I will be testing it out next week.

@JimMac, good luck, hopefully your new Vera will solve your issue!

Same issue here. I’ve been able to reproduce it twice now. Seems to be associated with using the portable power supply on the Vera2. It might not be holding a charge, not sure. In either event, if I unplug the Vera2 (Eth1 and Power) then plug in the battery pack, it lights up for about 2 mins then it goes completely lights out.

When I replace the eth1 and regular power, it always shows “No Zwave Dongle” message. Hard rebooting does not clear the problem, only reinstalling the firmware from the previously posted URL, combined with factory reset option. As a result, scenes and setting are lost. :cry:

I also noticed the same message once when plugging the eth1 into a wireless switch port, but a reboot fixed it. In any event, I’m reinstalling for the third time. I’m wondering if buying a USB Zwave dongle might be the solution for discovering new devices??

Thanks in advance for anyone’s assistance on this.

@ccordray, This sounds like something you should stick a trouble ticket in for, as it sounds like you have a faulty Vera if this is regularly reproducible! Have you tried making a backup when everything is working fine, and then restoring the backup to see if it recovers it when this happens?

One of my Friends has a similar problem where his Vera will not come up on the battery unless he switches the battery over while the Ethernet is still connected, once its booted, he removes the Ethernet.
In his case a power cycle was always enough to restore it and we never saw the no Zwave error message!
Doing the above might prevent you getting the problem?..Eitherway you should get MCV to look into it and either try to fix it or replace your box.

I’ve had the same problem tonight as the one described by ccordray. Everything was fine until I tried the portable power supply and then things went south. I’ll try a backup, URL flash, and restore the backup in the morning. I’ll also try to just carry the power cord around with me from place to place and remember to disconnect the ethernet cable last. Sort of a major pain right now.

Same problem for days. I submitted ticket. Tech support working on mine. They’re reviewing logs. I’ll let you know status when I find out something.

Lescombs, any update, was tech suport able to solve this ?

Having the same issue, so looking for the steps to fix!


yep. Mios is now showing no zwave dongle.

Show Stopper.

I have the same problem - No ZWave Dongle showing in status window. Nothing to do with the battery pack as I have not even charged it yet. Just familiarising myself with Vera2 (using UI4 1.1.1047).

Support ticket submitted.