Netatmo Weather Station plugin

Thanks for the fix, after updating to the latest the reoccuring downloqd issue is gone.

Thanks for this Great plugin.

Any way i can change the frequency of update? I know the netatmo sever is updated every 5 mins but in the app i am updating only every 10 mins. When i change in the parent device’s variable page it defaults back to 10.

Also the SensorRain value is always zero but SensorSunRain1 works and has value here. Just thinking loud if the value is ZERO because it done not have 0.000 (three decimals) store value.

its super cool to have it control my awnings with wind speeds, rain and temperature.

Quoating the Netatmo API documentation:

" Keep in mind that data are measured every 5 minutes by the modules and sent to the servers every 10 minutes ."

https://dev.netatmo.com/apidocumentation/weather

1 Like

Thanks for your reply. my sincere apologies for double posting this question under this thread and starting a new thread. Posting a link to the new thread question and answer here to consolidate the answer - both answers are exactly the same.

1 Like

I’m not sure if this was an App update or just because my Netatmo lost power for an hour last night, but all my Netatmo child devices just lost their id’s and Room setting and all re-spawned with new ID’s and no Room breaking all my reactor sensors that relied on them. :frowning:

Anyone else have this issue?

PS, @akbooer any chance you could update the Plugin logic to prevent existing devices from being replaced like this?

1 Like

Cheers, I didnt realise that the data was in the main device. :nerd_face:

This has been asked before and many months ago, to no response

The latest update means it’s no longer an issue.

1 Like

Just update via the app or manual update?

Indeed, see:

So this…

… is incorrect.

Just use the Plugins page to update to the latest development version.

My mistake I must of missed this communication , apology. I don’t see any option to do this from the Vera plugin page? Or perhaps the below is already the patched version?

No, the latest is 20.511, available for manual install from GitHub or the AltAppStore.

I’ve generally given up on the MiOS App Store since it’s so difficult (yes, really) to update files there, but I will give it a go.

I have attempted to update using altui and manually by got hub then rebooted but still showing old version

Not sure how you tried to update, but the only file which does need changing is the L_Netatmo.lua file.

IIRC, you need just to upload this using the Vera Luup files page and restart.

I have uploaded the one file but still shows older version

OK, I’ll see about updating the MiOS App Store.

1 Like

The new version (v20.511) is awaiting approval by Vera.

2 Likes

have updated to latest version, but can’t get the station to be recognised by my Vera Edge. I’ve been through the procedure with Netatmo and all the variable seem right, but get “Cant detect device” error and also Netatmo[374] : Startup Lua Failed" in the blue bar. I’m trying to migrate from the official app, which was working

Sorry to hear this. Actually, I don’t think that the very leatest version is actually released in the App Store yet. However, the old one should work. What version do you think you have?

A few things to check (although it sounds as though you have)

  • Username and Password variables set
  • ClientID and ClientSecret set (the right way round!)
  • Application enabled in the Netatmo web site

Also, for recent Vera firmware, you may need some security settings set correctly… no idea what or how, since I don’t run the latest Vera firmware.

Failing that, a section of the log after Vera restart showing any relevant error messages may help.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules