Neo Coolcam motion sensor: cannot change variables

I am trying to add a Neo Coolcam motion sensor https://www.robbshop.nl/motion-sensor-z-wave-plus-neo-coolcam
to my Vera Edge, but it appears to be a big struggle…
As this particular sensor is not in the Devices list, I selected Dome Motion Detector with Light Sensor DMMS1 , as it looks exactly the same in the inclusion process.
It comes up with 4 new devices. I added a notification and Vera Alert to check the operation, it works.
But the point is that it is far too sensitive in detecting motion, thus not usable for proper detection.
The leaflet in the box tells me to change parameter 1: set to a value between 8 and 255 (= lowest sensitivity).
I tried that in this way:
Device–>Advanced–>New Service
and put in the values:
New service: 1
variable :1
value : 255

But nothing seems to change in the sensitivity.
I tried to modify another parameter (interval between detections) in this same way, but there also nothing changes in the behavior.

What is the correct way to modify these variables ?
Or did I select the wrong device to start with ?

The device needs to wake up.
I usually find that after 24 hours it settles down.

Thnx, that seems to be the case…
I have tried to wake up the device by pushing the button , and by taking out and putting back the battery.
At some point in time it woke up, not exactly clear what has triggered that.

Other issue is that it is not really clear what these 3 things in UI7 mean:
New service
variable
value

Is the variable the parameter that needs to be changed, or should that be New service ?
So I used AltUI to modify the parameters, it is much more clear how to do that, and it also shows the result (current and new situation and history of changes).
In UI7 I cannot find that information…

You are confusing “Z-Wave Device Parameters” with “Vera Device Variables”.

The former is what you want to change, as they determine how the device operates. The latter, along with “Vera Device Parameters”, is what the Vera uses to store information about the device.

The Device/Advanced tab shows, and allows modification of “Vera Device Parameters” and “Vera Device Variables”… This is NOT what you want.

You want to go to the “Device Options” tab, and a a “Configuration setting”…

For your specificly mentioned change:

Select “Device Options”, click on “Add Configuration setting”. Set “Variable” to “1”. Set “data size” to “1 byte dec”, set “desired value” to “255”. click on “save changes”.

Then reload the LuaUPnP engine. Wait for the LuaUPnP to finish loading. Refresh your browser.

The, if the device is battery powered (which most motion sensors are), you need to wake the device… You can usually do this just by triggering the device (IE: walk in front of a motion sensor, or open and close the door/window for a door/window sensor). Alternately, opening the device cover, so that the tamper switch is tripped will also wake the device.

[quote=“cybrmage, post:4, topic:197628”]…
You want to go to the “Device Options” tab, and a a “Configuration setting”…
For your specificly mentioned change:
Select “Device Options”, click on “Add Configuration setting”. Set “Variable” to “1”. Set “data size” to “1 byte dec”, set “desired value” to “255”. click on “save changes”.
…[/quote]
Strange thing is, in the “Device Options”, I see “N/A”
so there is nothing I can do there…

If you see N/A, you are looking at a child device… Only the parent (main or primary) device will have the device options. Even though the primary advertised function is “Motion sensor”, the “Motion sensor” device may not be the primary device.

That is also what I expected, as I have 4 devices:

  • Parent (?) device, but this one has no tab “Device options”
  • Light sensor
  • Motion sensor
  • Temp sensor

When I look into the parent device with AltUI, I see a lot more options, and it also gives me the possibility to set new parameters.
See attached.
So I was able to solve it within AltUI, but remain puzzled by UI7.

Since it looks like you’ve gotten further then did, any idea it how log i need to wait for “Waiting for wakeup to configure device…”?
It still only shows one device. I’ve tried pressing the button which the manual says sends a wakeup call. I also removed the battery.
Thanks

I figured it out. I have my hub 2 feet away from me while I configure new devices. I had no problem with it detecting the motion sensor, it would just never leave the waiting to wakeup state.
What fixed it was pressing the button on the sensor while holding it directly on top of the hub. I cant believe 2ft made the difference, but all 3 sensors configed immediately this way.
I hope this helps someone else that runs into the same problem.

Mark

I have this same sensor, I don’t think mine has a temperature sensor in it .
My problem is I can’t get the light sensor to register properly like a proper value of lux light level in the room .

Hello,

I also have this device (just got it), and it seems I see 3 devices:

  1. Main one
  2. Motion sensor
  3. Light sensor

I can’t see any temperature sensor.

Do I need to configure anything ?

Thanks,
Nir

the new one has not temp sensor.
I’m not sure for the US one, but that’s true for the new EU one.

Thanks , anything I need to configure in terms of Vera since I am not sure the light sensor is working as it shows the same number all the time.

Thanks,
Nir Gal

I just bought one of these Neo Coolcam motion sensors the version 2 one that has a Temperature sensor on it.

I also added it to Vera as the “Dome Motion Detector with Light Sensor DMMS1” device. I now have four new devices in Vera see screen shot.

In Vera I associated my Kitchen Main Light device to the motion sensor in Association Group 2.

The LUX level does change in Vera OK in dark / light etc.

However the light turns on in the daytime.

The user manual I found here

Parameter 5: Ambient illumination Lux Level
This parameter can be set a lux level value which determines when light sensor is activated. If the ambient illumination level falls below this value, and a person moves across or stands within the detected area , PIR detector will send a Z-Wave ON command(i.e. BASIC_SET value = parameter 3#) to an associated device and activate it.
Size: 2 Byte, Default Value: 100

However when the LUX level is well over 100 the light still turns on. I would expect the light to only turn on when the LUX level drops below 100.

I then manually set parameter #5 to a value of 50 but the light still turns on when the current LUX value is over 50.

So not sure what’s happening?

EDIT: Had to set parameter #8 to a value of 1 and now it seems to be working.

[b]Parameter 8: Lux Level Function Enable
If this parameter is set to ?1?, and when Lux level is less than the value defined by parameter #5, PIR sensor will send a BASIC_SET command frame(i.e. BASIC_SET (value = parameter 3) to an associated device and activate it. If Lux Level is greater than the value defined by parameter #5, PIR sensor will not send a BASIC_SET command frame.

Size: 1 Byte, Default Value: 0
[/b]

Everything is working with this Neo Coolcam v2 motion sensor apart from in Vera very often the temperature sensor says 0.00 degrees.

Some times for a while it does show a temperature reading OK but a lot of the time when I look its 0.00

The supplied user manual leaflet makes no mention of any device parameter settings to do with the temperature sensor portion of the device.

Anyone else also had this problem ?

The Lux on the other hand is updating in Vera perfectly fine.

Thanks

I’ve also attached my current parameter settings and how this device looks in the Imperihome app.

I contacted support and they showed me a way to manually change the implementation files and the category of the main parent device, to change it from being a Generic IO device to being a Motion Sensor device.

The child motion sensor device is then hidden from the GUI as its not needed.

On the parent device, the one with the on/off button and the battery status, go to Advanced and then in to the Params tab. Change the following items.

  1. device_type from urn:schemas-micasaverde-com:device:GenericIO:1 to urn:schemas-micasaverde-com:device:MotionSensor:1

  2. device_file from D_GenericIO1.xml to D_MotionSensor1.xml

  3. category_num from 11 to 4

  4. subcategory_num from 0 to 3

  5. device_json from D_GenericIO1.json to D_MotionSensor1.json

You’ll need to edit any existing Vera scenes or PLEG logic to point to the parent device instead of the child one. Also you will need to check the Vera Dashboard - Configure My Preset Modes - Choose sensors to arm, area to ensure the arm / disarm modes are set correctly for the parent device, for the child device I set them all to disarm and then I hid the device.

To then hide the child motion sensor device from the Vera web GUI go to Apps - Develop Apps - Edit Startup Lua and add a line of code, where the device number (100) is that of the child motion sensor device.

luup.attr_set(“invisible”,“1”,100)

I now have the battery status showing on the motion sensor device in the Imperihome app as a result of the changes. I had to remove my initial dashboard widget and select the parent device instead to add a new widget again.

If you look at my previous Imperihome screen shot on the previous forum page you will notice when I initially added the child motion sensor device there was no battery status showing in the app for that device. On this new screen shot the battery status is now present as I am using the modified parent motion sensor device on the Imperihome dashboard page instead.

Attached are my current parameter settings for this Neo Coolcam motion sensor device.

Parameter number 10 with 1 byte dec and a value of 0 is meant to turn off the red light on the sensor when motion is detected.

I have set this however the red light still comes on, anyone else confirm this also ?

Thanks

10.​ ​Led​ ​Blink​ ​Enable This​ ​parameter​ ​defines​ ​the​ ​Led​ ​on/off​ ​enable.​ ​If​ ​this​ ​parameter​ ​is​ ​set​ ​to​ ​’1’,​ ​the​ ​led​ ​blink will​ ​be​ ​enabled,​ ​the​ ​led​ ​will​ ​blink​ ​once​ ​when​ ​motion​ ​sensor​ ​detect​ ​a​ ​movement. Otherwise,​ ​the​ ​led​ ​will​ ​be​ ​turned​ ​off​ ​always. Function:​ ​​Led​ ​Blink​ ​Enable Parameter​ ​Number:​ ​​10 Parameter​ ​Size:​ ​​1​ ​Byte
Available​ ​Settings​:​ ​0,​ ​1

Also worth noting you don’t need to add / pair this Neo Coolcam motion sensor device to Vera by selecting the “Dome Motion Detector with Light Sensor DMMS1” device.

You can just add it as a Generic Z-Wave device as it makes no difference.

Either way you need to modify the parent device as I described earlier.

Excellent info! Thanks! Any idea what the different settings mean?! I know 10 is for turning the LED off, which works flawlessly, the rest is in the documentation but doesn’t seem to be accurate… 1 seems to be for the sensitivity of the PIR, but when I add it and change it to 3 instead of 2 it gives an error, according to the manual it should be between 1 and 4, current setting shows 12… :confused:

All the parameter settings are covered in the user manual. I have parameter number 1 set to a value of 22 for the motion sensitivity, see my screen shot above.

Parameter number 10 didn’t seem to work for me and turn the red light off, I will try it again.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules