MiOS new plugin framework and documentation

Hello @ibrewster

I see that you currently have a Support account created, would it be ok if we try to access de controller to gather some logs?

Go for it! :slight_smile: You should have the date/time from the screenshots, but let me know if you need me to try anything out to get new/different logs.

1 Like

Hi there @ibrewster

I believe some of the devices have been removed, however, some are still there, I couldn’t retrieve the logs, I’m trying to replicate the scenario to escalate the case.

Let us know if you encounter something similar or if it repeats again after uninstalling a plugin.

It looks like the devices created by the ezlo_protocols plugin have now been removed, yes. The other two shown in the screenshot were virtual devices I created via the API, so I wouldn’t have expected them to go anywhere :slight_smile:

Is the removal of the three ezlo_protocols devices due to something you guys did, or did it just take some time for the removal to show up in the Ezlogic web interface?

I can try installing and deleting the plugin again, if that would help…

Basically, I reinstalled the ezlo_protocols plugin and then try to manage it, here:

And then there’s a button that says uninstall (In the image it no longer appears)


Then the devices should be removed.

Sure, and that works fine. The point here though was that just clicking “delete” without first uninstalling left orphaned devices, making it necessary to go through the re-install/uninstall/delete procedure you just described to remove the devices. This in spite of the statement that:

Unless we are getting confused about “uninstall the plugin” vs “delete”?

Going into manage plugins and clicking the “uninstall” button works as expected. What @Marvin.Miller apparently got confused about (and me as well) was the behavior that occurs when you simply delete the plugin without first uninstalling it from any devices.

1 Like

If a installed plugin was interlocked so it could not be deleted without going through the uninstall first this would not happen, leaving orphaned files that can’t be uninstalled without a reinstall first to resequence the operation.
Changing the plugin “Delete” to a interlocked Uninstall “if installed” else a “Delete” button would stop this from happening.


Yes I noticed this after I wrote the reply. I will add it as a task to our list. Thanks

1 Like

Hi, trying to install a plugin from the marketplace, still no luck, any news?

I can copy to my Ezlo but nothing happens clicking on install button.

Previous, I installed several test_switch from api_tools, do I need to remove them before to use the new PLUGINS?

or new plugin files will be installed in the same folder and overwrite the old files?

thanks in advance

I had actually just checked on that earlier today, and saw the same thing: copy to my Ezlo now (appears to ) work properly, in that the name, description etc now show up, which is more than it was before, but clicking install still does nothing. I guess it’s still a work-in-progress :man_shrugging:

Hello @lord55 @ibrewster
We are checking this issue on our side. We’ll let you know when the issue is fixed.

1 Like

Hi @ibrewster , @cw-kid the install issue still continues, meanwhile we introduced check on uninstall to remove all devices.


Thanks for that. Shame the install issue continues (for now), since I now see a DSC plugin listed in the market place that I would LOVE to install and try out… :grin:

1 Like

I also see WOL (Wake on Lan) plugin…but they are not officially launched yet…(but of course you can play with them)…

Ping Sensor plugin is coming shortly as well…

Yeah, so that sort of worked. Upload and install allowed me to successfully install it on my Ezlo Plus (so that trick still works, apparently), however with the DSC plugin at least I didn’t see any devices created, so no way to configure it. As @melih said, though, it is not officially launched yet so maybe it just isn’t fully implemented yet.

Is anyone able to install this WOL plugin ? Not working for me.

wol.tar.gz (3.5 KB)

I notice that the WOL and DSC plugins are now gone from the list in the marketplace. Although there are still six copies of the ezlo_protocols plugin listed.

Also, I can’t seem to delete the DSC plugin from my private plugins section now. :stuck_out_tongue:

Your a “BETA” tester welcome to the club !

1 Like

In fact I was a bit cheeky I shouldn’t of posted that .tar.gz file for the DSC plugin likely.

As the boss said they are not fully functional yet.

No worries (at least on my part). I’m happy to test out whatever, and at least in my software development life am pretty good at finding weird bugs! :rofl:

1 Like