Leviton Scene Controller - Why So Hit & Miss?

So I’m just stumped at this point. Today, I installed my second 4-button leviton scene controller. I added it to the network in normal fashion, Vera found it, and then attempted to configure it and the blue cog went on and never stopped. I thought maybe something had just gotten kluged up, so I removed the controller from the network and re-added it. Again, same behavior. So then I figured it was because I hadn’t assigned any scenes to the buttons yet. I attempted to do that using the old Method #2 (because apparently under 979, there really aren’t two methods anymore, and the only way to assign a scene to this controller is the old method 2 - you can’t just go into advanced settings on the scene controller itself and select a scene to assign to a button). According to what appear to be updated Wiki instructions, the only way to then ensure that the scene is “loaded” into the controller is to do an “Add z-wave Controller” with the scene controller in Program Mode (i.e. leave the dongle plugged into Vera, put controller into program mode, run back to vera, click “Add z-wave Controller” and hope for the best). That doesn’t seem to do anything. I still have 4 useless buttons on my wall.

I’m now wishing the old Method1/Method2 installation was still here - at least I got that to work for me.

Any ideas anyone? Help would be most appreciated.

The WiKi page doesn’t seem to be updated since there is no independent method 1 or 2. I also had a problem getting mine going. I tried the same process as you and finally gave up. The next morning the 4 scene buttons worked… some what. Once added to the network I assigned the buttons a scene but it took a long time before it would work. I even tried adding the device back to the network to see if that would help. Now that the On button(s) work I can’t get the Off or dim/bright buttons to do anything. I will experiment some more this weekend.

On the other hand my Intermatic HA07 work great though some times the remote says “Transmitting” for a long time as the lights either go off or on one by one.

In the more recent Vera (Luup 1.9xx) versions, Method 1 and Method 2 are defunct, they’re no longer needed.

You simply register the ZWave Scene Controller with the Dongle in the usual manner (here’s the snippet from the Wiki):

[i]Most in-wall controllers that are connected to your house's electricity (i.e. not battery operated) can be added like any other Z-Wave device and do not need to be treated like the battery operated controllers[/i]

and then you create a Scene in Vera, with an associated Event that contains the Scene-Controller and Button that you want to “attach” it to.

IMHO, it’s a huge difference from the old Method1/2 setup, and it’s a lot simpler.

Looks like the Leviton Scene Controller Wiki (http://wiki.micasaverde.com/index.php/Leviton_Scene_Controller) is out of date. I have 3x of these in my house , and they’re all working, so it’s really just the Wiki description that’s out of whack.

If I ever modify the Scene definition, I also do a “(Configure node right now)” on the Scene-Controller Device. Dont know if this is needed anymore, but it was referenced in one of the writeups somewhere so I still do it.

OK, so that makes sense. However, I still cannot get the scene controller to work. It adds to Vera just fine - shows up in the list, etc. But it seems it can never be configured. Right now, I have a grey cog next to it. I’ve added events to my scenes, referencing the scene controller and the button number, but it’s just not working. I have another one right next to it, and it’s working just fine. But whenever I press a scene button on the new one, I get a red LED. I’m perplexed.

I’ve removed/re-added a couple times - same result.

guessed: Some of my scene buttons work perfectly (push turns on, dim works, off kills all devices on the scene) but some don’t. I have a couple of scenes on buttons where everything turns on, but only one of three devices on the scenes will dim or turn off. On one of my VRCS4-MR I have all Leviton devices, and on the other it’s a mix of Intermatic and Leviton. They both have the same problem. Any ideas?

No idea. My scene defns are extremely simple. The “real” dimmer switches (all Leviton) are on the other side of the room, so the Scene controllers generally just turn on/off one of these lights “per scene button” to make it more convenient to turn them on (without walking across a dark room).

My understanding is that the Toggle behavior is something native to the Leviton Scene controllers, so not sure if that’ll work in a mixed Leviton-Switch and Vera-Controlled-Switch scene defn.

The only more detailed usage I have is in the master, and it’s an “All Off” scene via Vera.

That said, I have noticed that the controllers can be a little quirky. In particular, the Toggle doesn’t always do that and you might have to press a few times to get it sorted. I haven’t yet worked out if this is because I sometimes start the light from a remote control, not the physical Scene controller.

Hmmm. I have some buttons on the scene controllers that are used for a single device, too, and they are fairly reliable.

The other buttons are, as you so kindly understated it, “a little quirky”. This doesn’t bother ME too much, but my dear wife doesn’t know what to expect when she pushes a button, and certainly doesn’t know how to troubleshoot this stuff. Last week I was in Denver on business and she reported that, due to Vera’s eccentricities, “sometimes I just had to sleep with all the lights on.” Argh.

So FWIW, I think I figured out my issue with the Scene Controller. It turns out that one of the scenes in Vera I was trying to assign to my Leviton Scene Controller was using the “Advanced” feature of a 5-minute delay before execution. It was the only unusual thing I could discern about the scene, so I removed the delay, and voila, the scene controller configured immediately and correctly, and has been working like a charm ever since.

So for anyone who may be using a Vera-specific feature like an event delay, beware. Scene controllers can’t figure out how to handle them.

[quote=“slackner, post:4, topic:165188”]OK, so that makes sense. However, I still cannot get the scene controller to work. It adds to Vera just fine - shows up in the list, etc. But it seems it can never be configured. Right now, I have a grey cog next to it. I’ve added events to my scenes, referencing the scene controller and the button number, but it’s just not working. I have another one right next to it, and it’s working just fine. But whenever I press a scene button on the new one, I get a red LED. I’m perplexed.

I’ve removed/re-added a couple times - same result.[/quote]

there is one major problem with that method. IT is that Vera is actually controlling the that scene. The action takes more time than a direct association with the button and whatever you are trying to control. Besides is Vera is down or flakes out the event/action will not occur. Leviton spent a lot of money( royalties) to create these switches with features like associations it is a waste not to use them.

@zmistro, for Scene-aware ZWave Devices used in a Scene, Vera programs them natively into the ZWave Scene Controller.

Only the Vera-based Devices listed in a Scene items go “through” Vera.

There’s no more delay, and no dependancy upon Vera, if you only use Scene-aware ZWave switches in a Vera Scene.

I even tested this by removing Vera’s dongle and then pressing the Scene controller buttons. My lights go on and off as desired without need for interaction with Vera.

This is the thread that contains some of the background (before it was implemented):

Are you’re seeing this problem in practice, with Scene controllers in your network and these recent Luup builds?

Unfortunately you don’t list the devices you have in your Profile footer.

Interesting… so there’s no advantage to removing them from Vera’s network and then creating an association between the controller and the devices?


so there's no advantage to removing them from Vera's network and then creating an association between the controller and the devices?
...not to my knowledge. Since this functionality is new, it's possible there are bugs, but the basics are working fine for me.

I suspect the other thread, where they had manually inserted a 5-second Delay into their Scene, could be related.

I dont have another ZWave Pri/Sec Controller, only the Vera Dongle, so I couldn’t do anything different even if I wanted to. Luckily I dont need to :wink:

Just as a side note, I had similar problems with no explanation. At first a scene, would react instantaneously with the thermostat, but a 3 - 5 second delay on the lights(leviton plug-ins and switches) and the up/down control switch didn’t work at all. I gave up. The delay corrected itself that night before I went to bed and the up/down control worked the following day and fine since(about a week).

Not that this helps at all, but it is worth noting…

I have two Leviton VRCS4-1L 4 scene controllers and so far I have not been able to get either one working completely. These are the controllers that you press a scene button for on and press again for off as apposed to a rocker switch. The “ON” work every time though there are the delays as the devices in the scene are activated. What I can’t get working is the “OFF” function. I even tried to create a “scene de-activated” scene to see if it would trigger that scene when the OFF button is pressed. No luck there either. Any one else have this model and have actually got it working 100%?

Both of my scene controllers are the Levitons, and they do now work as intended, although as you can see from this topic, it took a while. I can press the button a second time and all the lights in the scene will go off. I can also use the rocker switch at the bottom to dim all the lights in the scene up or down.

What I’ve found is that if you only include basic, scene-capable z-wave devices in your scene, the scene controller works perfectly. As soon as you introduce any Vera-specific functionality, like delays or controlling non-scene-capable devices (like a thermostat), things start to get a little flakey.

Right now, I do have a couple scenes that control my thermostat settings in addition to lighting, and the scene controller is working appropriately for those, even shutting off the lights when I press the scene button a second time. However, in this case, pressing the scene button a second time will not revert the thermostat to its original setting.

So good luck with this. As evident from the title of this topic that I started, it really is hit & miss getting these controllers to work with Vera - I certainly wish it was more bullet-proof. But if your patient, and look carefully at what your trying to do in your scene and then keep it simple, they controllers seems to work fine.

My VCRS4s are not consistent - sometimes all devices work quickly and as expected (hurray!), and sometimes not. Last night I hit the Living Room button the second time and three of the devices started dimming to off right away, but the fourth one stayed on. I just made an unpostable comment under my breath and went to bed. It eventually turned off.

The other VCRS4 has been giving me fits and I plan to do a factory reset on it this evening and try starting from scratch. And then I’ll have to go and edit every scene that has the attached device in it, and all the scenes assigned to its buttons. sigh

Don’t bother with the factory reset exercise as it did me no good. My scenes are simple and include lights only and after a full system rebuild and installing the latest beta software nothing changed. My Intermatic HA07 works fine but this VRCS4-1L has me stumped. Mi Casa Verde any suggestion before I pull out my remaining hair…

Geez, guys. Now you have me nervous. I have one and just ordered 2 more and now I guess I’ll cross my fingers and hope for the best. After mine mysteriously fixed itself it’s been working like a charm.(lighting/thermostat mix & match) If anyone does find any sure fixes, please post so I don’t end up like Rancho & Jim. Obviously, I’ll do the same…

Hi everyone!

We’ve identified the problem and working on fixing this for the next release. I advice all of you which have this problem, send a trouble report from your Vera with logs attached so we can investigate more.

Thephoneguy678: can you remember the date and time when your controller start working fine and send us a trouble report so we can check your logs and see what triggered your success?

Thank you all!

MCV, I’ll see if I can produce a date for you. I have 2 more to install which I’ll work on tonight. Maybe they’ll reveal some secrets as well. I’ll let you know in the trouble report.